MyRogers Site on Chrome is Broken

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resident Expert
Resident Expert
Posts: 3,570

Re: MyRogers Site on Chrome is Broken


@OLDYELLR wrote: The only way I can do it now is using Chrome Incognito.

This means there's an issue with your cookies since incognito bypasses them.  If I can sign in with Incognito and can't with regular Chrome, I go into my Chrome preferences and delete the appropriate Rogers cookies - there are about a half dozen or so and I also delete my cache.  After I do that, I can almost always login, unless there is a problem that affects everyone, which does happen occasionally.  I suspect similar cookie issues with FF if you can sign in with "private mode", but if you can't then there might be another browser issue. I noted that FF was updated this week - might have messed things up.

 

Although I've had issues recently with this forum, I don't recall any issues with MyRogers for quite a while, although I only go there a few times a month, unlike this forum where it's sometimes several times a day, depending on activity.

 

Edit: I just signed in with FF 80.0.1. No problems



Highlighted
I've Been Here Awhile
Posts: 3

Re: MyRogers Site on Chrome is Broken

I have tried chrome, chrome incognito, and safari (all on my mac) as well as chrome on my phone (android). None of them work, always just the never-ending loading graphics... 😞

Highlighted
I'm a Senior Advisor
Posts: 3,670

Re: MyRogers Site on Chrome is Broken


@57 wrote:

 

Edit: I just signed in with FF 80.0.1. No problems


That's the FF version I have.  Still could not sign into my forum notifications, but I can sign into my PayGo balance. I then navigated to Community Forums at the bottom and clicked it, and here I am, signed in!


Rogers PayGo. Location: S-W Ontario
Highlighted
Moderator
Moderator
Posts: 1,158

Re: MyRogers Site on Chrome is Broken

Good evening @asilonca,

 

Welcome to the Rogers Community Forums!

 

MyRogers is a very helpful tool for customers to manage their accounts, I want to make sure you regain access to the platform. May I know when was the last time you were able to successfully log into your MyRogers? Have there been any significant account changes lately? For e.g. changing your MyRogers username, or changing the email you use for the login credentials? 

 

Have you tried to clear the cache and cookies to see if it resolved the issue for you? Additionally, have you tried to use the login credentials to access any of the GO apps like Sportsnet or Rogers Anyplace TV? Just trying to exclude any potential profile issues.

 

 

Looking forward to hearing from you :).

 

 

RogersZia