Can’t sign into MyRogers app

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Around
Posts: 1

Re: Can’t sign into MyRogers app

Every time i try to sign in it says “Go to Rogers business self serve app” but the thing is I don’t have a business account, just a personal one. Another thing, even when i try to sign in on the Rogers business app it says the account doesn’t exist?!? It works when i sign into my Rogers on the web browser just not in the app. I tried all troubleshooting but it still doesn't work
Highlighted
Moderator
Moderator
Posts: 1,831

Re: Can’t sign into MyRogers app

Hello, @User5983.

 

Welcome to Rogers Community Forums, and thank you for posting your MyRogers app login concern. 

 

It's good to know that you can log in to the MyRogers web portal; is there an account associated with your profile?

 

Are you using the username and password or the app code to sign-in to MyRogers app? 

 

Most likely, it's an account association issue, and we're happy to look into it for you. Please send us a private message at @CommunityHelps. You can find details about our private messaging in this blog

 

Cheers,

RogersMoin