Showing results for 
Search instead for 
Did you mean: 

Rogers Rocket Hub DNS Not Working

I plan to stick around

I have a ZTE MF271CA modem. Several days ago, when other providers were having network issues, my Rocket Hub stop being able to resolve names. I could ping an IP address like but ping failed on a name like


I overcame this problem by adding an additional name server to all my computers. So instead of just pointing to the hub of, I added Google's This has worked find except for some IOT devices where I can't specify additional DNS.


The Hub itself does not seem to have any provision for adding additional DNS name servers.


I haven't called Rogers since from previous experiences with the Hub, they are not well equipped to debug the problem.


I'm in Muskoka, Ontario around Windermere. Has anyone else had this problem?




*** Edited Labels ***


Re: Rogers Rocket Hub DNS Not Working


Hello, @DS256.


Thank you for being our Community member; I appreciate your post.


It appears that other Community members may not be experiencing the same issue with their MF271 Hub. I'm assuming you already rebooted the Hub. Have you tried factory resetting it?


It can be done through the Settings menu, Settings > Device Settings > Reset. Let us know if this helps.



Re: Rogers Rocket Hub DNS Not Working

I plan to stick around

Thanks @RogersMoin . As you observed no other community members have reported the same experience but that doesn't mean they haven't called Rogers to report the problem unless you cross checked against the call centre.


Yes, I've already rebooted the Hub with no success. I don't have time today to do a factory reset before the next family member comes up. Are you saying the DNS sites are stored on the Hub when the WAN connection is made? I always assumed DNS resolution would be downstream in Rogers for easier management.

Re: Rogers Rocket Hub DNS Not Working

Good morning @DS256!


We have ways to check into patterns to see if there's any similar reports but you're the only one recently reporting a DNS related issue with the Rocket Hub that we can see.


Typically, DNS issues cause great havoc and we get a flood of calls when a DNS issue happens. It's readily apparent to us when a DNS issue is occurring because we'll get many customers who also can't resolve websites.


The settings on your devices should be set to automatic. Setting a static DNS server on your devices is unsupported, even if it served as a workaround for you. I would recommend setting your devices back to automatic and then attempt the factory reset of your Rocket Hub as Moin suggested.


Please let us know if there's any change after the factory reset.




Re: Rogers Rocket Hub DNS Not Working

I plan to stick around

I have what sounds like a similar issue to the one DS256 is reporting, in that I get intermittent name not found errors for names that are will know (e.g.,, etc).  I have never reported it because it is intermittent and I cannot recreate it.  It is annoying/frustrating just the same

Re: Rogers Rocket Hub DNS Not Working

Hello, @joebloe2 


Thank you for posting your inquiry to the community.


DNS errors can become very frustrating. Have you attempted a factory reset of the Rocket Hub since noticing this issue?



Topic Stats
  • 5 replies
  • 5 in conversation