cancel
Showing results for 
Search instead for 
Did you mean: 

XB6 Modem Settings/Requests/Firmware Discussion

gp-se
I'm an Advisor

Hey guys, I noticed we don't have a dedicated thread on the XB6 modem like the Hitrons. I'm making this thread so we can talk about the various settings and requests for future changes through firmware updates. For me the biggest issues with the modem is we cannot block specific devices from internet access and we cannot use custom DNS servers.

With the Hitrons we could use a custom DNS without issues, and if we bridge the modem we can also use a custom DNS so I don't see why we aren't given the option with the XB6. The Xi6 boxes don't require using Rogers DNS since in bridge mode they are using whatever DNS the user has specified. For security and privacy reasons it's nice being able to choose whatever DNS server we want, and also being able to block devices like personal NAS and IoT from network access.

I know everyone is going to say put the XB6 in bridge mode and problem solved, however besides these two issues my XB6 isn't that bad. The range and speed suits my needs so why should I buy another $200-$300 router just so I can use a custom DNS and block some devices from the internet. Hopefully Rogers listens to our feedback and gives us more control like on the Hitrons.

 

***EDITED LABELS***

187 REPLIES 187

Re: XB6 Modem Settings/Requests/Firmware Discussion

-G-
Resident Expert
Resident Expert

FYI: https://communityforums.rogers.com/t5/Internet/Strange-recurring-issue-with-Rogers-Technicolor-CGM41...

 


@RogersGordon wrote:

Hi All and thanks for your patience with this issue.

We had a fix in hand in 4.0p7s1 but a new issue was identified for devices in bridge mode so the code was rolled back.

We're now expecting this to be included in the BCM 18.3 SDK update and the current target version is in a 4.2 release. We don't have a release date yet but as soon as we do I'll share it here.




Re: XB6 Modem Settings/Requests/Firmware Discussion

Good Morning All,

It looks like the fix for this issue has been pulled forward into 4.0p12s1. Most of the modems will have downloaded the firmware last night but may require a reboot to load the new build. We'll be validating the fix in the lab but would also appreciate any feedback from the community regarding the occurrence (or non-occurrence) of this issue on 4.0p12s1.

 Thanks

Re: XB6 Modem Settings/Requests/Firmware Discussion

@RogersGordon  Thanks very much!  I received the update to 4.0p12s1 this morning and my XB6 rebooted on its own to activate the new build.

 

FYI, this is a general thread that the Community uses to track XB6 firmware updates for both the Arris and Technicolor variants, as well as where we carry out general discussions and post feature requests.  Users following Strange recurring issue with Rogers Technicolor CGM4140COM (Ignite 1 gigabit) may or may not see your post here.

 

Thanks again for the update.  Any news/changes/updates that you can share here as time permits will be greatly appreciated by all!



Re: XB6 Modem Settings/Requests/Firmware Discussion

I am on CGM4140COM_4.0p12s1_PROD_sey  as of today and the firmware seems to have fixed the speed issues.  The speedtests are consistently in the 900's in bridge mode and modem did reboot. So far everything is going ok.

Re: XB6 Modem Settings/Requests/Firmware Discussion

@Gagee1 Thanks for the feedback!

Re: XB6 Modem Settings/Requests/Firmware Discussion

Alex4161
I'm a Reliable Contributor

Is this the latest version?

 

eMTA & DOCSIS Software Version:Prod_18.1_d31 & Prod_18.1
Software Image Name:CGM4140COM_4.0p12s1_PROD_sey
Advanced Services:CGM4140COM
Packet Cable:2.0

 

Thanks

Re: XB6 Modem Settings/Requests/Firmware Discussion

Yes that is the latest firmware as far as I know. 

Re: XB6 Modem Settings/Requests/Firmware Discussion

blues_clues
I Plan to Stick Around

The certificate to allow https remote management is invalid and has expired.  I remotely manage my parent's XB6 and require this to be a secure connection.  I can change the port and make a stronger password for now but if someone is sniffing, they can intercept my credentials.  Apparently, the certificate expired in March 2020.

Re: XB6 Modem Settings/Requests/Firmware Discussion


@blues_clues wrote:

The certificate to allow https remote management is invalid and has expired.  I remotely manage my parent's XB6 and require this to be a secure connection.  I can change the port and make a stronger password for now but if someone is sniffing, they can intercept my credentials.  Apparently, the certificate expired in March 2020.


Are you seeing the expired certificate on an Arris XB6?

 

The SSL cert on my Technicolor XB6 is valid until January, 2021.  When I connect, I get an ERR_CERT_COMMON_NAME_INVALID from my browser but the certificate is still current.

 

Issued To:

Common Name (CN) xfi-gw.comcast.net
Organization (O) Comcast Corporation
Organizational Unit (OU) NSO

 

Issued By:

Common Name (CN) COMODO RSA Organization Validation Secure Server CA
Organization (O) COMODO CA Limited
Organizational Unit (OU) <Not Part Of Certificate>

 

Validity Period:

Issued On Wednesday, January 9, 2019 at 7:00:00 PM
Expires On Saturday, January 9, 2021 at 6:59:59 PM



Re: XB6 Modem Settings/Requests/Firmware Discussion

Don_Ca
I'm a Reliable Contributor
I have the same cert, January 2021

Re: XB6 Modem Settings/Requests/Firmware Discussion

blues_clues
I Plan to Stick Around
Yes, details below:
Model:TG3482G
Vendor:ARRIS Group, Inc.
Hardware Revision 11
eMTA & DOCSIS Software Version:7.1.1.1.69
Software Image Name:TG3482SV6_4.0p13s1_PROD_sey
Advanced Services:TG3482G
Packet Cable:1.5

Re: XB6 Modem Settings/Requests/Firmware Discussion

@blues_clues  To get this resolved, you will need to contact Rogers Tech Support and have them open a support ticket internally.  You can do this either by telephone or by sending a Private Message to @CommunityHelps .



Re: XB6 Modem Settings/Requests/Firmware Discussion

gp-se
I'm an Advisor

Anyone notice after the latest firmware that the XI6 cable boxes will show a blank screen with no audio after leaving Netflix/Youtube/Amazon Video? Once I change the channel then the video/audio comes back. 

Re: XB6 Modem Settings/Requests/Firmware Discussion

Don_Ca
I'm a Reliable Contributor
Yes, I get that as well. I suspect that to be a firmware on the boxes, not the modem, problem.

Re: XB6 Modem Settings/Requests/Firmware Discussion

Don_Ca
I'm a Reliable Contributor
New firmware overnight:

eMTA & DOCSIS Software Version:Prod_18.1_d31 & Prod_18.1
Software Image Name:CGM4140COM_4.0p14s1_PROD_sey
Advanced Services:CGM4140COM
Packet Cable:2.0

Re: XB6 Modem Settings/Requests/Firmware Discussion

seadooxp30
I Plan to Stick Around

Interesting...

Have you noticed any improvement of fixes?

I haven't got it yet and have issue with my Panasonic cordless phone voice mail indicator..

 

Anyone know how to Triger firmware update?

 

eMTA & DOCSIS Software Version:Prod_18.1_d31 & Prod_18.1
Software Image Name:CGM4140COM_4.0p12s1_PROD_sey
Advanced Services:CGM4140COM
Packet Cable:2.0

Re: XB6 Modem Settings/Requests/Firmware Discussion

seadooxp30
I Plan to Stick Around

Latest one for Technicolor modem as of today

 

MTA & DOCSIS Software Version:Prod_18.1_d31 & Prod_18.1
Software Image Name:CGM4140COM_4.0p15s2_PROD_sey
Advanced Services:CGM4140COM
Packet Cable:2.0

Re: XB6 Modem Settings/Requests/Firmware Discussion

Don_Ca
I'm a Reliable Contributor
If only there were changlogs available for the firmware.

I did not get the 15s2 yet.

Re: XB6 Modem Settings/Requests/Firmware Discussion

-G-
Resident Expert
Resident Expert

@Don_Ca  Here's the changelog for the latest release:

 

Firmware version: 4.0p15s2

- General bug fixes

 

(Sorry! 🙂 )



Re: XB6 Modem Settings/Requests/Firmware Discussion

Don_Ca
I'm a Reliable Contributor

I finally got the upgrade overnight:

 

eMTA & DOCSIS Software Version:Prod_18.1_d31 & Prod_18.1
Software Image Name:CGM4140COM_4.0p15s2_PROD_sey
Advanced Services:CGM4140COM
Packet Cable:2.0

Re: XB6 Modem Settings/Requests/Firmware Discussion

gp-se
I'm an Advisor

I got the new firmware a few days ago, but I haven't noticed any changes. Has anyone with an XB6 gotten OFDMA upload, or is it only for the CODA currently?