Slow Speeds with CGN3 & AEBS Working Together.

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 15

Slow Speeds with CGN3 & AEBS Working Together.


I recently had my internet service upgraded with Rogers in Ontario.

They gave me the Hitron CGN3 modem/router.

When the Hitron is plugged directly into my computer, throughput is 320MB/s according to speedtest.

If I bridge the Hitron and put it through the latest AEBS, I only get 90MB/s. I cannot for the life of my figure out why that is.

I did the normal firmware update check and full restore of AEBS, that hasn't helped.

Has this been an issue for anyone else?

 

 

 

***Edited Labels***

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 6,229

Re: Slow Speeds with CGN3 & AEBS Working Together.

Can you log into the modem and check the firmware version that is listed on the Status page, which is the first page that comes up when you log in.  The latest version is 4.2.4.5   I suspect that you might have 4.2.4.3 loaded.  If that is the case, it has a firmware bug that throttles down the throughput of the CGN3 port that is connected with a 10 / 100 Mb/s device or cable.  Usually it will throttle down to 35 Mb/s, so this is a bit perplexing.  If you look at the back of the CGN3, the port color will be amber for 1 Gb/s interconnect rate, and green for 10 / 100 Mb/s.  If the port LED is amber, it will give you the full data rate.  If the port LED is green, the throughput is throttled down.  If you do have 4.2.4.3 loaded, the next version should be pushed out in 48 hours, but I would give it 3 or 4 days.  After 48 hours and no update, you can call tech support and ask the CSR to have it pushed out to the modem.

 

Can you expand on the term AEBS ?  Airport Extreme Base Station by chance.  And can you check the ethernet cable that connects the two and confirm that it is a Cat 5e or Cat 6 cable?

 

Edit:  If you have Firmware Version 4.2.4.3 loaded, have a look at msg #134 on the following page for a summary of the issues with that version:

 

http://communityforums.rogers.com/t5/forums/forumtopicpage/board-id/Getting_connected/message-id/190...

 

Firmware version 4.2.4.5 resolves the issue of port throttling.



I Plan to Stick Around
Posts: 15

Re: Slow Speeds with CGN3 & AEBS Working Together.

Thanks for the reply

 

AEBS = Airport Extreme Base Station (I have the latest version)

 

My modem has 4.2.4.5 installed and I went and purchased a CAT6 cable, I still have the throttling issue.

Resident Expert
Resident Expert
Posts: 6,229

Re: Slow Speeds with CGN3 & AEBS Working Together.

Ok, can you confirm if the connected port LED at the back of the CGN3 is amber or green.  When you run a test through the Base Station, is that a wired or wireless test?

 

You should be connected to the bottom port of the CGN3 when running in Bridge mode.



I Plan to Stick Around
Posts: 15

Re: Slow Speeds with CGN3 & AEBS Working Together.

I can confirm that the port light is amber.

 

Wireless is turned off on the computer, so the test is wired through the CAT6 cable.

 

I am connected through the bottom port.

 

In the port above, the Smart Home Monitoring device is plugged in. The light for it is green.

I Plan to Stick Around
Posts: 15

Re: Slow Speeds with CGN3 & AEBS Working Together.

Well, I unplugged the cable to the computer (iMac) and went wireless. I now get 320mbps through Wifi from AEBS, 90mbps through the cable.

Is it possible I need a CAT6 cable in the WAN port as well as from AEBS to the computer?

Resident Expert
Resident Expert
Posts: 13,994

Re: Slow Speeds with CGN3 & AEBS Working Together.

The light for the smart home will be green, its only a 10/100.

https://www.apple.com/ca/airport-extreme/specs/

This is the unit you have?

IF the unit is bridged.. i would think it should work.. it has gigabit ports, etc.. so shouldn't be that.

Your connecting DIRECT to the CGN3, shows that it outputing speed fine..

 

SOMETHING on the AEBS is not talking right to it...

 

Let me think on it.



Resident Expert
Resident Expert
Posts: 6,229

Re: Slow Speeds with CGN3 & AEBS Working Together.

For test purposes, can you try the following. I'm assuming that the CGN3 is still in bridge mode.  Disconnect the Smart Home Monitoring router and restart the CGN3 by unplugging from the socket and plugging it back in, with just the base station connected.  I don't think that this should do anything, but I remember a comment from of of the Rogers Mods recently who indicated that the CGN3 can become flakey if two ports are used when the CGN3 is in bridge mode.  If that turns out to be the case, just plug the Home Monitoring router into your base station.  Now the interesting thing here is that you would normally turn off the DHCP server on a router if you had it plugged into another router or modem, but in the case of the Home Monitoring router, you won't have that option.  That might require a discussion with tech support to see what IP address range the Netgear (?) router uses, so that you can adjust the LAN IP range of the base station if necessary.

 

Can you confirm that when you indicated "Smart Home Monitoring" that refers to the Netgear router?

 

Edit:  The cables that you use to connect all devices should be gigabit capable, ie. recent Cat 5e or Cat 6 cables.  People do have "Fast Ethernet" cables kicking around that were purchased not so very long ago.  Those cables only support a maximum of 100 Mb/s.  I wonder if that might be the case here, with the one cable limiting the throughput.  If you disconnected that cable at the base station and simply plugged it into the CGN3, the CGN3 port LED will tell you if the cable supports 1 Gb/s (amber) or 10/100 mb/s (green).



I Plan to Stick Around
Posts: 15

Re: Slow Speeds with CGN3 & AEBS Working Together.

I'm going to call tech support to make sure smart home monitoring with the netgear router is working ok.

 

I have found a partial solution.

 

I reversed the CAT6 and CAT5e cables I had. Now the CAT5e is plugged into the WAN port and the CAT6 goes from AEBS to the computer. I'm now getting 245mbps (324 direct from Hitron to computer). I'm going to head back out and get another CAT6 cable for the WAN port and see if that helps.

 

 

Resident Expert
Resident Expert
Posts: 6,229

Re: Slow Speeds with CGN3 & AEBS Working Together.

Have a look at my edit above.  Its possible that the cable is damaged in some fashion or that it isn't connecting properly at one or both ends.  The CGN3 port LED would tell you right away if that cable now only supports 100 Mb/s



Order Now!
Wilder vs. Ortiz II Live
LIVE: Saturday, November 23, 2019 8PM ET
Channels: 348 (HD) | 350 (SD) | Ignite TV 499
Price: $74.99 (HD) | $69.99 (SD) | Ignite TV $74.99
DTV can order on Nov. 21st & Ignite TV customers can order now!

Reigning heavyweight world champion Deontay "The Bronze Bomber'' Wilder takes on his most dangerous challenger as he defends his WBC title in a rematch against once-beaten Cuban slugger Luis "King Kong'' Ortiz.

Topic Stats
  • 10 replies
  • 1010 views
  • 3 Likes
  • 3 in conversation