Service isn't that good since Saturday install

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 10

Service isn't that good since Saturday install

 
Had Rogers Ignite 100u installed Saturday afternoon. Since then there's been dropouts and websites just wont load at all. When it does work, I get 94 mbps down and 12 up.
 
Not sure what do you, Rogers doesn't seem to care other than sending me instructions to reset the box which doesn't improve anything.
 
Noticed the modem they gave me is heavily banged up, scratched etc. Didn't know Rogers was in the business of providing second-hand cable modems to new customers.
 
***Edited Labels***
Solved! Go to Solution.

Accepted Solutions
Highlighted
Resident Expert
Resident Expert
Posts: 14,169

Re: Service isn't that good since Saturday install

Since all units are rentals now, they technically are all refurb, or a chance of being it.  All depends on what the tech has.

You could always go into any rogers store, and swap the modem if you wanted.

As for the drops, etc..

How are you connected? Wired or wireless??

Are you in a house or an apartment?


Are you able to log into the modem, and post the modem signal levels?



View solution in original post


All Replies
Highlighted
Resident Expert
Resident Expert
Posts: 14,169

Re: Service isn't that good since Saturday install

Since all units are rentals now, they technically are all refurb, or a chance of being it.  All depends on what the tech has.

You could always go into any rogers store, and swap the modem if you wanted.

As for the drops, etc..

How are you connected? Wired or wireless??

Are you in a house or an apartment?


Are you able to log into the modem, and post the modem signal levels?



View solution in original post