Samba SMB1 and Rogers Ignite CGM4141 Gateway

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pgardner1217
I've Been Here Awhile
Posts: 4

Samba SMB1 and Rogers Ignite CGM4141 Gateway

I am trying to connect to my shares on Windows 10 Home  PC via Oppo-BDP-103 using Oppo Media control app.  All worked before change to Rogers Ignite and CGM4141 gateway.  Does this device not support Samba SMB1 protocol?

Solved! Go to Solution.

Accepted Solutions
pgardner1217
I've Been Here Awhile
Posts: 4

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway

Using Plex now as DLNA server and Oppo media control App which sees shared files on IOS and Android devices.  However only Android devices allow for continuous playback when Oppo Media control App running in background on device playing thru Oppo BDP-103 to AV.  IOS works if Oppo media control app left open all the time and never switching to another App (not an option). Tried to test Plex App on iPhone but requires Plex login.  I don't need another login nor want to pay to stream internal media.  Plus want to play thru AV not iPhone.

 

So likely Oppo Media control/IOS issue and nothing to do with Roger CGM4141 gateway now.  I also tested with Serviio DLNA server and Oshare as well with similar results.

 

SMB1 (Oppo supported) did not work on either IOS or Android likely due to  Rogers CGM4141 not supporting SMB1. SMB1 worked with previous Rogers Arris TM502G modem pre-ignite.  I know SMB1 not secure and moving on with DLNA server.

 

All this due to older non HDMI and non networked AV.  Time for upgrade!

 

Thanks for your support!

View solution in original post


All Replies
Datalink
Resident Expert
Resident Expert
Posts: 7,132

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway

Samba SMB1 is no longer a secure protocol.  My guess is that Technicolor or Rogers has disabled or removed SMB1 support from the modem, but, that's just speculation on my part.  I doubt that you will get any official indication from Rogers concerning the possible removal / disabling of SMB1 for the CGM4141 modem.  

 

Here's a reference to SMB1, probably one of many references why everyone should stop using SMB1:

 

https://techcommunity.microsoft.com/t5/storage-at-microsoft/stop-using-smb1/ba-p/425858

 



pgardner1217
I've Been Here Awhile
Posts: 4

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway

Thanks, yes aware of security issues with SMB1 and using DLNA server now!

-G-
Resident Expert
Resident Expert
Posts: 1,738

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway


@Datalink wrote:

Samba SMB1 is no longer a secure protocol.  My guess is that Technicolor or Rogers has disabled or removed SMB1 support from the modem, but, that's just speculation on my part.  I doubt that you will get any official indication from Rogers concerning the possible removal / disabling of SMB1 for the CGM4141 modem.


The XB6 does not have any USB ports for connecting external storage and does not provide services for file/printer sharing... nor should it be interfering with or blocking those protocols on the internal network.



Datalink
Resident Expert
Resident Expert
Posts: 7,132

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway

I'm assuming that @pgardner1217 is connecting to the Oppo-BDP-103 via its built in LAN port, so, it worked previously, and now .... it doesn't.  Only change is the modem.  @pgardner1217 can confirm if that is correct.  



pgardner1217
I've Been Here Awhile
Posts: 4

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway

Correct

pgardner1217
I've Been Here Awhile
Posts: 4

Re: Samba SMB1 and Rogers Ignite CGM4141 Gateway

Using Plex now as DLNA server and Oppo media control App which sees shared files on IOS and Android devices.  However only Android devices allow for continuous playback when Oppo Media control App running in background on device playing thru Oppo BDP-103 to AV.  IOS works if Oppo media control app left open all the time and never switching to another App (not an option). Tried to test Plex App on iPhone but requires Plex login.  I don't need another login nor want to pay to stream internal media.  Plus want to play thru AV not iPhone.

 

So likely Oppo Media control/IOS issue and nothing to do with Roger CGM4141 gateway now.  I also tested with Serviio DLNA server and Oshare as well with similar results.

 

SMB1 (Oppo supported) did not work on either IOS or Android likely due to  Rogers CGM4141 not supporting SMB1. SMB1 worked with previous Rogers Arris TM502G modem pre-ignite.  I know SMB1 not secure and moving on with DLNA server.

 

All this due to older non HDMI and non networked AV.  Time for upgrade!

 

Thanks for your support!

View solution in original post