Rogers Online Gaming Thread

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

Re: Rogers Online Gaming Thread

I don’t know if it’s my luck or Rogers have bad internet service during winter time, every time I a intense gaming session Rogers has failed to keep me connected to my gaming and I pay over 150$ for this *ignite so called best internet* and I live in the middle of the city and this not onky happened once it’s many times already.

Highlighted
Moderator
Moderator
Posts: 950

Re: Rogers Online Gaming Thread

Hello @Qingkat,

 

Welcome to the Community!

 

I can imagine how connecting issues can put a damper on the gaming experience. Have you had a chance to speak to our tech support team? Do you have an open ticket for this issue?

 

 

 

RogersZia

I've Been Around
Posts: 1

Re: Rogers Online Gaming Thread

So I am having some problems with connecting to the fortnite servers and I live in the downtown Brampton area.  what happens is I get ping spikes.  I get 300mbps which is really good speed.  on fortnite I get about 30 ping which is what I usually get but then it spikes all the way to 300 ping and then goes back down and this happens almost every minute.  I thought I was the only person having this problem but my cousin has the same exact problem even other people in my neighborhood.  I have unblocked all the ports and nothing is working and know I believe this is on rogers end.  

 

Rogers please improve the internet so we do not get any ping spikes.

(Removed Personal Info - RogersTony)

I've Been Around
Posts: 1

Re: Rogers Online Gaming Thread

Been having issues with the internet ever since i switched to Ignite. Modem is constantly disconnecting - 2-3 times/hour going down for about 10 min at a time. When it does work i get stable ping for about 2-3 min at a time before it spikes to 300ms.  Basically the service is unusable!

I have had 5 techs at my house, about 50 calls to tech support, and about 100 hours wasted talking to Rogers.

The in-home techs have take the following actions:

- add a splitter

- remove a splitter

- add a filter

- remove a filter

- replace the modem

 

the problem persists. Today i was on the phone with CET and the manager said he has never heard of the modem causing lag or ping however "he would be the first to hear about it" seems like Rogers is a joke at the end of the day.

They provide zero solutions but keep charging me for Gigabit internet monthly. I'm not sure if this is even legal as i have home security as well and the internet is on for about 50% of the time. Can you even sell home security that works 50% of the time??? 

 

Just wrote this post to help everyone else that is experiencing the same problem. They have no clue what is going on.

 

After doing extensive research and reading about the same issue on Comcast forums, I can say confidently that Rogers has no idea of this issue and are in the process of switching all their customers to the ignite platform (without a way of ever going back to legacy). 

The modem is the problem and they refuse to acknowledge that.  A google search on "Technicolor modem constantly disconnecting" will get you 1000s of results. There aren't enough of us in Canada to get Rogers's attention. 

Moderator
Moderator
Posts: 284

Re: Rogers Online Gaming Thread

Hey @drfdfdf!

 

Welcome to the community, and thanks so much for reaching out to us via PM @CommunityHelps. We'll be happy to assist in identifying what's going on.

 

@RogersAndy