Rogers Hitron CODA-4582 Hardware

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Resident Expert
Resident Expert
Posts: 6,045

Re: Rogers Hitron CODA-4582 Hardware

Maybe its just a matter of a high data throughput and wifi use that's causing the modem to run hot.  More load, more heat......  Your comment is the first that I've seen indicating that the modem runs hot.  



I Plan to Stick Around
Posts: 26

Re: Rogers Hitron CODA-4582 Hardware

I will measure the heat dissipating from it over a couple of nights throw it in a little graph and see if there is a correlation, other than this I am super stoked with this device and with the throughput we are getting.

 

Highlighted
I Plan to Stick Around
Posts: 39

Re: Rogers Hitron CODA-4582 Hardware


@Datalinkwrote:

 

Edit:  one additional point, Rogers modems, in Bridge mode will support more than one device connected to the modem.  The modems will supply two IPV4 addresses and apparently an unlimited number of IPV6 addresses, so, you can have two devices running in Dual Stack mode (IPV4 and IPV6), and in theory, additional devices connected running IPV6 only.  I run two routers for test purposes and that works very well.  


Thank you @Datalink, this is exactly the info I was looking for.

 

Do the devices attached to the bridge need to be routers?

I tested this last night, very bottom port my Asus router and on the next port up, my laptop.

Router gets an IP and can surf the net.

Laptop would not get an IP address, is there something I need to do for it to get an address?

 

 

I Plan to Stick Around
Posts: 41

Re: Rogers Hitron CODA-4582 Hardware


@TECHHEADwrote:

 

Do the devices attached to the bridge need to be routers?

 


No.  Nothing knows what kind of device you attach.  Basically, the device needs to be a DHCP client.

 

Do remember that any device should be secured: any bad guy on the internet can address the device.  Your device is not "protected" by NAT.

 

The common wisdom is that most Windows users don't know how to secure a Windows system.  I don't either (because I don't use Windows) so I won't try to advise on you how to do this.

I'm a Regular
Posts: 859

Re: Rogers Hitron CODA-4582 Hardware

The last time I bridged my modem and hooked up my router then plugged in the 1st Xbox one to the router that worked fine but when I hooked up the other Xbox one to the coda on port2 I would keep on loosing connection
I Plan to Stick Around
Posts: 39

Re: Rogers Hitron CODA-4582 Hardware

@HughR,

ThanX for the quick reply.

 

I just needed to confirm that a second device can be added to another switch port on the 4582.

Not sitting a standalone PC directly on an internet port.

 

I was looking at adding wireless capability out in my workshop.

I have a Cisco 3602i AP in Autonomous mode and want to take it out to my garage to add WiFi out there.

Doing some reading, unfortunately I will have to sit the AP behind a router.

Resident Expert
Resident Expert
Posts: 6,045

Re: Rogers Hitron CODA-4582 Hardware

@TECHHEAD, with both devices connected and running, reboot/restart the modem.  Pull the power from the modem and plug it back in to force a restart.  

 

If the laptop still doesn't receive an IP address, disconnect the router and then reboot the modem.  The laptop should at that point pick up an IP address after the modem reboot.  It will then have a new ethernet profile generated by the connection to the modem.  As was pointed out, the laptop is on its own, in terms of any defence from port scanning miscreants out on the internet, so, I wouldn't leave it connected for very long.  No doubt there are people who run with direct internet connections, but, I don't advise it except for extremely short test runs of some type, after which its time to retreat behind a firewall.  

 

Ok, so, assuming that the laptop has an IP address at this point, reconnect the router and ensure that it picks up its IP address.  If it doesn't, once again, reboot the modem.  

 

Fwiw, that's the routine that I had to go thru a few weeks ago, get the modem to assign an IP address to each device with a single connection, then switch to two connected devices.  Just to see what would happen today, after seeing your post, I fired up the second router that I have connected to the modem and it picked up its IP address right away, without any issues.  I've never had any issues with losing connections as I run the second router for days on end for test purposes and would notice if it dropped a connection. 



I'm Here A Lot
Posts: 5

Re: Rogers Hitron CODA-4582 Hardware

I have tried your suggestions:

 

Placing the Hitron modem back in Gateway mode while my router was still attached still results in the slow internet speeds (no change). It is clear that it is my router that is the weak link, since a direct connection to the Hitron gives decent speeds. 

 

My router is using the latest Stock firmware. QOS has never been on. There are very few options on Stock firmware and they are all basically off. I can't see anything else left for me to turn off.

 

I have run out of ideas. I may have to start a thread about this issue on the Netgear fourms to see if anyone there has any idea why this router does not want to play well with this Hitron modem.

 

Alternatively does anyone here know of any New modern enthusiast level Wifi router that would work well with this Hitron Modem (tested and known to work well)?  Ideally something with excellent Wifi range (one of the reasons i like my current Netgear router). As a last resort I may have to look for a new router should i not be able to solve my current issue.

Resident Expert
Resident Expert
Posts: 6,045

Re: Rogers Hitron CODA-4582 Hardware

@mr_interested looking at the smallnetbuilder site, the review for the R7000 show throughput rates around 930/940 Mb/s:

 

WAN - LAN 931.4 Mbps

LAN - WAN 941.7 Mbps

 

The R7000 has a Broadcom BCM4709A0(1 GHz, 2 cores), which is a little faster than an Asus RT-AC68U (800 Mhz processor).  With the 68U running only the firewall, wifi and the AI Protection, it will max out around 900 to 910 Mb/s.  So, from what I've read I'd expect the R7000 to be slightly faster, depending on what functions are running.  

 

When you've finished disabling the various functions, reboot the router as I don't know if the simple act of disabling the offending functions will enable Broadcom's CTF.  A reboot might be required to reenable the CTF.

 

Do you happen to have a gigabit switch available for test purposes?  If so, try this:  park the switch between the modem and the router and see if that changes the speedtest results.  That will isolate the router from the modem which should alleviate any incompatibilities between the two.  PWhen you run the speedtest use the www.speedtest.net Toronto or Montreal Rogers servers.  The Toronto server is a 10 Gb/s server, so it has the horsepower to run gigabit speedtests.  I suspect that the Montreal server is the same, but, don't quote me on that one.  If you run this test please let me know what the results are.

 

If that still doesn't work, I would think that there is still some function running that is disabling CTF, or, perhaps there's a firmware issue as listed below.

 

Also, have a look at the following Netgear thread concerning the effect of recent firmware versions on the router's throughput:

 

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Netgear-Nighthawk-R7000-Slow-Internet-Speed-...

 



I Plan to Stick Around
Posts: 11

Re: Rogers Hitron CODA-4582 Hardware

For some reason the 2.4 ghz wifi on my CODA 4582u is not working properly. I get speed of 30mbps on speedtest.net even a couple meters away from the modem. Rarely, out of the blue i reach 90mbps. Range is also really short.

On the 5ghz wifi everything is fine and i get 190 mbps (i have 150u plan).

I tried fiddling with anything i could, changing channels, setting N only, trying different encryptions, nothing seems to be working. Any idea why? thanks

 

Hardware Version 1A
Software Version 2.0.10.28T2