Rogers Gaming & Streaming Lab

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Community Manager
Community Manager
Posts: 3,361

Rogers Gaming & Streaming Lab

 

  Streaming_Gaming_Lab.png

 

Hi Community, 

 

Welcome to the Rogers Community Forums Gaming & Streaming Lab!

We will use this thread as a central point to discuss upstream issues affecting your online gaming and streaming experience on the Rogers network.  

 

This Lab will work to consolidate all upstream specific issues into one place. By doing so we can work together to hone in on any issues specific to the Rogers network that may be impacting your gaming or streaming experience up to, but not limited to, dropped frames, stutter, increased latency and intermittent voice; all while streaming on Twitch, YouTube Gaming, Steam, etc. 

 

Our own Community Forums Specialist @RogersAndy , is an avid gamer with streaming experience on all major platforms in addition to many years of experience testing and troubleshooting with all technical lines of business. As part of our service resolution tracking, we recommend avoiding contact with alternative lines of support for this issue specifically. 

 

To take part in this lab, you must meet the following requirements. 

  1. All services work fine outside of streaming/gaming.
  2. Your modem’s RF levels are within spec. 
  3. You have had multiple service calls and/or tickets within 6 months regarding your game streaming issues. 
  4. Issues must be present with a wired connection to the modem. NO connected 3rd party equipment.

*If you do not meet the above requirements, your post(s) may be merged to a more accurate thread.

 

What troubleshooting will we need from you? 

  1. A screenshot of your Upstream and Downstream levels found on the status page when you log into your modem. 
  2. A current ping test result from command prompt to google.com 
  3. A current traceroute from command prompt to the streaming/gaming service you’re connecting to. (their support can provide you with that IP if necessary). 

 

*Always remember when posting an image of network testing results to block out/remove your personal IP address.

*Images will show in your post after they have been approved by our Moderator team. Don't worry when they don't show up right away.

 

We also recommend all of our gamers to sign up for the Rogers WiFi Modem Firmware Trial. Feedback from the Community has resulted in great improvements to the overall internet experience, specifically in regards to ping and latency on the Rogers network. For details of this program, please see this thread. 

 

To learn more about Rogers and online gaming, check out our gaming page at www.rogers.com/gaming 

 

Thank you for your continued feedback and support. 

 

 

 

Resident Expert
Resident Expert
Posts: 6,111

Re: Rogers Gaming & Streaming Lab

An excellent idea.  I hope this will also include open discussion of Rogers Peering with gaming companies and other providers, and open discussion of CMTS loads which affect the download and upload throughput.  I'm keeping my fingers crossed that these will be actively discussed. 

 

https://www.peeringdb.com/search?q=rogers

 

https://www.peeringdb.com/net/307

 

 



I Plan to Stick Around
Posts: 85

Re: Rogers Gaming & Streaming Lab

Hi there. I've been a small time streamer for the last 9 months or so, and for some of that time, my connection has been pretty awful. Usually it's in decent condition, where I might only drop 1-3% of frames per stream. Other days, I can stream for 6 hours straight with 0 frame drops. Sometimes though, I'm just unable to stream, because my upload speed and/or my connection to twitch ingest servers is too poor. For reference, I've been on ignite 150 for most of this time, but recently switched to ignite 300, which has made no difference in stream connection stability.

 

Recently, for the past week or so, I've been experiencing some pretty bad packet loss. Running the Twitch Bandwidth Test v1.5 application, I get a quality rating of 0 and upload speeds that vary (typically below 7mbps, sometimes below 3mbps). The games I play say I'm getting packet loss, and it comes in either huge spikes up to 50% or just sits around 0-10% most of the time. It's pretty constant, which is unusual. I've talked with Rogers support a few days ago about my issues, and they submitted a ticket on my behalf (no clue what will happen next though).

 

As for taking part in the lab, I believe I meet the requirements: 

 

1. Speedtest results are great, especially for download. Upload shows 20mbps, but sometimes results are significantly lower.

2. Downstream signal strength has all 32 channels at +-2 dBmV, give or take. Signal to noise ratio is all within 38-40 dB. My upstream seems to be worse, with Signal Strength between 30-37, and a few days ago it was between 20-30 dBmV for all 3 channels.

3. I think I first contacted support in June, and have since then been contacting every so often about these issues, looking for a fix. I've had a tech come out to my building at least 3 times as well in this period. They performed maintenance to the building, and replaced cables in my apartment. There was no noticeable change to my connection as a result of the techs, to be completely honest.

4. Very recently replaced  my CODA-4582U at the Rogers store with a new one, and I'm running it in Gateway mode and a wired connection. I've tried bridged mode too, but that doesn't solve my issues.

 

Here is my upstream/downstream: 

Downstream Overview
Port IDFrequency (MHz)ModulationSignal strength (dBmV)Channel IDSignal noise ratio (dB)
1597000000256QAM1.400838.983
2849000000256QAM0.400238.983
3855000000256QAM0.800338.983
4861000000256QAM0.300438.983
5579000000256QAM1.100538.983
6585000000256QAM2.000640.946
7591000000256QAM1.700740.366
8303000000256QAM1.100138.983
9603000000256QAM1.400938.983
10609000000256QAM1.0001040.366
11615000000256QAM0.9001138.983
12621000000256QAM0.7001238.605
13633000000256QAM0.5001338.983
14639000000256QAM0.3001438.983
15645000000256QAM0.2001538.605
16651000000256QAM0.2001638.983
17657000000256QAM-0.1001738.983
18663000000256QAM-0.1001838.983
19669000000256QAM-0.2001938.605
20675000000256QAM-0.3002038.983
21681000000256QAM-0.2002138.983
22687000000256QAM-0.3002238.605
23693000000256QAM-0.3002338.605
24699000000256QAM-0.4002438.605
25705000000256QAM-0.8002538.983
26711000000256QAM-1.2002638.605
27717000000256QAM-1.7002738.605
28723000000256QAM-2.2002837.636
29825000000256QAM-0.8002938.983
30831000000256QAM-0.4003038.605
31837000000256QAM0.0003138.983
32843000000256QAM0.3003238.983
OFDM Downstream Overview
ReceiverFFT typeSubcarr 0 Frequency(MHz)PLC lockedNCP lockedMDC1 lockedPLC power(dBmv)
0NANANONONONA
14K290600000YESYESYES3.000000
Upstream Overview
Port IDFrequency (MHz)ModulationSignal strength (dBmV)Channel IDBandwidth
123700000ATDMA - 64QAM30.50026400000
238596000ATDMA - 64QAM34.25033200000
330596000ATDMA - 64QAM37.75016400000
OFDM/OFDMA Overview
Channel IndexStatelin Digital AttDigital AttBW (sc's*fft)Report PowerReport Power1_6FFT Size
0DISABLED0.50000.00000.0000-inf-1.00004K
1DISABLED0.50000.00000.0000-inf-1.0000

4K

 

 

2. google-ping.PNG

 

3. You can't ping Twitch ingest servers without a stream key it seems, so I can only test my connection using OBS or the Twitch Bandwidth Test app. Here is a traceroute to a random AWS server in Virginia, which is used by the game I play.tracert.PNG

 

I'd also like to post relevant Twitch Bandwidth Test results. The 0 quality rating means my connection is very inconsistent. Having a solid connection will usually result in 85-100 quality rating. Ping results seems fine, speed results aren't near what they are on speedtest.net or dslreports speed test right now (I'm getting 20mbps on those for comparison).tracert.PNG

 

 

It's important to point out that my area is congested, and according to Rogers support, there is supposed to be a node segmentation in April which would hopefully help solve some of these issues. But even with congestion, I don't think my connection is supposed to be as bad as it's been the past week. The issues arise even at off hours it seems. I even ran a twitch test at 3am last night, and could barely push 3mbps upload. 

 

Here are the results of a roughly 3 hr stream I just had. Note that I wasn't dropping any frames for maybe the first half, then it got really bad. Probably 40% of my frames were starting to drop, and the total dropped frames rapidly rose to 14.6%. I was experiencing packet loss in game this whole time too, roughly 1-10%.obs pic.png

 

So yeah. Not sure what's going on, or if this packet loss stuff will stop sometime soon. I can't tell if it's an issue with Amazon Web Services or not, since both Twitch and Fortnite (the game I'm playing) use AWS. 

 

I'm willing to run more tests and gather more data if you guys can suggest them. 

 

Thanks.

Moderator
Moderator
Posts: 206

Re: Rogers Gaming & Streaming Lab

Hey @Nadernt!

 

Thank you so much for the details provided! I'll be happy to assist and get to the bottom of this for you. As someone who's experienced what you have I know first hand how incredibly disruptive to the streaming experience this can be. I did take a look at the congestion as mentioned but this was only notable for the downstream channels and it doesn't seem like you're being impacted there. Upstream congestion levels are within acceptable ranges, so that doesn't appear to be what's causing your dropped frames and packet loss.

 

Send me a PM @CommunityHelps and I'll work with you to get to the bottom of this as soon as possible :).

 

@RogersAndy

I Plan to Stick Around
Posts: 85

Re: Rogers Gaming & Streaming Lab

@RogersAndy Thank you! I'll send a PM.

I Plan to Stick Around
Posts: 85

Re: Rogers Gaming & Streaming Lab

Update to being a part of the streaming lab:

 

After like 6 months of intermittent issues, I believe my issues have been resolved.

 

Thanks to @RogersAndy and the rest of the crew involved who helped solve my packet loss, dropped frames, and high ping issues. Within a week of posting, my ticket was escalated and my issues were resolved. So far it's been a week of no issues, and really just perfect internet. 

 

I'd recommend everyone with issues to take part in the Gaming & Streaming lab if they can. Thanks to Rogers and especially to those involved. 

I'm a Reliable Contributor
Posts: 579

Re: Rogers Gaming & Streaming Lab

@Nadernt if you don't mind, what was done to fix your issues?
I Plan to Stick Around
Posts: 85

Re: Rogers Gaming & Streaming Lab

I'm not sure. I didn't ask and specifics weren't mentioned. All I know is my ticket was escalated and resolved. I didn't have to do anything personally. 

 

I can tag @RogersAndy and hopefully he can provide an explanation. 

I Plan to Stick Around
Posts: 10

Re: Rogers Gaming & Streaming Lab

I have been receiving high input buffer an sudden ping spikes during games, that cause rubber banding and disconnects through multiple games. I also receive lost frames whiles streaming. My downloads speeds are exceptional while using asus Game First and receive up to 400mbps download speeds sometimes on steam, yet I still receive such lag. I have tried using a pcie Ethernet card in case it was my motherboard Ethernet port having issues but it did nothing to help. I used to receive almost no lag but ever since last spring it has been slowly getting worse.

Highlighted
Moderator
Moderator
Posts: 206

Re: Rogers Gaming & Streaming Lab

Thank you all for your patience :). I'm glad to see the thread getting more activity!

 

@RyzenFx: There's certainly a combination of things but the short of it is identifying and isolating the underlying cause of what's being experienced. The hope being, for this lab, is to identify an area of consistency for customer's experiencing frame drops, latency and packet loss while streaming/gaming. My tenure with troubleshooting such issues helps in a lot of ways to take a calculated approach toward the possibility of false positives. Be it noise, congestion, local node or tap issues, signal disparity, routing anomalies etc. Though I can't divulge the exact specifics of any accounts particular issue what I can tell you is that I'm incredibly dedicated and admittedly way too stubborn to leave an issue alone until it's been resolved lol.

 

@Marcoux1: Seeing any form of latency when gaming is enough to start pulling apart your whole experience, like Jenga hoping the whole thing doesn't crumble. The good news is that you've got the lab here to help!
 

Can you confirm for us the following?
 

1) Which games are you experiencing this with? (Looking for server commonality if applicable)

2) Are you streaming while gaming? If so, which platform(Twitch, YTGaming etc), which software (X-Split, Streamlabs etc), as well as what CPU/GPU/Network Adapter(s) you're using in your configuration.

3) Have you tested this with Asus Game First uninstalled/disabled or have you experienced this on an alternative device not running that software as well?

4) Can you provide me with a screenshot of the modem's status page showing your signal levels?

 

Thanks so much! Looking forward to helping more and more people get the most out of their service experience when gaming!

 

@RogersAndy