Outlook v 4.2048.4 Android Will Not Connect to Rogers Email

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Giraffee66
I'm Here A Lot
Posts: 6

Outlook v 4.2048.4 Android Will Not Connect to Rogers Email

I got a new Chromebook for Christmas, and I'm trying to link Outlook to my Rogers mail.  I installed the Outlook version in the subject line from the Play store, and I've entered my rogers email address in the setup.  When prompted, I've entered my email password.  Outlook is trying to connect, but it just gives me a spinning circle forever and never connects.

 

So I have searched Rogers for assistance, and see that I need an app password.  OK, fine, but there is no place to enter this on my version of Outlook.  The instructions on Rogers.com are for Outlook 2010/2013/2016 and instruct you to go file/settings...etc.  However, on my version of Outlook, there is no file/settings etc.  There are only icons to maximize/minimize and close the window.  So how do I enter an app password when there is no place to enter it?

 

*Added Labels*

57
Resident Expert
Resident Expert
Posts: 3,955

Re: Outlook v 4.2048.4 Android Will Not Connect to Rogers Email

You enter the app PW in the same spot as you previously entered the PW?  There must be some place to enter it in Outlook?  Something like Outlook - Preferences - Accounts?  When initially setting up Outlook on the computer were you not prompted to enter the account (e-mail address) and PW?  Here's a link that may help.

 

https://www.rogers.com/customer/support/article/email-setup

 

Please realize that not all versions of e-mail clients work properly with Rogers/Yahoo e-mail.  I recently had to upgrade to the latest version of Outlook due to an older version being incompatible...



Giraffee66
I'm Here A Lot
Posts: 6

Re: Outlook v 4.2048.4 Android Will Not Connect to Rogers Email

Hi:
Thank you so much for taking the time to try and help me. I have been trying all morning to get Outlook to connect to Rogers, and I just tried again before replying to your post. Amazingly, it connected this time! And I didn't do anything different, and I didn't need an app PW, it accepted my standard Rogers email PW. All I can figure is that there must have been a problem on Rogers end, because like I said, I literally did not do anything different. Thanks again and Merry Christmas!