Internet Usage Tracking on MyRogers not showing up

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Here Awhile
Posts: 3

Re: Internet Usage Tracking on MyRogers not showing up

Rogers doesn't care about us or fixing this issue. They want us to go over our monthly usage. More money for them. Drives me nuts.
Moderator
Moderator
Posts: 1,893

Re: Internet Usage Tracking on MyRogers not showing up

Good evening @crzynoof,

 

I am very sorry for the late reply Smiley Embarassed

 

Were you able to get your issue sorted since you last posted?

 

What error message do you get when trying to access your Internet Usage on MyRogers?

 

Is everything else functional via your online profile?

 

We would love to provide you with additional assistance in regards to the issue at hand, if needed.

Looking forward to your reply!

 

RogersMaude

Highlighted
I've Been Here Awhile
Posts: 2

Re: Internet Usage Tracking on MyRogers not showing up

"Usage Not Available"
I've Been Here Awhile
Posts: 2

Re: Internet Usage Tracking on MyRogers not showing up

I've been trying get Rogers to fix this problem I'm having for over 5 weeks and this link showed me my usage. But Rogers somehow has my account linked to a different account number. That's why my usage hasn't been showing. I'll will be contacting my Rogers Account Manager about this issue.

I Plan to Stick Around
Posts: 8

Re: Internet Usage Tracking on MyRogers not showing up

After 18 months of "Usage Not Available" inside MyRogers account > My Usage, today Tuesday 2017-03-21, it looks like Rogers finally fixed the "internet usage" problem. I think the fix was not just for me, but for everyone that had the same issue. I really missed that feature. I am so glad that I can check my usage from now on. It's been a long time getting from there to here. Thank you to developpers who care about their customers.

It is interesting to note that the summary format has changed. It now looks like this:

2017-03-19-my_usage_2.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

The usage details look like this:

2017-03-19-my_usage_3.jpg

Moderator
Moderator
Posts: 1,005

Re: Internet Usage Tracking on MyRogers not showing up

Hi @PCao,

 

 

Thanks for letting us know!

 

 

Regards,

RogersCorey

 

I've Been Here Awhile
Posts: 2

Re: Internet Usage Tracking on MyRogers not showing up

I found a fix for my usage problem on this Rogers Community. Seems Rogers Tech Support couldn't resolve the problem at the time of my Post. Put me on the run around for about 3 months. I pushed my call to Corporate and then the day before, Tech Support fixed it. I found a link on this community site which resolved my problem.  Great people on this site, do a a much better job. I'm a retired Tech and regard this group as my preferred problem resolving group.

I've Been Around
Posts: 1

Re: Internet Usage Tracking on MyRogers not showing up

Hi all I'm about to go over my 200GB limit on my home package. Can anyone give me an idea of what the surcharge will be per GB?
Thanks!
Moderator
Moderator
Posts: 610

Re: Internet Usage Tracking on MyRogers not showing up

Hello @GR38,

 

Welcome to the Rogers Community Forums! =)

 

It's important knowing what the data overages are for your plan so you don't end up with a bad surprise when your bill arrives.

 

Overages can vary depending on which plan you are subscribing to, do you know what plan you are on? If not, we can look this up for you but we'll need to gain access to your account. Please send us a Private Message @CommunityHelps and we can assist you. For more information on our Private messaging system please click here. 

 

We look forward to hearing from you!

 

RogersTony

 

I've Been Here Awhile
Posts: 2

Re: Internet Usage Tracking on MyRogers not showing up

I'm having this same problem in 2018 - the link in a previous post did not work - anyone recently having this problem and what was the fix?