Ignite TV Internet - Google devices connection issues

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Moderator
Moderator
Posts: 1,898

Re: Ignite TV Internet - Google devices connection issues

Hello, @Avinash90.

 

Thank you for joining this discussion, and welcome to Rogers Community Forums! 

 

Thank you for trying to separate the bands; it's disappointing that your devices are not connecting to your home network. 

 

Can you provide us with more details on all the devices that are not connecting? Like the models, firmware version, etc. 

 

We have discussed a similar situation in connecting 2.4GHz devices to the network. Check out this thread from post 22 onwards. 

 

Cheers,

RogersMoin

I Plan to Stick Around
Posts: 8

Re: Ignite TV Internet - Google devices connection issues

Hi Rogers,

I appreciate you taking the time to reply to my problem.
I found a solution to the problem. I performed a factory reset on my Google Nest Mini and it fixed the problem immediately. There was also a firmware update for my Globe Suite smart plugs that also fix the problem. Now all my smart devices work flawlessly. I also turn band steering back on and the devices work perfectly.
Rogers internet is by far the fastest internet I have ever had. Much faster than any internet that Bell has to offer in my area. The speeds that are provided by Rogers are much faster than the speeds that are advertised even during peak hours.

Kind regards,

Avinash Persaud

I Plan to Stick Around
Posts: 8

Re: Ignite TV Internet - Google devices connection issues

Hi Dire,

If you previously setup your Chromecasts with a previous router or modem try factory resettingng them. I did that and now my devices are working perfectly.

Regards,

Avinash
I Plan to Stick Around
Posts: 8

Re: Ignite TV Internet - Google devices connection issues

Hi Duck,

Try factory resetting the devices. I did this when I switched from the white Hitron modem to the Technicolor Ignite modem. My devices connected immediately after a factory reset.

Best regards,

Avinash
I Plan to Stick Around
Posts: 13

Re: Ignite TV Internet - Google devices connection issues

I’ve been having the same issues I made a call to the tech department they detected a problem and said someone would contact me in 24 hours still haven’t heard anything it’s been four days.
My ignite is patchy intermittent unreliable.
I Plan to Stick Around
Posts: 8

Re: Ignite TV Internet - Google devices connection issues

Hello Marinacacic,

Try performing a factory reset on your devices if you previously set then up with another router/modem. Even if you didn't try factory resetting the devices. It worked for me. You can also try updating the firmware on the devices.

Kind regards,

Avinash
I've Been Around
Posts: 1

Re: Ignite TV Internet - Google devices connection issues

I’m also having the same connectivity problems between Rogers Ignite and our Google WIFI extenders which worked fine with the previous version Rogers modem until the Ignite connection a week ago. The Ignite hub also is affecting and prevented connection with our other connected smart devices such as Samsung TV and it appears it will simply not connect to the Samsung TV. Very disappointing. 4 hours on hold with Rogers over two separate calls amidst other problems encountered. I’m not seeing the speed improvement so far which tests our promised “1 GB download service” as actually 220 MB according to fast.com. (Literally as I type this..) 

 

Nothing easy and the set up of it has disrupted our existing services and uses.  The “troubleshooting” tip of moving the modem is priceless. Yes, let’s design the asthetic of our house around a randomly placed modem and Rogers electronics should dictate where our TV, home office etc should be located - not for example other preferences we might have - such as efficient use of space, adequacy of privacy, or access to outside windows. Also I could swear the Rogers Ignite modem wants to place itself somewhere obscure such as not where the old Rogers modem was located. Counter intuitive? Funny how none of this was raised by the Rogers agent, until after, when a more candid Rogers agent casually mentioned that Rogers ignite routinely disrupted other services (eg. such as our existing Rogers home phone which was literally cut off for a week). It was finally reinstated today. 

The penultimate Rogers agent seemed incredulous that we had problems and suggested it was because we were moving. Really?? News to me...

Probably if we were moving I would have known about it... 

 

Very disappointing. 

 

Andrew 

 

PS. If the factory reset works will let you know. 

 

 

 

I Plan to Stick Around
Posts: 8

Re: Ignite TV Internet - Google devices connection issues

Hi AH15,

I had the exact problem. My devices were configured using the white Hitron Modem and then we got the Technicolor Ignite modem and I kept getting a connection error. Try updating the firmware of the other smart devices as well. In terms of your slow speed test, are you using a wired connection? I cannot achieve anywhere close to the advertised speed over wifi unless it's using 5G and I find a wireless channel that a lot of people aren't using.

Kind regards,

Avinash