Hitron CGN3 / CGN3ACR USB Ports

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
Resident Expert
Resident Expert
Posts: 6,139

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

I suspect that your post was probably moved to this thread.  Have a read thru the thread, from the first post to see if any of it answers your questions.  Below are a few other threads concerning a USB storage device connected to a CGN3.  Hopefully this thread and links will provide a few answers.


Here is another thread concerning the LAN IP address of an attached NAS:




Mapping an external drive on a CGN3;




CGN3 free space reporting on a USB storage device:





I've Been Here Awhile
Posts: 2

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

Tks for the reply.


I had a couple extra external drives lying around and decied to test them all out. What I've concluded is that the ports are indeed blue on the modem, which usually indicates USB3 support, not in this case.


I had a few USB2 external drives and they work no issue, but all of my USB3 devices, thumb drives and what not do not work. Will power up but will not be recognized. I don't know if this is a fluke or possibly its not recognizing the brand of HDD or something. 

I'm Here A Lot
Posts: 6

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

How do i use USB port on a Mac with El capitan?  Tried replacing file with SMB but still no luck.  Works with windows but not MAc

I've Been Around
Posts: 1

Re: Hitron CGN3 / CGN3ACR USB Ports

Just got this today, everything is working great minus the external drives i have attached. any time a new folder is created, its being created with a last modified date for dec 31, 1999. any idea why this might be?

I've Been Here Awhile
Posts: 2

Re: Hitron CGN3 / CGN3ACR USB Ports 3.0

Hello all, 


I just bought myself a WD my passport ultra 1tb external HD. It is usb.3.0


My last HD had no issue with the usb ports, However this HD isn't being shown.


It works with my Mac/Pc's


Any suggestions?


right now the drive is formatted to NTFS 





I've Been Here Awhile
Posts: 2

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

I have the same problem.

I've Been Here Awhile
Posts: 4

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

Hi, I have the Hitron Modem router with 2 USB ports.

I have more than 2 drives I want to connect.

I have the 3 drives in a 4 bay DAS (Direct Access Storage).

It only sees the 1st HDD.


Its the same if I stick 2 hdds on a usb hub. only sees 1 drive.

Anyone have a fix, tweak, alternet method to get this to work?

Retired Moderator RogersShakir
Retired Moderator
Posts: 146

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

Hey @drizzt09


Did you find a solution yet?

So even in DAS it sees the first HDD only? Is it consolidating the drive as one (Disk space) or literally sees the first drive only?

@Gdkitty or @Datalink may have an answer for you.



I've Been Here Awhile
Posts: 2

Re: Hitron CGN3 / CGN3ACR USB Ports

I truly hope Rogers "tech support" (now there's a laugh) read these forums. As of Sunday, I'm moving to Bell. After countless calls and hours attempting to figure out WHY functionality of this modem that I've paid for (for years now) is DISabled, I discover that suddenly the firmware is upgraded. NOW, I can see my NTFS formatted drive - but no others. This has been an experience I'm thankful for. By doing some more digging, I've figured out how to make my MAC talk (Read/Write) to an NTFS formatted drive. Without ANY support from Rogers, I now have a system that works. The irony is that now - ALL my money is going to .... What a stupid company. Just know - your router with updated firmware will support (USB 2) NTFS formatted drives. When you go into the router menu that shows the attached drive - all the forward slashes appear as back slashes. So anyone that has no saavy with respect to networking would enter the information ( . presented) in the wrong format, and so attaching a drive via MAC or Windows would fail. I am stunned. Why in this age Rogers would make this functionality impossible for most users is beyond me. Does NOT to my knowledge read MAC formatted drives; however, if you go here 
you will find the easy solution through terminal to allow your NTFS formatted drive to be not only read - but WRITTEN to, by MAC.
Good luck, peeps - just know that while they try to keep you ignorant, google is a tool to solve your problems.
What a joke - can't WAIT for my new services to be installed from "Ma".

I've Been Around
Posts: 1

Re: Re:Hitron CGN3 / CGN3ACR USB Ports

(The path shown doesn't include "\share" for me -- using a Hitron CGN3ACSMR modem.)

Doing what you say (copying the URL and pasting into IE's address bar) worked for me on Windows.


I was able to connect to it on the Mac in Safari by substituting "smb:" for "file:".

I was promped for my a username/password, but it didn't actually need them and regardless of what gibberish I entered for the password, the drive was mounted as a network drive on my desktop, a window appeared with the contents of the USB drive, and I was able to manipulate the files on it.


I hope this helps the rest of you Mac users out there.