Gigabit Internet - Slow Speeds on a Wired Windows PC

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 12

Gigabit Internet - Slow Speeds on a Wired Windows PC

Issue with slow LAN speeds on Gigabit (but not on 500u plan)

 

So I'm at a loss as to what might be causing this issue. I recently upgraded my plan from 500 mbps to gigabit. Since doing so my windows PC has had incredibly slow speeds over LAN. Prior to switching I would often get very close to the 500 mbps but since changing to gigabit I've been getting between 100 and 150 mbps consistently. 

 

When I check my connection it's showing 1000 mbps, as is the port in the Modem settings. I've also tried the SpeedTest app on my Apple TV and got 945 mbps. I've tried multiple LAN cables (including the one that was hooked up to my Apple TV for that test) and still can only get 150 mbps max. 

 

I've tried to update my LAN driver and still nothing. Anyone have any idea what might be causing this? Would it be a Windows issue? (Windows 10 x64 bit). 

 

*Added Labels*

Moderator
Moderator
Posts: 1,329

Re: Gigabit Internet - Slow Speeds on a Wired Windows PC

Hello, @worky.

 

Thank you for posting your concern in the Community. The issue is technically engaging. Are you using the same modem after the upgrade? If you were using CODA-4582, then you don't have to change it. 

 

I appreciate checking the speed on another device. Since you are getting package speed on the Apple TV, we can rule out any provisioning issues.

 

Do you recall modifying anything either on the PC or the modem prior to upgrading the Internet package? Is the IP dual-stack enabled on your modem? 

 

Also, we have seen in the past if Jumbo packet/frame is enabled on the Ethernet adapter it may cause speed issues. Can you confirm it's not enabled?

 

Looking forward to seeing the issue resolved soon!

 

Cheers,

RogersMoin

I Plan to Stick Around
Posts: 12

Re: Gigabit Internet - Slow Speeds on a Wired Windows PC

No, I didn't modify anything on the PC prior to upgrading and it's the same modem as before. That's what is so perplexing since I was getting close to 500 on a consistent basis before. I've tried both dual stack on and off to no avail. I also chatted with someone at Rogers tonight who suggested I reset my modem to factory settings. I did that and it didn't make that much difference. Jumbo packet is disabled and I've tried setting my Ethernet adapter to 1000 mbps from auto and that didn't make a difference either so I switched it back to auto. 

 

Tonight I did manage to get up to 270 mbps on the PC, which is the highest that it's been. The tech I chatted with suggested I switch out my modem if it didn't improve which I'm going to try tomorrow night. 

 

Thanks for the response and I'm open to any other suggestions if you have them. I'll try switching out the modem to see if that helps and will report back. 

Resident Expert
Resident Expert
Posts: 5,874

Re: Gigabit Internet - Slow Speeds on a Wired Windows PC

@worky this is the third case of its type in recent history, that is, totally abysmal data rates with the 4582 modem and gigabit service.  As far as I'm aware, those cases aren't solved and the customers might not be using Rogers anymore.  Don't know what the outcome is for those cases.  

 

One thing you could try is to download Ubuntu 18.10 and create a boot USB stick or boot CD.  Boot the pc from the USB or CD.  Ubuntu will start in Demo mode.  Run a speedtest using the built in firefox application just to see what you end up with when you're not running Windows.  The results will tell you if in fact there is an issue with data rate delivery thru your current modem. 

 

There is always the chance that swapping the modem situation.  It should be the same as running a factory reset on the current modem, where a new configuration file is downloaded when the modem boots up.  If that config file is correct, you should be seeing a maximum of 940 to 950 Mb/s on a speedtest. 

 

You could ask tech support to confirm whether or not the modem is configured for gigabit service, and also ask for a signal check on the modem to determine if the signal levels and signal to noise ratios are within spec.  Ask specifically if the OFDM parameters are within spec or not. 



Topic Stats
  • 3 replies
  • 135 views
  • 0 Likes
  • 3 in conversation