FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I Plan to Stick Around
Posts: 45

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

That's great news @rogerslan. Thanks for acknowledging this issue and looking into it with the vendor.

Looking forward to hearing about your progress on this...

I've Been Here Awhile
Posts: 4

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

I'm having a bunch of connectivity issues related to


The modem "disconnects" frequently: not from the Internet - from the whole network.  When it does, DHCP isn't working and it won't renew IP addresses.  The DNS server is also buggy.  Previously, you could specify manual DNS server settings to a remote IP (I use Cloudflare's and and it didn't matter if a client computer had a static IP or not, but would still look upstream for a DNS server and get it from the modem.  The option to offer DNS proxy for manual DNS is no longer present either, which is what I used to use.  Now it seems like any static IP device needs to have DNS specificed manually on it.  IPv6 DNS is no longer present as an option although it looks like this was an expected change in the current firmware.


Also, Reserve IP's can no longer be specified outside of the DHCP Range, despite what the subnet is set to, whereas before the modem would accept any valid IP within the subnet.


This started happening at ~2:30 Tuesday morning for me.  That whole day, both DHCP devices and static IP devices on my network would experience a disconnection from the network where the modem would not issue DHCP IP's, nor would it show any kind of Internet connection.  The modem lights DID NOT indicate that it was rebooted.


On Wednesday, I had a technician come and replace a 3db attenuator inside my home with a "reverse tap" outside, and even replaced the modem with another CODA w/ the same hardware revision and firmware.  I'm seeing errors and warnings in the logs.  But someone please explain how 2 separate modems will not respond to DHCP IP address renewals to any *wired Ethernet* or wireless computers or devices when it appears to be on and NOT in a reboot state, whether the Internet is connected or not.  Shouldn't the DHCP server ALWAYS function on the modem?  This has NEVER been an issue with a CODA modem prior to this week, nor to any router that I've ever seen (aside from Bell's, which reboot if they don't detect an Internet connection).


I've been using custom settings with my modem since I got Rogers, and since this problem started happening, I tried hard resetting the (previous) modem, as well as the current replacement, and running with the default settings with all dynamic IP's, and it's still showing the same problem.  I suspect there's more to it than just blaming a faulty Ethernet cable considering it affects every PC and device in my home, and I'm reading about numerous issues lately about similar problems.  Maybe someone should look at possible firmware bugs.


Here's a bunch of info from the modem:



System Information

This menu displays general information of the device


Hardware Version 1A
Software Version
Gateway Serial Number 9999999 (obfuscated for privacy)
HFC MAC Address 9999999  (ditto)
System Time 2020-07-09 17:23:08
Time Zone UTC-05:00 Eastern Time(US & Canada)
LAN Up Time 000 day 01h:03m:02s
WAN IP Address  
WAN Receiving 72.52M Bytes
WAN Sending 12.20M Bytes
Private LAN IP Address
LAN Receiving 28.84M Bytes
LAN Sending 42.55M Bytes
WAN Up Time 000 day 01h:03m:25s



This menu displays both upstream and downstream signal parameters

DOCSIS Overview
Network Access Permitted
IP Address  
Subnet Mask
Gateway IP Address  
DHCP Lease Time 😧 6 H: 18 M: 42 S: 41
Downstream Overview
Port ID Frequency (MHz) Modulation Signal strength (dBmV) Channel ID Signal noise ratio (dB)
1 597000000 QAM256 -2.799 8 38.983
2 849000000 QAM256 -2.200 2 38.605
3 855000000 QAM256 -2.700 3 38.605
4 861000000 QAM256 -3.500 4 38.605
5 579000000 QAM256 -2.799 5 38.605
6 585000000 QAM256 -2.599 6 38.983
7 591000000 QAM256 -2.599 7 38.983
8 279000000 QAM256 -4.700 1 38.605
9 603000000 QAM256 -2.799 9 38.983
10 609000000 QAM256 -2.799 10 38.983
11 615000000 QAM256 -2.400 11 38.983
12 621000000 QAM256 -1.900 12 38.983
13 633000000 QAM256 -2.099 13 38.983
14 639000000 QAM256 -2.099 14 38.983
15 645000000 QAM256 -2.500 15 38.605
16 651000000 QAM256 -2.000 16 38.983
17 657000000 QAM256 -2.299 17 38.605
18 663000000 QAM256 -2.200 18 38.605
19 669000000 QAM256 -2.099 19 38.983
20 675000000 QAM256 -2.200 20 38.605
21 681000000 QAM256 -2.200 21 38.983
22 687000000 QAM256 -2.400 22 38.983
23 693000000 QAM256 -2.700 23 38.605
24 699000000 QAM256 -2.000 24 38.605
25 705000000 QAM256 -2.099 25 38.605
26 711000000 QAM256 -2.099 26 38.983
27 717000000 QAM256 -1.900 27 38.605
28 723000000 QAM256 -2.299 28 38.605
29 825000000 QAM256 -2.000 29 38.605
30 831000000 QAM256 -1.799 30 38.983
31 837000000 QAM256 -1.900 31 38.983
32 843000000 QAM256 -2.099 32 38.983
OFDM Downstream Overview
Receiver FFT type Subcarr 0 Frequency(MHz) PLC locked NCP locked MDC1 locked PLC power(dBmv)
1 4K 275600000 YES YES YES -4.700001
Upstream Overview
Port ID Frequency (MHz) Modulation Signal strength (dBmV) Channel ID Bandwidth
1 30596000 64QAM 47.020 3 6400000
2 36996000 64QAM 47.020 4 6400000
3 22100000 64QAM 46.010 1 3200000
4 25300000 64QAM 46.010 2 3200000
5 0 QAM_NONE - --- 1600000
6 0 QAM_NONE - --- 1600000
7 0 QAM_NONE - --- 1600000
8 0 QAM_NONE - --- 1600000
Channel Index State lin Digital Att Digital Att BW (sc's*fft) Report Power Report Power1_6 FFT Size
0 DISABLED 0.0000 0.0000 0.0000 0.0000 0.0000 2K
1 DISABLED 0.0000 0.0000 0.0000 0.0000 0.0000 2K


I've Been Around
Posts: 1

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

I am also experiencing the NAT Loopback issue, where all of my internal services are unavailable from inside my  network. This is extremely frustrating and disappointing and I urge you to deploy a fix as soon as possible.


The lack of communication regarding this issue is also disappointing, I spent two hours trying to debug this issue before stumbling upon this thread. There is a great deal of room for improvement both on the firmware dev side and the communication side from Rogers.

I Plan to Stick Around
Posts: 147

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

I am not too sure what our worth is on this thread anymore as firmware is being rolled out with bugs this group has identified.

I've Been Here Awhile
Posts: 4

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

I've ordered a (expensive) router which should be here on Monday sometime and I plan to put the modem in bridge mode to see if it's just network related, or if the whole modem is stalling out.  From what I've seen on a few other message threads here, I'm not hopeful that bridge mode will fix this.


Here's another bug that I'm noticing:  Disabling DNS Proxy under the Auto section of DNS still forwards the modem IP to clients even after a modem reboot and doesn't forward the external Rogers DNS server IP's (I forget what they are - 64.71.whatever I think).  This is horribly broken.


I talked to a technician again about these issues and he said he can offer a roll-back to one of the CGN3 models which don't run the same firmware code.  One of these will work for me because I'm only on 150Mbps service and those are certified for plans up to that speed (although the modem hardware itself can actually do Gigabit connections according to Hitron).

I'm Here A Lot
Posts: 6

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

you rogers people want feed back here's feed back;


with the new firmware update 7-32 the modems http gets unreachable every time, was on T8 and it was fine



The connection has timed out

The server at is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.


I Plan to Stick Around
Posts: 45

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

+1 to this issue as well on the new firmware in bridged mode.


It would be reachable for a day or two, then seemed to take a while to reach, and then after a few days I couldn't bring up anything when trying to reach I received the same error messages as Pir8pete.


When the router is in gateway mode I can reach it fine after 10 days and counting (knock wood).

I've Been Here Awhile
Posts: 4

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

Ya it's definitely network-related.  I got my new router set up and the CODA modem in bridge mode (disabled Residential Gateway Function and is no longer accessible via address - is now forwarding the WAN IP directly to the router) and it seems to be good so far.  Previously, some days I could only go like 5 minutes after a modem reboot before the network would completely disconnect on Ethernet computers ("no network access" in Windows - not just "no internet") because the router functionality of the modem would just drop out altogether, on and off again.  A few weeknights last week were the worst times for it.


I'm using a Ubiquiti Dream Machine as my router now.  Expensive, but has so many good options for monitoring network activity.  Ubiquiti has them on sale cheaper than most other online retailers, at $400CAD.  It doesn't have native DNS-over-HTTPS/TLS though, but it's a frequently requested feature for Unifi OS (the controller's Linux-based OS UI), so I'm hoping they add it eventually.


Just out of curiosity, what is Rogers' policy on DNS privacy?  Do they sell, monetize, or otherwise provide the DNS realtime searches or search history of customers (home, or business) to third-parties, outside of the scope of providing Internet services that require DNS?

I've Been Here Awhile
Posts: 2

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

I'm glad I found this post to confirm there is an issue with the latest firmware version regarding NAT loopback and that I didn't mess something up locally. Any update on when this might get fixed?

Also, it seems that on the DDNS settings page for the 4582U, you cannot set a DDNS provider other than the 6 provided. I am using and previously had been able to manually enter the information needed to automatically update my DNS information. This no longer works. It isn't a huge issue for me as I can do the same with a script on my computer, but curious if this ability will be added back to the firmware or if only the 6 predefined entries will remain?
I've Been Around
Posts: 1

Re: FEEDBACK - Rogers Rocket Wi-Fi Modem Firmware Trial

I have both of the same issues... rogers where are we at with the fix for 2 issues that shouldn't even be issues if you knew how to properly release firmware updates?
How on earth can a company release a broken update and then 2 months later its still not fixed... SHAME