Email POP Certificate not valid anymore pop.broadband.rogers.com

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resident Expert
Resident Expert
Posts: 1,117

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

@BillyBob2000

POP Settings

Incoming Server

pop.broadband.rogers.com

Incoming Port

995

SSL

Yes

POP Authentication

Email address: Full Rogers Yahoo! email address
User Name: Full Rogers Yahoo! email address
Password: Rogers Yahoo! email password

Outgoing Server

smtp.broadband.rogers.com

Outgoing Port

465

SSL

Yes

SMTP Authentication

Email address: Full Rogers Yahoo! email address
User Name: Full Rogers Yahoo! email address
Password: Rogers Yahoo! email password

IMAP Settings

Incoming Server

imap.mail.yahoo.com

Incoming Port

993

SSL

Yes

IMAP Authentication

Email address: Full Rogers Yahoo! email address
User Name: Full Rogers Yahoo! email address
Password: Rogers Yahoo! email password

Outgoing Server

smtp.broadband.rogers.com

Outgoing Port

465

SSL

Yes

SMTP Authentication

Email address: Full Rogers Yahoo! email address
User Name: Full Rogers Yahoo! email address
Password: Rogers Yahoo! email password



Highlighted
I've Been Here Awhile
Posts: 2

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

@BillyBob2000

 

Here is clue which I fixed my problem:

Select "View Certificate ..." when warning pop-up

Look at "Issued to: " under "General" tab, in my case "legacy.pop.mail.yahoo.com", which I used to replace "pop.broadband.rogers.com" and worked.

 

more reading:

https://www.msoutlook.info/question/613

 

Hope it helps.

Highlighted
I Plan to Stick Around
Posts: 9

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

Ok, I think I'm making some progress.  I had my original POP account, but I deleted that to try to setup IMAP.  Now I went back to setting up POP via legacy.pop.mail.yahoo.com, and linking it to my existing folders (via the database file) and previous POP account.  

 

The test message both now sends and receives (it always sent before this issue), but I'm still not receiving any actual Emails in Outlook.  

 

Error Mesage:
Task 'Home - Receiving' reported error (0x800CCC90) : 'Your incoming (POP3) email server has reported an internal error. If you continue to receive this message, contact your server administrator or Internet service provider (ISP). The server responded: -ERR Server error - Please try again later. [SYS/TEMP] pop_error_type=NULL_MESSAGE_METADATA, context=com.yahoo.mail.pop.user.PopUserContext@92cf301'

Highlighted
I've Been Around
Posts: 1

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

Turning off my Bitdefender Antispam (as posted above, Thanks) worked for me.

I did try the added @rogers,com username and it didn't work for me. Also changing the pop server to the yahoo didn't work either.

I called Rogers twice on this and  the techs I spoke to were unaware of this issue.

Their billing works fine though.

 

Edit; By turning off the antispam add-on within Outlook, I was able to turn antispam back on in Bitdefender.

I Plan to Stick Around
Posts: 9

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

So all of a sudden, my email started working again in Outlook, without my doing anything again for a while.  But now it seems like it takes a lot longer to be done receiving emails (for the last few in the queue, it takes forever)... what should the timeout setting be set at?

Highlighted
Rogers Employee
Rogers Employee
Posts: 145

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

Timeouts shouldn't need to be touched. They were mainly there for the old dial-up internet. If you are having troubles getting your email you should be looking at your computer or internet service.

 

Brian

Highlighted
I Plan to Stick Around
Posts: 9

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

I do have a great computer, and am on the 250 Mbps down plan (which is even faster most times using Speedtest), so those shouldn't be issues.  It was working normally before this glitch.  

 

I do have the timeout set at 1 minute... I don't think that changed.  Also, whenever I do finish sending and receiving in Outlook and all the messages go out and come in, I'm getting a "Send / Receive" error in Outlook still in the bottom right.  Strange.  

Highlighted
I'm Here A Lot
Posts: 5

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

I have been using Rogers/Outlook combination for over 13 years but since yesterday I have been receiving my emails but have not been able to send emails.

 

Something has changed.

 

First I thought it was an issue with Yahoo (I use a yahoo.com email address and not rogers.com email address). Now with over 30 hours past and having the same problem I think maybe Rogers has changed something. Yes I contacted them and they did go over my outlook setting. Deleted and created a new account and everything in between but no luck so they say contact Yahoo. Whaaat?

 

Clearly something has changed and not at my end.

 

Any ideas?

Highlighted
Resident Expert
Resident Expert
Posts: 3,624

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com

@Jables321:

 

I assume you're using POP and not IMAP settings.  I'm surprised that this only happened to you recently. Your post was probably added to this lengthy thread which started early February.  There are several Outlook settings that need to be correct - Username and the server settings at a minimum. There are also other settings in Outlook that "tell" the server whether to leave e-mails there or delete after download.

 

Here's one of my earlier posts that outline those settings:

 

http://communityforums.rogers.com/t5/forums/forumtopicpage/board-id/Getting_connected/message-id/413...

 

That post, and the ones that follow, address various client settings that people have tried to get things working, but again, I'm not sure what prompted the change to your client more than a month after this all began, unless Yahoo made some recent changes.



Highlighted
Rogers Employee
Rogers Employee
Posts: 145

Re: Email POP Certificate not valid anymore pop.broadband.rogers.com


@Jables321 wrote:

I have been using Rogers/Outlook combination for over 13 years but since yesterday I have been receiving my emails but have not been able to send emails.

 

Something has changed.

 

First I thought it was an issue with Yahoo (I use a yahoo.com email address and not rogers.com email address). Now with over 30 hours past and having the same problem I think maybe Rogers has changed something. Yes I contacted them and they did go over my outlook setting. Deleted and created a new account and everything in between but no luck so they say contact Yahoo. Whaaat?

 

Clearly something has changed and not at my end.

 

Any ideas?


@I'm really surprised that Rogers technical support went into checking the settings and recreating the account since it was not an @rogers.com email address. While they should not have touched that at all .... the answer leads to either a problem with outlook or a possible port block. You can run a repair on outlook by going to the list of installed programs and choose "uninstall/change". If that doesn't work, disable your firewall and test but if your security software is not responding, you may want to uninstall that, test, then reinstall. Lastly, if all else fails, you can factory reset the modem and setup wifi again. Had that work once.

Do these in the order presented for the least inconvenience.

 

Any error messages????

 

Brian