Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I Plan to Stick Around
Posts: 17

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Thought I'd report in after going through a trial firmware update. I'm running 4.5.8.21 and this problem is still not fixed. Goodbye, Rogers. Thanks for wasting my time. Just called Bell and they'll be here on Saturday morning to install my new internet. Finally going with a company that actually provides a serevice that works. First thing the guy on the phone said is, "Let me guess, Rogers firmware problem?" Haha....

 

Firmware update did nothing to solve this problem. Called Bell and making the switch on Saturday. I'm convinced this will never be fixed.

 

I feel your pain. I'm done with Rogers. I have wasted 11 years of my life as a customer of theirs and I've had it. Unaccpetable incompetence at evey level. When they screw up, they screw up big. Sadly, the only solution I have come up with is to switch to Bell. The technician will be here Saturday and I got a great deal.

Highlighted
I Plan to Stick Around
Posts: 13

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Hi, thanks for checking on the .21 firmware.  i've been considering a switch to another carrier as well.  II use the chromecast for so much, and the fact that the simple device doesnt work is really disappointing. I'll give it a month to see what happens, but i have a feeling this issue will not be resolved in a timely manner. Thanks for pointing out Bell, ill see what kind of deals theyre offering now

I've Been Here Awhile
Posts: 4

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Now that user Zaphod99 has confirmed the firmware update 4.5.8.2 does not solve the problem, does anyone think that either A) purchasing a new router to use with a Rogers modem or C) replacing the current Hitron router with their older 2.4G-only capability would temporarily solve the issue?

I Plan to Stick Around
Posts: 17

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

I'm curious to know if any confirmed Rogers staff members actually read or offer any solutions to these posts. We're all going around in circles here and there's no sign of a Rogers employee. We all have hundres of dollars worth of equipment that no longer works because of these firmware updates and we don't even get a single acknowlegment that this problem has been recognixed. I'm wondering if this is perhaps deliberate and, for some reason, Rogers don't want their customers using chromecast etc. Thoughts?

I Plan to Stick Around
Posts: 17

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

The manual DNS solution does not work. Like everything else, it appears to work for about an hour and then the icon disappears once again.

I've Been Around
Posts: 1

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Here is the story that i got yesterday:

I reset my chromcast a half a dozen times and truly thought i had a faulty unit.

Exchanged it with no issues, and had the same problem with the new one

Got onto the online chat with a rogers tech..... he said the modem was working fine and if i wanted to fix the issue with chromcast a tech would be willing to try for 129.99 plus tax.

My answer was really? thats your solution?

He then told me that the issue was with chromcast, i should call them.... so i did

 

Chromcast advised that the update on the router made chromcast incompatble with this specific hitron modem and that they are in negotiations not just with Rogers but also with Hitron.

 

Right now there is no fix .... although i did not try the changes on the modem settings as of yet

 

After what i heard from chromcast i have a feeling it wont work for any length of times

I've Been Here Awhile
Posts: 2

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

1: Has anyone tried a Factory Reset for Hitron modem? Does it help resolving the issue?

2: would switching to older 2.4G only modems be a solution to chromecast problem? How do we know Rogers also didn't  recently do the same mess up in other modems to block chromecast - not fixing this self-created problem  suits them as it saves them a lot of bandwidth !


@hamdan wrote:

I have Chromecast and it was working fine and I can send videos from my iPhone from YouTube and other applicable applications. Chomecast is not the only device I can cast videos on, my Samsung TV can cast as well. 

 

Now the icon disappeared from YouTube and other apps and I am not able to see the icon for both (Chromecast and TV). I tried to reset Chromecast, but the setup can not go through. Chromcast support suggested that I have to change a router setting, for example, AP Isolation is to be Disabled.

 

Note that I have't change anything I mean router or phone or app settings.

 

Thanks 

 

***edited labels***

 


 

I'm Here A Lot
Posts: 6

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Chromecast no longer works on Hitron

 

I'm not sure what happened but it seems that the Chromecast no longer works properly. Rebooting the modem restores the Chromecast functionality temporarily but after about 30 mins it's gone again even though it's connected to the network.

I Plan to Stick Around
Posts: 17

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Ok...so there is a fix. It is 100% bad firmware. Don't let anyone tell you differenly. This is a problem caused by Rogers. The update to 4.8.5.20 killed all casting. I contacted Rogers on this forum (not technical support on the phone) and asked to be rolled back to the previous firmware (4.5.8.16). The problem was instantly fixed.  Thank goodness because I had already scheduled an appointment with Bell this past Saturday, and was fully prepared to change providers. This fix has kept me a Rogers customer...that is, until the next untested stupid update they try and force on me. 

I'm Here A Lot
Posts: 7

Re: Chromecast icon is not showing/disappeared from my iPhone as well as TV casting!

Just adding my data to this thread.

 

Note that this message contains an admission that the current firmware version (4.5.8.20) is known to have/cause problems with Chromecast.

 

Maybe a week ago, my devices stopped seeing my Chromecast (older generation).  Meaning to say, the apps did not have the casting icon (rectangle with wifi waves in the corner) any more.  All manner of Chromecast hard resets, unplugs, replugs, and router power cycling did nothing.  I even went and bought a current-gen Chromecast, thinking my old one got broken, possibly by a firmware update from Google.  But both devices exhibited the same problems.

 

However, as of right now, I have both devices working.  Here's my current setup and what I did:

 

  • Router/modem is a CGN3ACSMR
  • I have no idea what firmware version is running, because I can't find it in any of the router/modem admin pages.  Current firmware version is 4.5.8.20.  (Thanks, Datalink, for showing me where to find this.)
  • I have done power cycles of the router a few days ago, but when I eventually got it working, I didn't need to power cycle the router.
  • I did a hard reset of the old-gen Chromecast (hold the button for 25 seconds while it is powered)
  • Did many unplugs (power) and replugs of the Chromecasts during my fiddling
  • I already had my DNS servers manually set.
  • Residential Gateway Function is Enabled
  • UPNP is Enabled
  • I had to temporarily disable 5G before the Chromecasts could be found using chromecast.com/setup
  • I was able to reenable 5G after the Chromecasts were set up
  • I did my set up using a screen/TV that was extremely close (less than a foot) from the router (my thinking being that this maximizes the chances of it connecting to my router instead of any neighbours, etc.)
  • chromecast.com/setup did not work from any desktop or laptop computer.  I had to use a mobile device
  • I did not do anything about "isolation", as mentioned in other places on the Internet (I don't even see such a setting in my modem config pages)
  • There are reports on the Internet of being able to connect initially at first, but then the Chromecast loses the connection after a short while.  In my case, it seems able to cast for at least a full TV show episode (20 to 30 minutes).  I am also able to reconnect after a long period of time (e.g. overnight).  Granted, it doesn't STAY connected, but I don't think it's such a big deal to tap the rectangular casting icon each day.  It takes, what, 5 seconds to reconnect?
  • At first, Shomi didn't have the Chromecast icon, but after fiddling alot with the various Chromecast-aware apps (opening, closing, restarting, etc.), eventually all my Chromecasting apps were working fine, detecting the older-gen Chromecast.

Hope this helps others.

 

At this point, I'm just waiting to see if the older-gen Chromecast holds up for a few more days without problems, then I'll return the new-gen one I just bought.

 

If anyone can tell me how to determine my router/modem firmware version, I will update this post with my version.  (Found it with some help.)