Can't load Netflix! "DNS address could not be found"

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 3

Can't load Netflix! "DNS address could not be found"

I'm all of a sudden unable to load Netflix!

 

I get the following error message: "This site can't be reached. movies.netflix.com's server DNS address could not be found."

 

I'm on Windows 7 and the Internet Connections troubleshooting tells me "Contact your network administrator or Internet Service Provider. The DNS server may be experiencing problems."

 

I've tried restarting my modem, checked the settings on my browser (Chrome), turned off Unblock-Us, etc. but nothing has changed.

 

Has this happened to anyone else?

 

***Edited Labels*** 

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 13,944

Re: Can't load Netflix! "DNS address could not be found"

That is an odd one.

Your using the default ROGERS DNS server??
Your not using a 3rd party DNS server to access USA netflix?

(reason i ask.. is that netflix is starting to BLOCK DNS based services used to bypass the geo-locking)

 

Are you able to go into a command prompt (start > run > type in cmd)

 

 

then type

 

ping movies.netflix.com

 

and

 

ping www.netflix.com