CODA-4582 - Open Issues for Investigation

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I've Been Here Awhile
Posts: 3

Re: CODA-4582 - Open Issues for Investigation

hey Datalink, thanks for your help/input. Its appreciated!

1. The performance I was getting with the R7000 in bridge mode on ethernet was degraded unfortunately, was getting results between 500-750mbps, not the 900+ I was getting with it directly connected into the Modem. So it might be the same thing where it might be an issue with broadcom and the modem possibly?

2. I'll take your advice and play around with having the wireless turn off and having the R7000 run as my wireless AP and see how that goes, hoping for some improvement. Is there anything else I should disable on the modem outside of the wireless if I am using the R7000 as an AP?


Yeah it is running stock firmware, I'm open to trying other ones if anyone else is having success with non stock.

I Plan to Stick Around
Posts: 24

Re: CODA-4582 - Open Issues for Investigation

Random disconnects with newly acquired  CODA 4582


Samsung S8 will will be working fine then without warning I will realize it has dropped the wifi in favour of LTE

All attempts to reconnect fail giving the message "cannot obtain IP address"

When the iPhone 7 does the same thing the message is "no internet connection available"

Lenovo Windows laptop seems impervious as does my iPad 3 

The laptop has a untion to operate as a hotspot and if we do that both devices will connect problem free/

The only action that resolves the issue it to reboot the router (unplug replug) the modem

Tech support chat has set up a tech to visit because "My tests are indicating that there are some possible signal issues coming into the modem." This does not give me confidence.

I hoping this is the best place to seek advice.



I've Been Around
Posts: 1

Re: CODA-4582 - Open Issues for Investigation

Hi, I'm back on rogers with the Coda-4582 (, wifi off, non-bridged) on 1000/30 service. Is anyone else seeing issues downloading files from google drive via rclone?  I was downloading a 29GB file. The file transfer ramped up to 100MB/sec in the beginning but then tanks after a minute and will sit below 2MB/sec, sometimes it will ramp up again for a short period but then it's back down to like 1.5MB/sec. It's like a roller coaster lol I'm just not getting a consistent file transfer speed. Could this new modem be the cause? I still have my cannet 100/10 service with technicolor modem. I was getting a consistent 11-12MB from google drive on it.  I was going to cancel my cannet service but now after seeing these ridiculous transfer speeds I'm wondering if I should cancel the rogers service and stick with cannet instead. I never had this weirdness back when I had rogers on 250/20 (CGN3ACSMR). Any thoughts?

I Plan to Stick Around
Posts: 12

Re: CODA-4582 - Open Issues for Investigation

Nest thermostat keeps on disconnecting from Hitron CODA  4582


Hi I'm looking for some help please. I was able to control my Nest thermostat remotely over WiFi but recently my Nest thermostat is unreachable. Nest replaced the thermostat under warranty and I've replaced the Rogers router too. I tried adding a range extender even though Nest is only 20ft from the router. Has anyone experienced this? Nest is saying to call Rogers and Rogers says they only troubleshoot PC / Mac connectivity issues, and not appliances such as the Nest.


Posts: 319

Re: CODA-4582 - Open Issues for Investigation

Hi @Doumat,


Welcome to the Community Forums, and thanks for your post!


I've been thinking about adding Nest to my setup at home as well, but have yet to pull the trigger. Having said that, I'm not super familiar with how it works just yet, but perhaps @Gdkitty's post in this thread might be able to offer some direction?  Keep us posted!



Resident Expert
Resident Expert
Posts: 14,075

Re: CODA-4582 - Open Issues for Investigation

You have gone through from scratch, trying to connect it again to your wifi?

I am using the CODA modems with the nest smoke alarms with no issues.
(though i am using the coda in bridge now with my own router)

I Plan to Stick Around
Posts: 69

Re: CODA-4582 - Open Issues for Investigation

I’m hoping @RogersDave or someone can help me. I just got the CODA modem (f/w 28T2), and I would like to use it in bridge mode. Problem is, the modem comes up with a hard coded IP address ( This conflicts with my private network (, and means I can’t use it in bridge mode.

I have an ER-X EdgeRouter that I’m going to try blocking this address with, but is there any way to change this (seemingly) hard coded IP address?

im willing to try new firmware or different modem if necessary. I’m on the Gigabit package, getting 930/30 right now, so speed is good.



I Plan to Stick Around
Posts: 12

Re: CODA-4582 - Open Issues for Investigation

UPDATE -  RESOLVED    Changed out :    CODA-4582 - Open Issues for Investigation 


Well the problem is fixed.   There is a problem with the CODA-4582 modem !    About six months ago Rogers upgraded me for free to the CODA 4582.   Since then my Nest Thermostat app has  not workeded reliably, it seems the Nest Thermostat is not communicating with the Nest Server fast enough so the Nest app on iPad, Android phone or my windows PC says the Nest thermostat is offline


Troubleshooting all without fixing the problem

- replaced the Nest thermostat

- replaced the CODA4582 modem

- Put on a range extender, even though the Nest was less than 15ft from the CODA and good signal 

- Put the CODA into bridge mode and added my own router, then a Google wifi router

All the same problem - problems with the Nest Thermostat access over Wi-Fi



- Tried setting up a wi-fi hotspot using my phone,  with my Nest thermostat and the app works, I change temperature on my phone and it changes the thermostat in about 2 seconds

- Configured my Nest thermostat to log into my neighbour's wi-fi (Bell) .    Nest works and app changes on my phone show up on Nest within 2 seconds



-  Took the drive to the Rogers store and said I would like to try a Rocket Modem (the old model modem I've had for a couple of years)    SUCCESS !    Changes in the Nest app show up within 1 second.


ROGERS:   You have a problem with the CODA modem and no matter how many times I chat or call into your support line, no one cares or shows any interest in fixing this.   Your technical reps will only support Mac or PC connectivity issues, not network appliances (or so they tell me) 

Resident Expert
Resident Expert
Posts: 6,360

Re: CODA-4582 - Open Issues for Investigation

@Doumat, were you using the wifi on the 4582, or running the 4582 in Bridge mode with a follow-on router?  Thats an important distinction as it points to where the problem might be, on the wifi side, or protocol side. 

I Plan to Stick Around
Posts: 12

Re: CODA-4582 - Open Issues for Investigation

Please see my follow on post for full details. NEST Enginnering is investigating adding the Coda router to their problematic list.

Yes I did bridge the router so it was running modem only to a Google WiFi router. No go, had to go back to the Rogers Rocket router, which works both bridged and as a router