Showing results for 
Search instead for 
Did you mean: 

CODA-4582 - Open Issues for Investigation

Retired Support
Retired Support

*** This post was last edited May 2, 2017 ***


Good morning Community,


As I mentioned in a post two days ago, we have received the next firmware from Hitron. We are currently running initial testing on this version and will push it out to participants in the firmware trial program as soon as it passes initial testing.


However, while running these tests, we discovered abnormal behavior with ICMP and are awaiting feedback from Hitron today to asses how this will be addressed. As soon as I this is confirmed, I’ll update the change log with the correct version information and start pushing it out.


In parallel, we are still working on the following high priority items. In some cases below, I requested affected customers to reach out to me via private message. If you do so, please include your modem MAC address in the subject line (even if we exchange messages daily) as there are a lot of you reaching out to me daily 🙂


UDP Packet Loss

The investigation for what has been reported as UDP packet loss is still ongoing. We have deployed a probe at one fellow forum member on both a CODA-4582 and a CGNM-3552 to collect additional data. We are actively working with Hitron and Intel on the results observed.


Based on what we know so far, in most instances UDP packet loss is coupled with higher uplink usage in the area. Although the impact is noticeable in specific logs (League of Legends), the root cause for the perceivable impact (while playing) is likely related to bufferbloat (see next issue).




When comparing the performance of a CODA-4582 to a CGNM-3552 in the same network conditions, the CODA-4582 consistently reports higher bufferbloat when tested on DSLReports.


Update April 12: The solution for this problem will come in two folds. It will require a change in software which will possibly be included in but more likely in and a change in network configuration.


The network configuration change is not compatible with the current firmware so this change will only come after a vast majority of the modems are running the new code. We are however looking at a way to make the change only for specific modems to support testing in the community.


Update April 22: This problem seems resolved in firmware



5 GHz WiFi Low range for channels 36 to 48

Lower WiFi channels on the modem have a much smaller range. This is due in part to the limit imposed by Industry Canada to maximum transmit power.


Furthermore, the current automatic channel selection (auto mode) tends to select the lower channels when in similar load conditions.


Workaround: manually select higher channels (149-153-157-161)


Update April 22: The channel selection algorithm has been improved in firmware



Loss of OFDM Channel Lock

Under some RF conditions, the modem fails to lock properly on the OFDM channel. This typically result in variable performance.


Update April 12: This problem is resolved in



List of connected device does not get fully populated

This is a known issue that has been tracked since firmware We are making improvements at every firmware but it is not a perfect system.


The situation is worst after a reboot or firmware upgrade as the list gets reset and must be repopulated as devices renew their DHCP lease.



NAT Loopback not working for wired clients

When setting up port forwarding to an internal server, it is possible for a client on WiFi to reach the server using the external IP/port. If the client is on a wired interface, it doesn't work.


Update April 12: This problem is resolved in (not confirmed)



LAN Counters not working

Some customers reported that LAN counters (especially in bridge mode) are reporting inaccurate values.


This problem has been reported to Hitron for investigation.



Unexpected modem reboot

Some customers reported their modem reboots unexpectedly. We have also seen this behavior in our lab.


Update April 12: This problem is resolved in



Missing SC-QAM Channels

After a reboot, some modems are missing SC-QAM channels. A fix has been implemented in to address this behavior but it has not corrected all scenarios.


Investigation continues with Hitron.



WiFi Survey

The WiFi Survey functionality in firmware (and possibly before) reports incorrect SSID names.



Guest Network

When connecting to the Guest Network, an error message is displayed "only allow DHCP client to use this wireless".  This has been reported in firmware


Update April 22: This issue has been resolved in firmware

Update May 2: It seems this issue is not fully resolved and still experienced by some users


Future Planned Improvements

The following are items that we are working on in parallel of the above.

  • Improvement in WiFi speeds
  • Improvement in latency / bufferbloat





*Edited Labels*

2,620 REPLIES 2,620

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Take a look at my detailed troubleshooting. With only the router, an iPad and the Nest thermostat, it did not work. I do have a V2 Nest thermostat though.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

To say this is becoming frustrating is an understatement.

We have had the new modem approximately 2 weeks and we have had a tech out once and chat support has another on the way.

I may have resolved how the samsung S8 connects by setting a fixed IP address, but the iPhones refuse to interact with this gateway.

The only solution we have found is to unplug and replug the modem when the phone cannot get internet.

What happens when the modem is restarted like that??

Can this info not be used to pinpoint the issue?

Chat guy said ", the signal appears weak to the modem. Just to confirm, has there been any changes made to the Rogers cable installation in the home such as added new wires or splitters?" well the tech that visited said the signal was too high and added a splitter to reduce the signal by -7db. 

I think that the signal is within spec (highest is 8.000 and lowes around 0) it feels like fluff when the chat guy wants to send a tech. He did says "I think it is the modem from what you are describing" and agreed to have the tech bring a modem.

I am still seeking an answer to "what happens when I "reboot" my CODA modem?" because I can't believe that the solution is not indicated by the fact that this works every time and instantly to get all affected back to being connected to the internet.




Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

This is what I have been experiencing as well. The wifi gets disconnected after a certain time and would give a 169.xx number as its IP. A reboot is necessary to get it to work again. At first, I thought it was one of my devices having an issue so I changed it to a static address and it has been stable so far.

Not sure if the CODA modem/router has a DHCP issue with the assignment of IP addresses.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I have seen others say this an I should have listened.

Added D Link DIR 885L we have had 48 hrs of bliss.

Hopefully this is a permanent solution.

My family does not care so much about speed as connectivity.

I hey high 700s from speed test with ethernet connected Lenovo laptop.

So as much as it sux to spend $$ on a router I think this is the only reliable way to enjoy this new gateway untill Rogers fixes it.




Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

This isn't specifically a Rogers issue. Majority of Internet gateways suck! And its why people recommend you get a real router for many years now. A device that tries to do many things will never be better than a device that is dedicated to doing one thing.


I'm surprised so many people still continue to fight this battle.



Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

I have had this issue three different times and it seems to happen like clockwork every 3 to 4 months.  My upload seems like it is capped at 10Mbps (it has not gone past this in a few days testing both day and at night), I am on the 500/20 plan and I always (when its working correctly) get the offered speed both up and down.  My modem is bridged, I use an Asus AC5300 router and have for some time now plus I have done the typical things .. rebooted the modem, reset the modem, tried the speed tests with the computer connected directly to the modem .. all the things Rogers asks you to do when you call and each time this has happened they have told me to go a swap the modem for a new one, that actually does work and does bring back the correct speed but why is this happening in the first place?  Can I PM someone and have them look into this please, it's get a little tiresome to have to exchange modems all the time and would like to find out what causes this if it is possible.


Current speed test results

12 latency
5 jitter




9 latency

4 jitter

Re: CODA-4582 - Open Issues for Investigation

I'm a senior contributor

I have noticed that both my PC's have had issues obtaining DHCP IP address when doing a renewal after 1 week.  It would either get an address after some delay, or I would have to reboot the PC again to get it.  

Re: CODA-4582 - Open Issues for Investigation

@lighter wrote:

Yeah don't listen to what they are saying. I switched back to an older modem and my speeds on testmy are consistent.... the COD (WHITE Modem) is trash!!! Rogers just doesn't want to admit it! I had no issues till I went to that modem... I have gone back to the older one... can't stant the packet loss and rogers believes speedtest (flash based trash is true yet when I am connected to my work VPN and I am dropping every 2 - 3 minutes now.. and has nothing to do with my works VPN servers... everything to do with my inconsistent and packet losing internet connection...

I have similar issues. I "upgraded" to the white modem about 2 weeks ago and can't keep a consistent download speed from the usual places. Steam used to max out my 250/10 connection easily, but now with 1000/30, downloads will be all over the place ranging from 0 to around 50MB and stalling at 0 for long periods of time throughout. I spoke with someone at Rogers and they apparently updated the modem from their end including reboot and asked me to use SpeedTest. SpeedTest showed around 950mbit which is complete B.S. considering I can't get over 50mbit from ANY of the other speed test sites, Steam, usenet, linux distro downloads etc. Very disappointed with this so far.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around


So today my house mate and I have been having this issue where the Ethernet connections to our modem ( CODA -4582U ) the wifi still works but the Ethernet connections will drop and then reconnect and then drop again after awhile. I tried unplugging for awhile and plugging it back in but that only helped for like 30 minutes.

Anybody know what might be causing this?

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Regarding my wifi issues wherein I lose the ability to connect to the CODA wifi after some time ( I have to reboot the CODA to re-establish the ability to connect to wifi).

This is what I see from my wireless device after a reboot:



And this is after some time:




Any idea on why this is happening on the CODA? I did not have any of these issues with the older black modem/router. Thanks in advance.


Edit: Re-attached screenshots

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
I found the CODA modem extreamly problematic including issues like your problem. I ended up going back to the black modem, having Rogers put it in bridge mode and bought a Google wifi mesh router system. ( 2 units to cover a 3 story townhouse). Beyond all the problems with the Coda modem, no modem/router from Rogers would give me adequate coverage and speed. The Google wi-i works, wifi is stable and a solid signal with excellent speed in the hiuse, garage and on the patio

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Thanks for the reply. In a sort of bad way, it is good to know that I am not alone with my issues.

Re: CODA-4582 - Open Issues for Investigation

I'm a senior advisor

I think that many of us are in the same boat with the reality of the layout of our homes.  Definitely the description of a 2 story townhouse, is probably similiar to my challenge - a very narrow, long linked home, with a ton of walls.


The solution of the Google WIFI gives you a wireless mesh solution and can be easily expanded on.


Others have used a router in bridge mode in a better location.


In my home, one of the worst spots is right where the cable connection got put for the modem, against a sheet of drywall separating our office/basement rec room from the furnace room.  The signal has to pass up through 3 feet of drywall, a steel support I beam, and a couch, with the furnace and lots of electrical behind that wall all causing interference.  The best location, we now know would have been our living room on the first floor in the middle of the house, away from transmitting through a vertical wall, and no steel beams, and no electrical, but when we installed, we had wired connections throughout the house, no WIFI devices, and ever since we went WIFI, we have been struggling to find the best solution.


Currently my solution is a wired connection to a D-Link 1620 extender which can be a repeater on wireless or wired as I have done, turn off the 2.4 to avoid any further saturation on that frequency, and only unfortunate thing is that we have to switch our connections as we move around the home, but I named the WIFI SSID as west side from the router on 2.4 and 5.0 and from the repeater east side on 5.0 only to make it easier to know which network signal I should be on.


I have gone the bridged router route with improvements before 5.0 came along and before my 2.4 was totally saturated from my neighbours, then I went the router, with another router on the upper floor acting as an access point - basically the same as the 1620 does.


I looked at the Google WIFI solution that was on sale last week on black friday sales, but they were out of stock, and the repeater was also on sale for under 50.00, so I went that route.  I am not fully satisfied, it is a compromise, but the reality of the layout of my home.  I can't blame Rogers or Hitron for the reality of how WIFI signals work, and the architectural layout of my home.  So I work the solutions.


Thanks for telling all of us what you did, it allows us all to become educated on how to work with the reality of the limitations of WIFI, interference, electrical structural walls and so forth.


Good luck with your solution.



Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Good luck Bruce. FYI on the Google wifi sale, (if your existing system diesnt work well) a number of retailers have had and may have the sale again. Best Buy, Visions, and Walmart

Good luck,

Re: CODA-4582 - Open Issues for Investigation

I've been around
Everything was working fine with 28T2 firmware, never lost connection. Losing connection now at least once a day on 33T3.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around

Not sure if this is a CODA issue, but we have a Samsung Camera that in the past we were able to connect to wifi to share pics.    Now all of a sudden we are unable to do so.  Took the camera in for repair and they reset the wifi internally on the camera.   Brought it home and it does not work here.    All other devices connect without issue, camera gives me the error "reconnect to the ap or ensure that the ap is available".    Have rebooted the camera and the Coda and nothing, also tried manually entering SSiD and credentials.     Next step will be trying wifi at friends house or work.     

Re: CODA-4582 - Open Issues for Investigation

I've been here awhile

Had a similar issue with a printer which wouldn't connect. Found out that it would connect without issue on the 2.4G band. Is your CODA setup to accept 2.4G connections? Have you allowed g/n mixed mode? Hope it works.....

Re: CODA-4582 - Open Issues for Investigation

I've been here awhile

I've switched my modem 3 times already, spoken to technical support varies times. Even have an interaction number after I've escalated the issue, which I receive a call about every week. Technical Support and even the Hitron Engineer still cannot pin point the root cause. Hopefully you guys can give me some ideas, since this issues is almost at 3 months long.


Has anyone faced issues with not connecting to ipv4 sites (ipv6 sites work perfectly fine) on devices wired or wirelessly connected to the Hitron CODA-4582 Router (FW: 33T3)?


We've tried the following...

  1. Technician onsite to check signal
  2. Changed Router 3 times (issue first raised with AC Router) 
  3. Factory Reset several hundred times
  4. Upgraded Firmware to newer version and older version
  5. Disabled IPV6
  6. Re-allocated connected devices between 2.4 vs. 5
  7. Removed all wireless devices and test with wired devices (and vice versa)
  8. Tested with only 1 wired or wireless device

I've ran an test and its unable to connect to ipv4 "unsupported" on one device but successful on another device.  For any device that fails it states that the DNS6 + IP4 is unreachable.


Hope you guys have an insight to resolve this issue.

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
Have you tried going back to a non CODA modem. I had VERY poor support from Rogers on the CODA, so went to an older modeland the problems went away

Re: CODA-4582 - Open Issues for Investigation

I plan to stick around
So tried other wifi access points and get same error code. Guess it is going back to Samsung.

Re: CODA-4582 - Open Issues for Investigation

I've been here awhile
The issue started with the older modem first Advanced Wi-Fi (black modem) which i had for 3 years, then I went to the CODA modem.