No signal on Rogers Box --> Projector?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I'm Here A Lot
Posts: 5

No signal on Rogers Box --> Projector?

I recently purchased an Epson 5050ub projector for my home theater, routed power and HDMI cables, all for it to be in vain because the Rogers Xi6-T box doesn't seem to want to connect to the projector. Other devices work fine, such as an XBOX 360 and a Samsung Blu-Ray player. Alas, the Xi6-T doesn't send an output. Does anyone have a fix?

Highlighted
Resident Expert
Resident Expert
Posts: 3,355

Re: No signal on Rogers Box --> Projector?

Here are a few comments/questions:

 

1. How long is your HDMI cable from the box to the FP?  Is this cable 4K compatible?  Have you tried a short cable temporarily?

2. Are you connected directly to the FP or are you going "through" an AVR (audio video receiver).  Try connecting directly as a test if you're going through another device first.

3. Try connecting the box to another TV and set the video output to 4K instead of "auto".  Try 1080i as a test?

4. Have you updated the firmware in the FP?  Sometimes there are handshake issues if the firmware doesn't talk well to the box.



Highlighted
I'm Here A Lot
Posts: 5

Re: No signal on Rogers Box --> Projector?

1. How long is your HDMI cable from the box to the FP?  Is this cable 4K compatible?  Have you tried a short cable temporarily?

 

The original cable is about 100 inches long, and I have tried a shorter cable. The cable is 4k compatable.

 

2. Are you connected directly to the FP or are you going "through" an AVR (audio video receiver).  Try connecting directly as a test if you're going through another device first.

 

I've connected directly and with an AVR

 

3. Try connecting the box to another TV and set the video output to 4K instead of "auto".  Try 1080i as a test?

 

I don't have any 4k monitors in my house, but I know someone who does. I'll try that. Also, I have tried 1080i.

 

4. Have you updated the firmware in the FP?  Sometimes there are handshake issues if the firmware doesn't talk well to the box.

 

I have updated all firmware

 
Highlighted
Resident Expert
Resident Expert
Posts: 3,355

Re: No signal on Rogers Box --> Projector?

Do you have another box in the house that you could try connecting directly to the FP?  Since you've done everything else, it could be a bad box.

 

Have you tried connecting the "bad" box to another TV in the home?  Doesn't need to be 4K.



Highlighted
I'm Here A Lot
Posts: 5

Re: No signal on Rogers Box --> Projector?

Yeah, the "Bad" box works fine with other TV's, but other boxes don't seem to work with the projector.

Highlighted
Resident Expert
Resident Expert
Posts: 3,355

Re: No signal on Rogers Box --> Projector?

So, if the boxes work with other TVs, there must be something odd about the FP working with the Rogers boxes.  Perhaps contact Epson to see if they have any suggestions?  Does the FP have other (HDMI?) inputs that you could try directly from a box?  Try "hot plugging" the HDMI cable after starting the box and the FP?  Make sure you wait a few seconds for the handshake to take place and try it with a box set to 1080i first?



Highlighted
I'm Here A Lot
Posts: 5

Re: No signal on Rogers Box --> Projector?

Hot plugging didn't work. Epson support is closed right now, so I will contact them tomorrow.