Netflix not working with Ignite TV

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I'm Here A Lot
Posts: 5

Re: Netflix not working with Ignite TV

I am having this problem now. Just started happening. When I click on the the Rogers Menu button>Apps>Netflix it shows 3 dots (trying to access the app) and then nothing happens. I tried to reset and nothing happened.

I'm Here A Lot
Posts: 5

Re: Netflix not working with Ignite TV

A reset of the Ignite TV box fixed the problem I was having accessing the Netflix app.

I've Been Around
Posts: 1

Re: Netflix not working with Ignite TV

We recently switched to Rogers Ignite. Up until now Netflix  has worked fine by using voice activation. All of the sudden it is no longer switching to Netflix, though it will go to other channels. We found a thread outlining solutions, including getting the app to be reset in Rogers, but it still does not work.


Any suggestions.

Posts: 2,099

Re: Netflix not working with Ignite TV

Good evening @DRrad,


Thanks for your post! The great thing about Ignite TV’s all-in-one search is that if you have a Netflix account, you can search for Netflix content without even entering the app.


Simply use a voice command like “Netflix originals” or “Stranger Things,” and watch as results pulled from Netflix appear instantly. But if you want to open the app itself, here’s how to do it:

With a voice command:

  1. Press and hold the Mic button on your Rogers remote.
  2. Say, “Open Netflix,” or “Netflix.”
  3. The Netflix app should open instantly.

Without a voice command:

  1. Press the Rogers button on your Voice Remote to open the main menu.
  2. Select Apps.
  3. Select Netflix.
  4. The Netflix app will open.


We tried to replicate the issue on our end, but we were able to load up Netflix without any issues using voice command.


What is the issue you are experiencing? Have you tried to reboot your Ignite TV equipment?


Let us know if you still need our help!