IgniteTV Surround Sound

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: IgniteTV Surround Sound


@Kromtara wrote:

The receiver says it is receiving Dolby D+.  Normally PCM lights up on the receiver if it sees PCM.


I'm guessing that your AVR is receiving "improperly encoded DD5.1", which your AVR interprets as DD+, which contains only the LF & RF speaker signals, as discussed in this and the other thread for Ignite recordings. Your AVR is currently set to decode these signals to provide (synthetic) surround sound (see link below).  Most people who leave their AVRs set up properly for incoming DD5.1 signals end up with only the LF & RF speakers being active for Ignite recordings.

 

You will probably not see PCM unless you change the audio settings in the Ignite box to "other" instead of "expert"?  Changing to "other" is also a workaround to get surround sound by invoking DPLII in the AVR for the incoming 2-channel signal from Ignite recordings.

 

Edit: 

@Kromtara : I see from your other recent post (Item 4 of link below) that you are using a "simulated" surround sound.  This is not true DD5.1.  You would also have sound coming out your surround speakers if you set it to something like "7-ch Stereo", however, again, this is not true DD5.1 and the sound is not being reproduced as intended, even if your surround speakers are active.

 

https://communityforums.rogers.com/t5/Ignite-TV/IgniteTV-Surround-Sound/m-p/452754#M4503

 

I have encountered lots of people during my optimization travels who utilize "7-ch Stereo" (or something similar) because they want to hear sound from all of their speakers, however, this doesn't provide the discrete audio from the various speakers that the director of the original programme intended.  In many cases, like a news programme, the dialogue will/should come out the centre speaker and nowhere else.



Highlighted
I'm Here A Lot
Posts: 5

Re: IgniteTV Surround Sound

Hi @DDave_ca . I have run into the exact same problem as you. I tried calling Rogers tech support as it seems only to be a problem with input coming out if the ignite box. All others seem fine - PlayStation, blue ray disc player, etc. The tech support can’t help me either. Wondering if you got it solved and how?
Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: IgniteTV Surround Sound

@Lott : As discussed extensively in this and other threads:

 

1. You need to set the audio output setting of the Ignite box to "Expert" and you should get properly encoded DD5.1 on any live or on-demand programming that you watch.  Assuming you're connected directly to an AVR from the Rogers Ignite box.

 

2. If you're going "through" a TV, then you'll need to properly set up the output audio from the TV's optical (or HDMI-ARC) signal to "DD5.1, or Raw or similar setting and not PCM.  I've provided previous links on that topic in this thread.

 

3. With any recorded programming, even if everything is set up properly, you will get a DD5.1 signal at the AVR, but the audio will come out the LF & RF speakers only because that's currently what's happening on recorded material with Rogers Ignite. At some point in the future, this should get fixed.

 

4. Although it's possible to override the incoming incorrect signal from recordings using something like "5/7CH Stereo" in the AVR, you will not experience the audio as originally intended.

 

5. Most of what I've stated above relates to HD channels, the majority of which provide properly encoded DD5.1 signals.  For SD channels and some HD channels, the audio signals are DD2.0 and can be decoded by DPLII in the AVR to provide surround sound.  Some HD channels are such outliers - Global is currently DD2.0, as is CTV2 and CP24. CBC (and some PBS) can be "improperly encoded" DD5.1 when the original programme is not DD5.1.



Highlighted
I'm Here A Lot
Posts: 5

Re: IgniteTV Surround Sound

Thanks for the response @57. My TV is a bit old and does not have an HDMI-ARC port for my SONOS sound bar. So I used the SONOS-supplied optical output to HDMI converter, connected to SONOS. Then I have the ignite box, PlayStation, and blue ray disc player connected to my TV via its Input HDMI ports. Only the ignite box seems to have a problem playing sound through Sonos. I will try your suggestions above again I a while, but I swear I tried the expert setting in the ignite and still didn’t work.

I am not very well versed in this audio tech lingo, but I hope I explained it well enough. I have a sharp aquos TV that also seems to assume a tech savvy user. 😬
Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: IgniteTV Surround Sound


@Lott wrote:
I used the SONOS-supplied optical output to HDMI converter, connected to SONOS. explained it well enough.  😬

Not sure why you're using this at all. If all of the devices are connected to the TV via HDMI, why not simply connect the TV's audio output optical port (properly configured for "external" speakers and DD or Raw) to the Sonos?



Highlighted
I'm Here A Lot
Posts: 5

Re: IgniteTV Surround Sound

That’s exactly what I did, but for some reason the sound is not coming out of Sonos for ignite but the others (disc player and PlayStation) are. 😩
Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: IgniteTV Surround Sound

@Lott : Here are a couple of things to try/experiment with.

 

1. Try feeding the Ignite HDMI cable to a different input on the TV - one you know works for the other devices.

 

2. Try setting the Audio output format on the Ignite box to "other/PMC" if there is such an option.

 

3. Try swapping the HDMI cables. There may be an issue with the one you're trying for ignite - again, use a cable that you know works for other devices?

 

Good Luck.



Highlighted
I'm Here A Lot
Posts: 5

Re: IgniteTV Surround Sound

Hi @57! Firstly, thanks so much for taking the time to help me with this problem. I haven’t been exact with my set up so really sorry! Right now, I have one HDMI input cable from tv connected to an HDMI switch box that is connected to my three sources (ignite, PS and disc player). So I am pretty sure it has not to do with the cables. Before I ended up with this set up, I have tried what you described, switching cables directly to each and every one of my devices. It is only the ignite box that doesn’t work.

In the #2 suggestion, I went to the Rogers settings, then device settings menu, then Audio, then HDMI audio output and selected STEREO (other options were auto detect and expert mode). Is this what you meant? This is what I did, and no success.

I am starting to think this issue is something specific to how ignite passes through sound to tv and a setting that I can’t seem to figure out, not my connection set up.
Highlighted
Resident Expert
Resident Expert
Posts: 3,619

Re: IgniteTV Surround Sound

@Lott : I'm not sure if you've tried this yet, but try connecting the Ignite box directly to the TV without going through the HDMI switch.  If that doesn't work, I'm probably out of ideas.



Highlighted
I'm a Reliable Contributor
Posts: 218

Re: IgniteTV Surround Sound

For cripps sake, when is this problem going to be fixed???!!  Soon will be 2 months, rogers stated it will be fixed shortly, ha ha.  Now programs recorded on Global have no surround sound and now the sound has an echo and sounds like garbage!  Why o why did I switch to Ignite?