cancel
Showing results for 
Search instead for 
Did you mean: 

IgniteTV Surround Sound

DDave_ca
I've Been Here Awhile

Hello!  First post...

 

Long time Rogers customer, new Ignite subscriber.  Any Ignite customers having trouble getting surround sound (DDS5.1) to work from these Ignite TV boxes?  In the settings, I have tried both Auto and Expert (forced surround sound), but neither work.

 

My connection is not HDMI direct to my surround receiver - it only has optical (toslink/SPDIF) input.  My Panasonic TV has optical output.  I have DDS5.1 when using the smart TV for Netflix playback - not from the Rogers Netflix app.  I also tried using an audio extractor/splitter - same results.

 

Thoughts?

 

*** Edited Labels ***

135 REPLIES 135

Re: IgniteTV Surround Sound

Lott
I'm Here A Lot
That’s exactly what I did, but for some reason the sound is not coming out of Sonos for ignite but the others (disc player and PlayStation) are. 😩

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Lott : Here are a couple of things to try/experiment with.

 

1. Try feeding the Ignite HDMI cable to a different input on the TV - one you know works for the other devices.

 

2. Try setting the Audio output format on the Ignite box to "other/PMC" if there is such an option.

 

3. Try swapping the HDMI cables. There may be an issue with the one you're trying for ignite - again, use a cable that you know works for other devices?

 

Good Luck.



Re: IgniteTV Surround Sound

Lott
I'm Here A Lot
Hi @57! Firstly, thanks so much for taking the time to help me with this problem. I haven’t been exact with my set up so really sorry! Right now, I have one HDMI input cable from tv connected to an HDMI switch box that is connected to my three sources (ignite, PS and disc player). So I am pretty sure it has not to do with the cables. Before I ended up with this set up, I have tried what you described, switching cables directly to each and every one of my devices. It is only the ignite box that doesn’t work.

In the #2 suggestion, I went to the Rogers settings, then device settings menu, then Audio, then HDMI audio output and selected STEREO (other options were auto detect and expert mode). Is this what you meant? This is what I did, and no success.

I am starting to think this issue is something specific to how ignite passes through sound to tv and a setting that I can’t seem to figure out, not my connection set up.

Re: IgniteTV Surround Sound

57
Resident Expert
Resident Expert

@Lott : I'm not sure if you've tried this yet, but try connecting the Ignite box directly to the TV without going through the HDMI switch.  If that doesn't work, I'm probably out of ideas.



Re: IgniteTV Surround Sound

Square
I'm a Reliable Contributor

For cripps sake, when is this problem going to be fixed???!!  Soon will be 2 months, rogers stated it will be fixed shortly, ha ha.  Now programs recorded on Global have no surround sound and now the sound has an echo and sounds like garbage!  Why o why did I switch to Ignite?