Ignite stuck on Welcome screen

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 2

Ignite stuck on Welcome screen

My ignite box has been stuck on the Welcome screen for nearly an hour now - every so often I will get a black screen, then the Welcome screen comes back again.
Internet is working and our other box in another room is working normally. Any tips would be most appreciated!
Solved! Go to Solution.

Accepted Solutions
Highlighted
I've Been Here Awhile
Posts: 2

Re: Ignite stuck on Welcome screen

Ended up getting touch with customer service, and they concluded it was a box issue and will be sending a technician with a new box. They did say it is a known issue with no other solution. Thanks everyone for weighing in!

View solution in original post


All Replies
Highlighted
I've Been Around
Posts: 1

Re: Ignite stuck on Welcome screen

Ignite TV been stuck welcome screen 3days now

Highlighted
I've Been Here Awhile
Posts: 3

Re: Ignite stuck on Welcome screen

I'm having the same problem. For about 24 hours now. Only on 1 of 4 cable boxes. Nothing is working. Not unplugging box. Or main modem. Am trying a system refresh (new option added in help screen). So far nothing. 😒
Highlighted
Resident Expert
Resident Expert
Posts: 698

Re: Ignite stuck on Welcome screen

We had a widespread issue that was similar to this about 5 weeks ago.  The solution was to first power-cycle the XB6 modem and then (after the status light turns solid white) power-cycle each set-top-box.



Highlighted
I'm Here A Lot
Posts: 5

Re: Ignite stuck on Welcome screen

The stuck on welcome screen happened for me as well on a single box. After multiple router and box re-boots I called Rogers and a technician came and replaced the box.

Highlighted
I've Been Around
Posts: 1

Re: Ignite stuck on Welcome screen

just had the fourth or fifth ignite box failure...this is beyond ridiculous ...

Highlighted
Resident Expert
Resident Expert
Posts: 3,242

Re: Ignite stuck on Welcome screen

Although a box can sometimes fail, it's almost impossible to have 2 or more box failures, much less 4-5.  This indicates to me that you have another issue. It's almost always related to signal problems at your home or in your neighbourhood.  This was proven time and again with digital cable and is being repeated on IgniteTV.

 

Although a new box sometimes seems to solve a problem, most people find that the problem will return shortly because the problem was not the box.  With many IgniteTV installations utilizing WiFi, that brings another parameter (poor WiFi, or WiFi interference from say neighbours or whatever connection you have between the various boxes) into play.  So that needs to be checked properly also.



Highlighted
I'm Here A Lot
Posts: 5

Re: Ignite stuck on Welcome screen

I have the exact same problem as you. Tried resetting box . That didn't work .  This really aggravating, its the Livingroom one that is stuck.  Its the main one.  

Highlighted
I've Been Around
Posts: 1

Re: Ignite stuck on Welcome screen

Exactly the same problem that i'm seeing. I have 6 boxes, 5 work fine but one is stuck on the welcome screen. Incidentally, it is also the main one,  closest to the Modem is the one frozen. Rebooted everything multiple times in multiple orders and it didn't fix it. 

Highlighted
I've Been Here Awhile
Posts: 3

Re: Ignite stuck on Welcome screen

Same or similar problem. One is stuck on the welcome screen and another on the picture screen. The 2 other boxes in the house are fine, internet is fine, phone is fine. Rebooted everything multiple times.  After chat with Rogers support, moved to Tech support. They decided it was a software problem (their words, not mine) and both boxes need to be replaced. Everything was brand new in boxes as of Sept 26th so 2 weeks! Not a signal strength problem - checked by Rogers 2 weeks ago + everything else works fine. Not a WiFi problem (checked by Rogers + one sits perhaps 12 feet from the Rogers Ignite Router and the other perhaps 8 feet from a Rogers repeater). One of the 2 boxes that still work is MUCH further away. Very frustrated.