Ignite TV Yellow/Green Screen issue on RCA TV

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 59

Re: Ignite TV Yellow/Green Screen issue on RCA TV

so Rogers tell me that a firmware update wasn't sent out! What the heck! So I changed Power Savings back to 'on' and restarted the box, and my TV works again. Does it seem like they don't know what the heck they're doing. We'll see what happens tomorrow, but it's been fine for about 5 hours now. 

Highlighted
I've Been Here Awhile
Posts: 2

Re: Ignite TV Yellow/Green Screen issue on RCA TV

I have the same issue and I have a Samsung 4k. It happens every time the tv has been off for a while, then when I turn it on again it's yellow/green and then goes black. The fix is to disconnect the pvr box power cable for 10 seconds ago, and then it's fine for as long as it's on. But then the next time I turn the tv on again, same problem. I had a Rogers technician come over and install a network (apparently, this network has been available from Rogers for about 3 months now; wasn't available when I first got Ignite back in August 2018. Techie thought the network would fix the problem, plus he gave me a new pvr box. Nope. Same problem.

Highlighted
Moderator
Moderator
Posts: 1,055

Re: Ignite TV Yellow/Green Screen issue on RCA TV

Hello, @Zimby

 

Welcome to the Rogers Community Forums!

 

I can understand how inconvenient this issue must be for you. We definitely want to investigate this fully to see if we can find a solution. Have you tried using a different HDMI cord to see if there is any improvement? Is that the same cord that came with the Ignite TV box or one that you had for the TV previously?

 

This is the first time we have heard of this issue affecting a Samsung TV, most report this issue occurring on RCA TVs and other similar models.

 

We look forward to your response!

 

RogersTony

Highlighted
I've Been Here Awhile
Posts: 2

Re: Ignite TV Yellow/Green Screen issue on RCA TV

Re: Ignite TV Yellow/Green Screen issue on Vizio TV

 

Hi,  Well I am going to jump in on this post.  I have two Vizio TVs that are doing the same thing.  Numerous calls to rogers and to the manufacturer (Vizio).  No one seems to have a solution.  Both say it is a compatability problem and could be Comcast that provides the modem (arris xb6). Did every trouble shot imaginable and still same yellow screen.  Smartcast works fine and DVD players so there is nothing wrong with the TVs.  All other tvs in house work fine. One TV is 75 inch so not too anxious to replace.  Every time I call, I have to explain the same thing over again and they say they are not aware of the issue.  Even sent the address to this post. Very frustrating

Terry

Highlighted
I Plan to Stick Around
Posts: 59

Re: Ignite TV Yellow/Green Screen issue on RCA TV

I have found a kind of work around as follows:
Go into settings, by pressing the Rogers button & choose the gear icon, then Device Settings-Power Preferences, and set Power Saver to ON. This will make the Ignite box shut down overnight. The next morning, start & see what happens. If you get a snowy screen with crackling noises, unplug the box for 10 secs. Then it should start up normally. This works for me almost all the time & on occasion, the TV starts right up, but not often. It's a pain & not a fix, but I can watch my TV. Let me know if this works.

Highlighted
I've Been Here Awhile
Posts: 2

Re: Ignite TV Yellow/Green Screen issue on RCA TV

Thank you for the suggested work around.  Unfortunately it didn't work for me.  Tried it twice but still unsuccessful.  It would seem that Rogers should take the lead on this as we are a bit helpless to resolve the issue.  Need real expertise to figure out why it is caused on specific TVs and the solution.

Highlighted
I've Been Around
Posts: 1

Re: Ignite TV Yellow/Green Screen issue on RCA TV

I am also having this issue on a Samsung 4k tv. So far resetting the cable box once a day has worked, but I don't know for how long. Screen goes green/yellow and no sound. Reboot the box and it is fine for the rest of the day.
Highlighted
Moderator
Moderator
Posts: 1,326

Re: Ignite TV Yellow/Green Screen issue on RCA TV

Hello and welcome to our Community @Jazzman16!

 

Have you checked to make sure your Samsung TV is fully up to date and has received all its firmware updates?

 

Regards,

RogersCorey

Highlighted
I've Been Here Awhile
Posts: 3

Re: Ignite TV Yellow/Green Screen issue on RCA TV

This green screen/no sound issue is not exclusive to RCA TV's. It also is simulated through receivers such as my Onkyo receiver. I have tried all of the fixes like HDMI cable switching, Rogers box switching, etc., to no avail. I believe that the signal is too weak to display/provide the required signal to produce the correct color and sound. The final word from a low level technician was that it would require a software update which is not yet available. He then put me on hold in order to escalate, and without notice, disconnected me? And, btw, the screen changed to green and no sound directly after a scheduled daily Rogers software update...prior to the update commencement, I did not touch anything and was just watching TV.

Highlighted
I've Been Around
Posts: 1

Re: Ignite TV Yellow/Green Screen issue on RCA TV

I'm experiencing the same issue on a Samsung 4k. I switched with another box which resolved the problem briefly, but it came back. I changed to a new HDMI cable... Fixed for a few hours and now it's green again.