Hooking up Rogers Ignite to an Onkyo Receiver - need help!

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Here Awhile
Posts: 3

Hooking up Rogers Ignite to an Onkyo Receiver - need help!

So our receiver is an Onkyo AV Receiver TX-SR333. Our TV is older (but HD), an Emerson LC320EM2. For reference, that TV doesn't have a digitial optical port.

 

So, how do I hook this up? I thought just HDMI cable from box to receiver and then receiver to TV would be enough but apparently not?? Help appreciated!!

 

 

***Added Labels***

Solved! Go to Solution.
Resident Expert
Resident Expert
Posts: 13,877

Re: Hooking up Rogers Ignite to an Onkyo Receiver - need help!

Just looked up the specs on both the TV and receiver.

Everything has HDMI.  That is your best bet.

HDMI from the ignite, into one of the inputs on the receiver.  
HDMI out from there into the one HDMI into the TV

 

Looks like the TV only has one HDMI.. so you would want to make sure any/all devices go through the receiver.



Resident Expert
Resident Expert
Posts: 2,811

Re: Hooking up Rogers Ignite to an Onkyo Receiver - need help!

That TV is 1366x768 Pixels, so set the output format on the Rogers box to 1080i.  It may not be working because the box may be set to 1080P or 4K. Should be under "Settings" somewhere.

 

You may need to temporarily connect the box directly to the TV to set the box' output format.



I've Been Here Awhile
Posts: 3

Re: Hooking up Rogers Ignite to an Onkyo Receiver - need help!

I've tried both of these (the hdmi to box/tv thing was the first solution) and nothing. Any other ideas? Thank you, though!

 

To be clear, the receiver works. We were literally using it for the old cable box before the ignite guy came. So idk.

I've Been Here Awhile
Posts: 3

Re: Hooking up Rogers Ignite to an Onkyo Receiver - need help!

Sooo I fixed it by fiddling with buttons but in a million years I don't know how it fixed. Whatever! Thank you.