4K channels not working

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

4K channels not working

4K channels not working. I have already restarted the Ignite TV box and speed test on internet is showing sufficient speeds. Anyone else having issues?

Highlighted
Moderator
Moderator
Posts: 151

Re: 4K channels not working

Good evening @StavrosH,

 

Welcome to the Rogers Community Forums and thanks for posting! 🙂

 

We don’t want you missing out on the awesome picture quality 4K brings! With a bit more information, I’m sure the Community can assist you. 

 

1.    Have the 4K channels worked in the past?
2.    Are you getting any type of error message on the screen or is the picture degraded?
3.    What brand/model of TV do you have?

 

We’re looking forward to your reply!

 

RogersTim

Highlighted
I've Been Around
Posts: 1

Re: 4K channels not working

Lg TV, changed settings as recommended for 4 K and getting invalid format, have sound but cann change sett back. Then get no signal
Highlighted
Resident Expert
Resident Expert
Posts: 3,237

Re: 4K channels not working

@Lily_snowfinlay : A few comments/questions:

 

1. What is the exact model number of the LG TV?

2. Have you tried a different 4K compatible HDMI cable?

3. Have you tried a different HDMI input on the TV?  On some TVs only some inputs are 4K - check the operating manual.

4. Have you tried 1080i as an output format under settings just as a test?

5. Are you connected directly to the TV?  If you're going through an AVR, what is the make/model of that Audio Video Receiver?  Any other equipment involved?