Signing in

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OLDYELLR
I'm a Senior Advisor
Posts: 3,804

Re: Signing in

It's been back to the "new normal" the last 2 days. Signing in with Firefox I get the endless loop, have to use a workaround. 😫


Rogers PayGo. Location: S-W Ontario
jays77
I'm a Trusted Contributor
Posts: 728

Re: Signing in

It took me about 20 minutes tonight to get signed in. I usually I can sign in with Edge In Private Browsing no but no luck tonight. Tried a few times with Chrome Incognito and finally got signed in.

57
Resident Expert
Resident Expert
Posts: 4,171

Re: Signing in

When I signed in today, after providing my username and password, there was an additional pop-up regarding adding a phone number for recovery purposes.  I asked to skip that step (in future?).

 

I was then taken to Rogers main page instead of the forum, however, I used my regular "all posts" bookmark and was taken to the forum without issue.

 

I then signed out and signed back in as a test without issue.  Using Chrome on a Mac Mini.

 

Again, make sure you don't have any extensions or blockers (pop-up) that may impact your sign in process.

 

https://communityforums.rogers.com/t5/Internet/Unable-to-load-certain-website-s-and-or-videos/m-p/46...

 

Tried FireFox and the same thing happened since it uses separate cookies.  After one login, all was fine again.



jays77
I'm a Trusted Contributor
Posts: 728

Re: Signing in

Tonight using Chrome Incognito I could sign in with no problem as long as I was not signed into MyRogers at the same time,

It used to be that I could sign into MyRogers check my bill or band usage then scroll down to Community Forums and would be signed in there.
-G-
Resident Expert
Resident Expert
Posts: 2,497

Re: Signing in

I have also had problems signing into various Rogers web sites recently as well: Community Forums, MyRogers, Onlinevoicemail.  I know you "need" your analytics data and need to integrate seamlessly with some 3rd-party sites... but your web sites are waaay too heavy, too complex and too susceptible to breakage.



-G-
Resident Expert
Resident Expert
Posts: 2,497

Re: Signing in

@CommunityHelps  My login difficulties were due to a simple content blocker extension.  I was able to log in fine after disabling uBlock Origin.  I'm not happy about this.  Extensions, such as uBO, provide essential protection... and blocking undesirable trackers should not break the site.



Bplayer
I'm a Trusted Contributor
Posts: 208

Re: Signing in

I have uBO addon installed on FF and except for the one login problem ~2 months ago it has never been a problem for me. I also use the custom HOSTS file from winhelp2002.mvps.org and maybe that is blocking some site that is problematic.

-G-
Resident Expert
Resident Expert
Posts: 2,497

Re: Signing in

I am able to log in now without having to relax any security settings or disable any extensions.



OLDYELLR
I'm a Senior Advisor
Posts: 3,804

Re: Signing in

It almost seems like a waste pf time posting about signing in problems. Some people apparently never have a problem, while others have problems all the time. And it changes from day to day. Maybe it's changes Rogers keeps making; they won't say. A common remedy is deleting all cookies and data, but that has its own problems, like other websites requiring extra steps to log in, even text or phone verification.  Another solution is to use a private or incognito window. Lately I've had success signing in to my PayGo Balance after the loop-de-loop and then scrolling down to Community Forums. But the last couple of days I've had no problem signing in, no more perceptual looping (touch wood). And I've made no changes that could have accomplished this.  Looks like we'll never figure Rogers out.


Rogers PayGo. Location: S-W Ontario
57
Resident Expert
Resident Expert
Posts: 4,171

Re: Signing in

Cookie issue again the past couple of days.  Could not sign to the forum in using Chrome on my Mac Mini in normal mode. I could sign in using Incognito.  I could also sign in using FireFox.  I could sign in to MyRogers without issue, but the link to the forums didn't "work" as I was not signed in when I got there from MyRogers.

 

Cleared Cache and Rogers cookies and was able to sign in this morning.    I don't clear all my cookies, just the Rogers ones by searching for "roger" (no s).  I don't clear my Rogers Bank or Rogers Anyplace cookies.