Signing in to the forum

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resident Expert
Resident Expert
Posts: 3,694

Re: Signing in to the forum

I'm back home using Chrome on my Mac Mini (instead of FF or Safari on my MBPro when travelling) and I occasionally still get the "accounts" popup (where you would normally choose one of your accounts if you have more than one) instead of being taken directly to my notifications.  Occasionally, I'm able to get directly to my notifications - seems to be no pattern.

 

There is, however, another new issue that I've seen.  When I choose my notifications bookmark

 

https://communityforums.rogers.com/t5/notificationfeed/page

 

, instead of being taken to the sign-in popup I'm taken to the following Rogers page:

 

https://www.rogers.com/consumer/home

 

Initially I thought I'd clicked the wrong bookmark, however, it's happened to me several times in the past couple of days and I've been checking very carefully to ensure I'm choosing the correct bookmark. I can also see the URL changing during the process.

 

The "tie-in" between MyRogers and this forum is causing way too many problems due to redirects not working, etc.

 

 



Highlighted
I'm a Trusted Contributor
Posts: 766

Re: Signing in to the forum

And look at whats on that redirect ...    My bet is it's not a glitch at all .  Smiley Wink

The more  I see of this type of thing ..the less I want to become any more of a Rogers customer than I am now  . 

 

 

 

Highlighted
Resident Expert
Resident Expert
Posts: 3,694

Re: Signing in to the forum

I'm sorry to keep harping on this, however, for the past few days the forum login has been anything but consistent.  I've logged in perhaps a dozen times and I've encountered three different scenarios.  I can understand if something goes wrong and you get the same experience, but to have a different sign-in experience each time you login is really weird.

 

- Sometimes (rarely) I'm able to sign in properly and am taken to my Notifications page using my Notifications bookmark

 

- Many times I'm taken to the Rogers main page instead of the forum sign-in pop-up and basically need to start over.

 

https://www.rogers.com/consumer/home

 

- Many times, after I log-in at the pop-up, I'm taken to the pop-ups where you would normally choose one of your MyRogers accounts (if you have two or more).  I then need to click my notifications bookmark again (at lease I'm logged in).

 

This all started a couple of weeks ago and is getting worse and worse.  I'm currently running Chrome on my Mac Mini.  I tried deleting cache and cookies a few days ago, however, that didn't seem to make any difference. I'll try again today...



Highlighted
I'm a Senior Advisor
Posts: 3,688

Re: Signing in to the forum

For me, mostly it has given me my 2 account popups to choose from, but I've just clicked my Notifications bookmark again and got Notifications. This time I just got my cable account page and then clicked Notifications again. I've quit worrying over it sinceit's just one extra click and still gets me here. It seems that whenever Rogers fixes something, they keep fixing it some more until it's broke again. You would think as a communications company they would be better at it.


Rogers PayGo. Location: S-W Ontario
Highlighted
Resident Expert
Resident Expert
Posts: 3,694

Re: Signing in to the forum

I deleted cookies and cache and after a few attempts have encountered all three outcomes outlined in post 333.

 

I haven't bothered with a different browser or computer.  I'll just put up with this extra clicking...



Highlighted
Resident Expert
Resident Expert
Posts: 3,694

Re: Signing in to the forum

Not once was I able to login directly to my notifications using that bookmark today. I was either taken to the Rogers home page, or to the popups for selecting an account. In the former case I have to click my notification bookmark again, then click it a third time if I'm taken to the account popups.  In the latter case, I have to click notifications bookmark again.

 

To add insult to injury, I had to solve a few captchas today as well.

 

C'mon Rogers, put things back the way they were 3 weeks ago, or fix what you did two weeks ago to change things.



Highlighted
I'm a Senior Advisor
Posts: 3,688

Re: Signing in to the forum


@57 wrote:

I deleted cookies and cache and after a few attempts have encountered all three outcomes outlined in post 333.

 

I haven't bothered with a different browser or computer.  I'll just put up with this extra clicking...


It was bad enough when Rogers restricted Manage PVR to a few specific browsers, excluding Firefox, but even that's now gone. Any site that restricts users to a small, limited number of browsers is shooting itself in the foot.  Why would they want to make things difficult for visitors?  It makes you wonder whether sites get special consideration to favour the use of certain popular browsers.


Rogers PayGo. Location: S-W Ontario
Highlighted
I'm a Trusted Contributor
Posts: 766

Re: Signing in to the forum


@OLDYELLR wrote:

 It seems that whenever Rogers fixes something, they keep fixing it some more until it's broke again. You would think as a communications company they would be better at it.


It seems to me that a lot of the issues we see presented  here  suggest that Rogers is first and formost a marketing company  ...not necessarily  a communications company .  Smiley Wink 

I realize that they only market one type of products ...but they seem to focus so much on marketing that customer service is lost and to me that is more of  a marketing company  than a service provider . 

 

I just had a laughable captcha ... a shot of a car bumper and mainly pavement  with the request for squares containing a motorcycle  ...I clicked on 3 squares showing part of the bumper and won my way in  .... I still have heard no explantion of what  the captcha's during log in  actually save anyone from . I can only assume it benefits rogers  somehow.  Smiley Frustrated 

Highlighted
I'm a Senior Advisor
Posts: 3,688

Re: Signing in to the forum

I wasn't going to post anymore on this until there had been no change for maybe 3 days. So for 2 days so far I was not getting the choose account popup after signing in using my notifications bookmark. Even if there were no new notifications, I could just click one of the old ones to get to the forum. But this time I got this:

 

"You don't have any notifications. Try posting a new topic or question to see some activity here."

 

Of course to get to the forum I had to click my  username at the top, then the bell, then one of the old notifications.

 


Rogers PayGo. Location: S-W Ontario
Highlighted
I'm a Senior Advisor
Posts: 3,688

Re: Signing in to the forum

So that was a fluke error message. This morning, after signing in with my notifications bookmark it went straight to notifications, even though there were no new ones.


Rogers PayGo. Location: S-W Ontario