rogers.com profile GONE?

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 15

rogers.com profile GONE?

So i go to check my internet usage this morning, like i do every friday morning for the last 4 years, and am greeted with "There are no accounts registered with your online profile. Please add your Rogers account(s) to your online profile in order to perform this activity."

 

i have now been on hold with Rogers for 20 minutes due to "higher than normal volumes" which is the SAME message i get every time i call them..

 

Seriously.. When i am giving you $300 a month for services, my third highest monthly expense, (mortgage and car being 1 and 2) and my single highest DISCRETIONARY spend item (meaning, i can live without the servies i am paying for) i expect much better service.

 

 

***edited labels***

 

 

Solved! Go to Solution.
I'm a Reliable Contributor
Posts: 115

Re: rogers.com profile GONE?

This is one of the boondoggles of Rogers.com. You should give it a try a little later and you may find that it is working again. I know, because I have also had this happen to me.  Although it has been working much better in the past few months, rogers.com has been a constant source of frustration to myself and many others ever since it was revamped about a year ago!

I'm a Senior Contributor
Posts: 161

Re: rogers.com profile GONE?

I had that very same error last night. When I called in, the error was there because of 2 issues:

 

1) my account section of rogers.com doesn't work well with Chrome

and

2) My cache and cookies hadn't been cleared out.

 

Switching to IE (although was forewarned not to use the new beta version as its not supported) or FireFox and cleaning out all cache/cookies/temp internet files worked.

 

Have you tried these steps yet?

I'm a Reliable Contributor
Posts: 115

Re: rogers.com profile GONE?

It is now working fine now, as I suspected. The problem was at the Rogers end. It is funny, but when the CSRs don't really know what to do, they usually tell you to clear your cache. Not sure how many times I have done that, but it has always been to no avail!