note 5 64gb battery issue

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I'm a Reliable Contributor
Posts: 170

Re: note 5 64gb battery issue

How High is Android System?
I'm Here A Lot
Posts: 6

Re: note 5 64gb battery issue

@Dx9 during 8 hours sleep time last night, it had 23% android system and cpu up time was almost 6 hours without touching it. More importantly, I turned off everything last night before I went to bed included mobile network, wifi, sync, gps, location history blablabla with the ULTRA power saving mode on lol really don't know what to do now.
I'm a Reliable Contributor
Posts: 170

Re: note 5 64gb battery issue

You might need to do a factory reset. Even though it's brand new I always do when getting a new phone. Also the update could have corrupted something
I'm Here A Lot
Posts: 6

Re: note 5 64gb battery issue

@Dx9 omg 5.5 hours screen time is just perfect lol thats really what I need for my note 5. Hopefully in couple days later it will settle down.
I'm a Reliable Contributor
Posts: 170

Re: note 5 64gb battery issue

I have 72% left today right now with 2hrs 12 min screen. On LTE all day.
I've Been Here Awhile
Posts: 2

Re: note 5 64gb battery issue

Hello everyone,

I just updated my note 5 with the latest software update with the November security patch. Since then, as soon as my phone reaches 15 percent, it starts to drain drastically at about a percent every 10 to 15 seconds.

I let it drain all the way to 2 percent within a minute or 2 and then plugged it in. The number instantly jumped to 15 percent again.

Something strange is happening. I've tried the factory reset but didn't help the issue.

Any help would be greatly appreciated.

Thanks.

 

I'm a Trusted Advisor
Posts: 32,102

Re: note 5 64gb battery issue

Hello @Gibran7

Have you tried contacting Rogers to off if they can assist you with the issue you are having?

Also have you checked if any app or email client you are using is running in the background? This can happen and i noticed it on mine.