cancel
Showing results for 
Search instead for 
Did you mean: 

iPhone 5 4g H+ LTE Problems

randomdefence
I'm Here A Lot

Hello, 

 

I upgraded from my 4s and noticed that so far, even though my area supports 4g and H+ my phone has only been connecting to 3g. I have been on the phone with rogers tech support for the better part of the day and think it's a problem in my area. Is there anyone in the woodstock ontario area on here with these problems? Or have other people been having this problem in other areas?

 

****Edited Labels****

26 REPLIES 26

Re: iPhone 5 4g H+ LTE Problems

mukuls2
I've Been Around

I face the same issue in Calgary  iphone5 is unable to hold on to LTE signal for long . Also it shows 3g all the time and note even 4g

Re: iPhone 5 4g H+ LTE Problems

Meowmix
I'm a Trusted Advisor
Hello mukuls2

The iPhone may never show 4G indicator. This is because the canadian carriers do not seem to want it on the iPhone yet the US carriers have that 4G indicator. You will only see E ( EDGE), 3G & LTE.

Have you called Rogers & asked them about the area you live in & if LTE is in that area? Also ask them why is it not on for long LTE i mean.

Re: iPhone 5 4g H+ LTE Problems

addiction
I Plan to Stick Around

I live in Calgary too in Evanston in the NW. The coverage map shows LTE all over my area and 4G too but I'm only getting the 3G indicator as well. I did a speedtest getting 7 mbps downloads so this confirms its only 3G coverage. So either the map is wrong or there's something wrong with the towers out here. The map says there is 4G and LTE coverage all over here. I have a tweet in at Rogers helps lets see if I hear anything about it.

Re: iPhone 5 4g H+ LTE Problems

topdog
I Plan to Stick Around

@jdyoung

 

   London does have LTE now not sure if it did at the time of your post, but it is working now in certain areas, i get it at work in the downtown area but not in the eastend where i live, so it is spotty but working

Re: iPhone 5 4g H+ LTE Problems

pdubois64
I Plan to Stick Around

@addiction wrote:

I live in Calgary too in Evanston in the NW. The coverage map shows LTE all over my area and 4G too but I'm only getting the 3G indicator as well. I did a speedtest getting 7 mbps downloads so this confirms its only 3G coverage. So either the map is wrong or there's something wrong with the towers out here. The map says there is 4G and LTE coverage all over here. I have a tweet in at Rogers helps lets see if I hear anything about it.


I live pretty close to you in Huntington Hills and never get LTE at my house either. When driving around I seem to get it most of the time. I talked to a Rogers tech rep on Nov 6 and he told me that there are some new LTE towers that are due to come online very soon. That may improve some of the fringe areas.

Re: iPhone 5 4g H+ LTE Problems

Jojoimpala
I've Been Around
We are in London ont and we are having the same issue.. No service no lte sometimes 3G extreamly frustrating this has been going on for the past few weeks I've tried everything I have read on here yet nothing works
We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats