Xperia X10 Earphone possibly damaged

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 3

Xperia X10 Earphone possibly damaged

Hello

I bought a Sony Xperia X10 back in the Spring (April/May)

Recently the in call volume has gotten alot worse - too low, and the for tiny at the highest volume.

 

Am I able to RMA my phone for a new phone? Or what are my options in getting this either fixed or replaced?

Thanks

 

***edited labels***

Solved! Go to Solution.

Accepted Solutions
Highlighted
Retired Moderator
Retired Moderator
Posts: 497

Re: Xperia X10 Earphone possibly damaged

That may indicate the actual speaker is defective.

 

Just to be safe, I assume you updated to 2.1? Does the same issue occur with a headset?

That is usually a good indication of a defective speaker, if both do the same, we know it is software related, if headphones are fine and speaker is weak, it is usually a physical defect.

 

If the device is physically defective and you are stil under warranty I recommend calling in to 1866-931-3282 and speaking with technical support.

View solution in original post


All Replies
Highlighted
I've Been Here Awhile
Posts: 3

Re: Xperia X10 Earphone possibly damaged

*spell check - Too low, and the sound is very high pitched or tinny at high volume
Highlighted
Retired Moderator
Retired Moderator
Posts: 160

Re: Xperia X10 Earphone possibly damaged

Hello Pyro224,

 

Welcome to the Rogers community,

 

My suggestion is to perform a master reset on your device.


Please be aware that performing this task will erase everything on the device.

 

On the device,go to  Settings > SD card & phone storage > Factory Data reset (follow instructions)

 

If the issue still remains please call our support line at 18669313282.

Highlighted
I Plan to Stick Around
Posts: 14

Re: Xperia X10 Earphone possibly damaged

You could also try 'repairing' the software using the Sony Ericsson Update Service (link below).

 

http://www.sonyericsson.com/cws/support/softwaredownloads/detailed/updateservice/xperiax10?cc=gb&lc=...

 

As RogersJonathan said with ther master reset, this will erase personal data in the phone, so be sure to use the Backup and Restore app on the phone first, and perhaps sync what you can using your Google account.  If you don't have one, it would be worth getting one first.

Highlighted
I've Been Here Awhile
Posts: 3

Re: Xperia X10 Earphone possibly damaged

reset did not solve the problem, volume remains the same.
very frustrating as I can barely hear a phone call if I am in a public area such as a mall
Highlighted
Retired Moderator
Retired Moderator
Posts: 497

Re: Xperia X10 Earphone possibly damaged

That may indicate the actual speaker is defective.

 

Just to be safe, I assume you updated to 2.1? Does the same issue occur with a headset?

That is usually a good indication of a defective speaker, if both do the same, we know it is software related, if headphones are fine and speaker is weak, it is usually a physical defect.

 

If the device is physically defective and you are stil under warranty I recommend calling in to 1866-931-3282 and speaking with technical support.

View solution in original post

Highlighted
I've Been Here Awhile
Posts: 3

Re: Xperia X10 Earphone possibly damaged

Hello, I have the same issue and it seems to be a X10 issue.  A lot of people reported that problem in forums...  The upgrade from 1.6 to 2.1 didn't solve the problem.

Highlighted
I Plan to Stick Around
Posts: 69

Re: Xperia X10 Earphone possibly damaged

Run the Speaker test in the service menu.

On your lock slider screen press the Home and Back buttons in this order:  H B B H B H H B

Go to service tests then Speaker and see if the speaker plays at a reasonable volume.

[not sure if u can adjust volume while its playing a sound]

 

Rogers Moderators...you always suggest to wipe everything first. Sheesh.....