TVO - Channel 2

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

TVO - Channel 2

Hello,

 

Anyone else having troubles with Channel 2  - TVO not working for the past few days.

 

Cheers

 

 

 

***Edited labels***

I've Been Around
Posts: 1

Re: TVO - Channel 2

I am also having trouble with channel 2 TVO. It works for a little while then stops working especially in the evening. This has been happenning for the last 2 weeks

Resident Expert
Resident Expert
Posts: 2,550

Re: TVO - Channel 2

what is your signal level on HDTVO? Channel 2?


I've Been Around
Posts: 1

Re: TVO - Channel 2

I have had no sound on Channel 2 TVO for a couple of weeks. Why does Rogers not inform us about the problem and tell us what to do about it?

I'm a Senior Advisor
Posts: 3,547

Re: TVO - Channel 2

Where are you all located? No problem here in Woodstock.


SA8300HD, SA8300SD, DTA50, LG-E410B PayGo. Location: S-W Ontario
Rogers Employee GRtechJason
Rogers Employee
Posts: 26

Re: TVO - Channel 2

What are you guys using to watch channel 2, digital box, adapter, analog, etc
I'm a Senior Advisor
Posts: 3,547

Re: TVO - Channel 2

TVO (Channel 2) comes in just fine on analog, DTA50 and SA8300 PVR.

 

I notice that this was 2-year-old thread and the OP never came back. Neither has the poster who jumped on here yesterday with the same problem.

 

Just an idea, but I would suggest if anyone as a problem with a secific channel, they call Rogers first.


SA8300HD, SA8300SD, DTA50, LG-E410B PayGo. Location: S-W Ontario