Scientific Atlanta E940 Box - No Power

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

Scientific Atlanta E940 Box - No Power

Left for work this morning and the tv was working fine when i got home the box would not power on. Tried unplugging everything and reseting it but it still didnt turn on

 

 

 

 

***Edited labels***

Solved! Go to Solution.

Accepted Solutions
Highlighted
Resident Expert
Resident Expert
Posts: 14,169

Re: Scientific Atlanta E940 Box - No Power

If you have unpluged everything and re pluged it in (both from the WALL outlet, as well as the back of the box), and checked the batteries on the remote and its on the right setting..

Could be, the box is dead 😞

If its a rental, you should be just able to swap it.



View solution in original post


All Replies
Highlighted
Resident Expert
Resident Expert
Posts: 14,169

Re: Scientific Atlanta E940 Box - No Power

I know this will sound silly, but just making sure.
Change the batteries in the remote, and make sure, press cbl before the power button to make sure its on the CBL button.



Highlighted
I Plan to Stick Around
Posts: 64

Re: Scientific Atlanta E940 Box - No Power

I had a call from a friend a couple of weeks ago who had the same problem. When I checked his power suppy, it was dead. The local Rogers store replaced it. You'd need a voltmeter to check it.

Highlighted
I've Been Here Awhile
Posts: 2

Re: Scientific Atlanta E940 Box - No Power

I tried all step. Is there any other tip?

 

Thanks

Highlighted
Resident Expert
Resident Expert
Posts: 14,169

Re: Scientific Atlanta E940 Box - No Power

If you have unpluged everything and re pluged it in (both from the WALL outlet, as well as the back of the box), and checked the batteries on the remote and its on the right setting..

Could be, the box is dead 😞

If its a rental, you should be just able to swap it.



View solution in original post

Highlighted
Resident Expert
Resident Expert
Posts: 2,667

Re: Scientific Atlanta E940 Box - No Power

the hydro outlet on the wall could also be bad try another hydro outlet



Highlighted
I Plan to Stick Around
Posts: 17

Re: Scientific Atlanta E940 Box - No Power

If other devices are powering on frombthe same outlet, then your e940 is dead due to a power surge. Take it to your local Rogers store for replacement.

Highlighted
I've Been Here Awhile
Posts: 2

Re: Scientific Atlanta E940 Box - No Power

Thanks for all your replies. Unfortunately that is my personal device and now have to get a rental one.

Highlighted
Resident Expert
Resident Expert
Posts: 2,667

Re: Scientific Atlanta E940 Box - No Power


@imranabbas wrote:
Thanks for all your replies. Unfortunately that is my personal device and now have to get a rental one.


not true, no one is holding a gun to your head to "rent" one, you can purchase one outright from the retail stores who sell them, or if your looking to save some $$$, you can easily buy one second hand and activate it on your account providing the ESN is clean. I did this and heck, I paid like only $20 for a used box, was a great deal, cus some ppl i know paid upwards of $80 bucks or more for theirs



Highlighted
I've Been Here Awhile
Posts: 2

Re: Scientific Atlanta E940 Box - No Power

I own a few of these old SD boxes.  I have a small under-the-counter TV in my kitchen that uses the E940 and the size is perfect to hide away in the cabinet.  Within the last 10 years I've had 3 E940 fail on me. 2 power cords failed and 1 box start pixelating.  The cords are near impossible to find online, and as far as I can tell the box has been discontinued. I have, in the past, purchased used E940's on ebay from between $20-$30 each just to replace my cords.  If any one has any old E940 cords gathering dust in their drawers, I'd be glad to take them off there hands. (GRE-SA-PM8.2V/1.7A) AC/DC Adapter.