Samsung Galaxy S2 LTE SIGNAL PROBLEMS

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I Plan to Stick Around
Posts: 9

Samsung Galaxy S2 LTE SIGNAL PROBLEMS

I have a samsung Galaxy s2 LTE. Since the battery dies in about 2 hours when i have LTE turned on i always set it to 4G/HSPA. So when im at home and its plugged and i can use LTE it only gets 1bar and sometimes no messages get through or worse no calls. Sometimes even when i go out it only stays at one bar LTE...anyone know how to fix this problem?

 

 

******* Edit labels ********

I'm a Trusted Contributor
Posts: 255

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

Move. That's your only option. The location you are trying to use LTE in has poor LTE coverage. I get the same thing all over Ottawa.. Very few places have LTE higher than 1 bar.

Highlighted
I Plan to Stick Around
Posts: 9

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

LOL. right away. i live in the heart of toro.to it says that the whole area os covered 100%. sue for false advertising again? smh
I'm a Trusted Advisor
Posts: 32,019

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

I live in scarborough & i got 1 bar of LTE on my s2 LTE & on my Raider. When i was downtown Toronto near the eatons center i got at least 2-3 sometimes. It all depends on how many are on the network at the same time.

Even if you sue Rogers for false advertising you will lose seeing as everyone is having the same issue as you & Rogers even says that when you call in to tell them that..
I Plan to Stick Around
Posts: 13

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

rogers lte-- thats funny they cant even give you proper 3G signal on any phone people use,stays on 2G 90% of the time.
I've Been Around
Posts: 1

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

okay so i updated my phone to jelly bean last week with no issue. but does anybody elses phone no longer connect to the LTE network?

 

the highest i get is H+ but that's rare too, i called rogers and they told me that the update just removes the LTE icon but it's still connected to the LTE network, but my internet is noticably slower so i think they are just lying to me. 

 

 

I'm a Trusted Advisor
Posts: 32,019

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

Hello shawnathen

Have you tried doing a factory reset to see if that will fix it? Sometimes a new update MAY do something & you may need to do a factory reset after to fix it.

Also yes the new update from OTA took off the LTE status & shows 4G now.
I'm a Senior Contributor
Posts: 267

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

Actually, the first OTA update was messed up by Samsung Canada.

They posted on their facebook page to re-do the update via Kies to correct the issue of no longer showing LTE.

I'm a Trusted Advisor
Posts: 32,019

Re: Samsung Galaxy S2 LTE SIGNAL PROBLEMS

Hello AnonymousUser

That is correct. Mind you tho, not many do care about the LTE indicator as long as you get the speeds. Anyways if you re do it from Kies, it will update the phone showing LTE.