cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP output from Outlook getting password failure

DragonsOfWine
I'm a Reliable Contributor

Ok, my accounts been working just fine for a dog's age and there is no issues with the web client. Yesterday I started getting prompts for my password when sending out email but the mail would get sent. Today, nothing will go out and I keep getting prompted.

 

I'm loath to call Rogers support as they are not usually helpful in complicated matters like this.

 

I'm hoping there is a work around.

 

Again, this is with MS Outlook.

 

 

***edited labels***

1 ACCEPTED SOLUTION

Accepted Solutions

Re: SMTP output from Outlook getting password failure

khowells
I've Been Here Awhile

Ok - so I have been using my email with just the start of my email address (no @rogers.com) as the username. This has worked for the past year , even after updating the SSL settings.

 

It was working fine for receiving email today but i just added the @rogers.com to my username and now the sending works again.

 

Not sure why it worled without it for so long but at least it seems to be ok again now

View solution in original post

16 REPLIES 16

Re: SMTP output from Outlook getting password failure

Gdkitty
Resident Expert
Resident Expert

Just confirming the settings..

outgoing server: SMTP.broadband.rogers.com

You have the new SSL settings set.
uses authentication, your email as the username..

and then your password?

Re: SMTP output from Outlook getting password failure

OneCrazyCanuck
I've Been Here Awhile

Hey,

 

My wife is having the exact same problem. I've verified all of her settings and everything seems fine and it's only the outgoing SMTP connection that is having problems. Its been happening since yesterday.

 

Strangely I'm not having issues with it and so it seems to be account-specific. Any thoughts? Sounds like we may have to contact customer support...

 

Re: SMTP output from Outlook getting password failure

khowells
I've Been Here Awhile

Hi,

 

same issue here. I have two Rogers email addresses in my Outlook and neither one can send email since late last night

 

 

Re: SMTP output from Outlook getting password failure

DragonsOfWine
I'm a Reliable Contributor

GDKitty, why did I know that would be your response 😉

 

Yup, all that is fine. Based on the other replies it looks like something is going on that I'll have to check out with a call to Rogers.

 

Need a coffee first though.

Re: SMTP output from Outlook getting password failure

khowells
I've Been Here Awhile

Ok - so I have been using my email with just the start of my email address (no @rogers.com) as the username. This has worked for the past year , even after updating the SSL settings.

 

It was working fine for receiving email today but i just added the @rogers.com to my username and now the sending works again.

 

Not sure why it worled without it for so long but at least it seems to be ok again now

Re: SMTP output from Outlook getting password failure

DragonsOfWine
I'm a Reliable Contributor

Ok, a mea culpa to GDKitty and thanks to khowells. That has got it working until next time 😉

Re: SMTP output from Outlook getting password failure

davehooper
I Plan to Stick Around

Yup, worked for both my wife's computer and mine. Just make sure you know what your password is for your email client. When you append the "@rogers.com" to your server settings (incoming and outgoing) your client may ask for your passowrd.

 

Re: SMTP output from Outlook getting password failure

Yeah.. rogers seems to allow some LEGACY stuff for a time period.. so may work, even though a NEW way has been implemented 😛

Thats one reason why i was asking the information...

I ran into that when the SSL stuff came out with my MOMs email address.

She was able to figure out wher to change the SSL ports, etc.. but it wouldnt work!
Ends up, she was using the OLD OLD DNS method of just haveing POP / SMTP as the server names.
These ended up resolving to the pop.broadband.rogers.com, etc... but obviously, didnt work/carry forward with the SSL stuff 😛

Re: SMTP output from Outlook getting password failure

...worked for me, too - thanks!

Re: SMTP output from Outlook getting password failure

DragonsOfWine
I'm a Reliable Contributor

I've noticed there are still some lingering issues after this is fixed. I'll get some message that timeout on sending but no password prompts.

 

Cancelling the task and restarting it seems to work.

Re: SMTP output from Outlook getting password failure

Thank you! I was having the same problem and this fixed it. Why couldn't Rogers send out an email to their users about this? A lot of us use Outlook. 

Re: SMTP output from Outlook getting password failure

I am suprised, that there are this many users, who were still using only the username portion of it...

I remember... we are talking more than 3 years ago... being told that the FULL name is the recommended/required method.
Guess the old way still worked.
Dont remember HOW i was told/got the info... weither from a mailing.. or just from talking to a tech, etc.

Re: SMTP output from Outlook getting password failure

gmanuelp
I've Been Here Awhile

I am still having this issue - I have been using the full username@rogers.com, and all my SMTP settings are correct - again, its been working fine for ages, and today bam... keeps popping up with the password prompt, and says my login is rejected.

 

Even tried with a different rogers login, but no luck.

 

Any help would be appreciated!

 

thanks

Re: SMTP output from Outlook getting password failure

gmanuelp
I've Been Here Awhile

So - I tried changing smtp servers (to a different ISP) just to 'clear' the Outlook's cache (if there is such a thing) - then changed it back to Rogers and it worked - nothing else changed!

 

However, half an hour later now - and it doesnt work again... sigh...

 

 

 

 

 

 

Re: SMTP output from Outlook getting password failure

How often is it checking?

I know it can get rejections, if it checks too often, or tries to do MULTIPLE at one time (thunderbird is natorious for this).

Sometimes if its the above, there can be a partial lock on the account, which the best way to clear it, is by loging into the webmail.

Re: SMTP output from Outlook getting password failure

gmanuelp
I've Been Here Awhile

No different than for the last year - not sure what the frequency is (defaulted to whatever Outlook 2013 is), but the server timeout is at 1 min...

 

This is for a 3rd party email account (not @rogers.com) - not sure if there's still the requirement for the 'authenticated SMTP' to allow me to send via rogers servers.  Regardless, will try logging into the Rogers webmail to see if that clears any lockouts, although, as i said, haven't had any issues in ages until today.

 

The fact that several people suddenly had this happen probably means that there was some server issue (corrected by now) that Rogers is not talking about - people may have tried various things, and they all worked coincidentally since Rogers probably fixed the issue in the background at the same time!

 

I changed my SMTP server to something else, tried to log in (and failed, because i didn't bother changing the login id), and then changed it back to Rogers, and voila, it works again!  Gonna wait and see if this happens again...

 

Thanks

Topic Stats
  • 16 replies
  • 4164 views
  • 5 Likes
  • 8 in conversation