cancel
Showing results for 
Search instead for 
Did you mean: 

Rogers On Demand Menu not Appearing

AJ
I've Been Here Awhile

This is an issue I've had with both ROD (Channel 100) and TMNOD (Channel 309)

 

I am in Ottawa.

 

Occasionally (though more often than not) when I access ROD or TMNOD (at the above-noted channels) I run into problems.

 

What is supposed to happen/What happens when it works:

I access the channel, wait for it to load and hit the "A" button or the "Select/OK" button on the remote. A little grey box appears reading "loading...please wait", with the divided circle beside it. After a few seconds the menu appears and I am on my way to watching some glorious on demand programming.

 

What happens often enough to cause me to post this/When it, too often, doesn't work:

I access the channel, wait for it to load and hit the "A" button or the "Select/OK" button on the remote. No grey box appears, no message reading "loading...please wait" and no divided circle icon. After a few seconds the menu appears without any text. That is, the background to the menu, as well as the preview box are there but there is no text in the menus. Without the actual menu up I cannot browse through ROD or TMNOD. (if I know the key sequence, i.e. TV Shows is 2nd on the list, and Global is 1st on the subsequent list, etc... I can still view the program, but unless I know the sequence I wouldn't be able to browse to it.) Generally to resolve this I need to reboot my box which takes between 5-10 minutes. This doesn't always work and I try again.

 

This issue happens more often than when it works the first time. This is a huge annoyance in that everytime I want to watch something on demand I now need to build in an extra 20 minutes in case I need to reboot...or reboot twice.

 

Please help since I'd rather always have the scenario described under "What is supposed to happen/What Happens when it works".

 

 

 ***Edited labels***

42 REPLIES 42

Re: Rogers On Demand Menu not Appearing

Orange
I Plan to Stick Around

I wish you luck in getting this resolved.  I have had a similar problem for a month now, although even worse, as I can't get programming even if I know the sequence of menus, and Rogers seems incapable of fixing the issue.  I'm afraid you will have to do as I have done, call Rogers tech dept every day, have multiple service techs visit, call every day again because the service techs haven't solved the problem, have multiple tickets opened on the problem, be told by Rogers repeatedly (through automated calls) that the problem is solved, call back repeatedly to say that no, it is not solved...  I hope you have better luck than I have had.

Re: Rogers On Demand Menu not Appearing

Chris
I'm a Senior Advisor
Sadly Rogers On Demand is not yet ready for prime time. Netflix is here to compete so rogers lowers the bandwidth allotments in order to block the competition instead of actually fixing ROD and making it a legitimate competitor.

Issues like these will continue on ROD until they update the software.. Until such time we will have to live with crashes and horrible user experience or pay for the overages of using netflix.

Re: Rogers On Demand Menu not Appearing

Coda
I've Been Here Awhile
I have the same problem on my HD box and I keep having to unplug it and reset it to get it to work.The weird thing is I also have an old Digital box (non HD) and I never have problems with that one.

Re: Rogers On Demand Menu not Appearing

Orange
I Plan to Stick Around

Coda, do you have one of the new 8642 model HDPVRs?  We had a problem with more than one of this model "freezing" all of our channels, and the only way to get the channels back was re-booting.  The tech who finally figured this out recommended switching back to the 8300 model, and the problem hasn't recurred.  He thinks there is a software issue with the 8642.  (But now, of course, we are having different issues, and don't know yet if it is the 8300 box or something else.  Sigh.)

Re: Rogers On Demand Menu not Appearing

Coda
I've Been Here Awhile
I have an old Explorer 3250HD box. I'm thinking its time to exchange to a newer model.

Re: Rogers On Demand Menu not Appearing

AJ
I've Been Here Awhile

@Chris

 

That has absolutely nothing to do with the post at all.

 

However, if Rogers basic internet doesn't provide enough bandwith I suggest you try using a different ISP; try Acanac or TekkSavvy.

Re: Rogers On Demand Menu not Appearing

Chris
I'm a Senior Advisor

@AJ Sorry I was just stating that ROD is not yet ready for primetime and was stating my dissatisfaction with the service. I often run into the same issues as you described above and feel it is an unacceptable implementation of the service.

Re: Rogers On Demand Menu not Appearing

James
I'm a Senior Contributor
Hey AJ,

I am not a cable expert myself. However, I have had a very similar problem with the cable boxes. For several months ROD was not working for me (although in fairness, I never called in about it).

In the end, all I had to do was swap out my box at a local store and and its worked without a hitch ever since.

Have you tried this yet or any other troubleshooting? Have you called our technical services yet or is this your first form of communication about this issue?

Re: Rogers On Demand Menu not Appearing

mel6725
I've Been Around

I'm surprised there aren't more posts here. I'm just getting started so maybe there are different topics covering similar issues.  When we moved in July I decided to 'go digital' and bought a new TV and digital box. Had a good experience hooking everything up (did it myself) and a good experience calling Rogers to activate. Things have gone downhill since then. Cable and HD channels came in OK but ROD did not "LOAD". Techs came out and decided to run a new cable to the house. After three weeks waiting and a new cable buried - still no ROD. The next tech swapped out the brand new (may have been refurbished) box I bought at Sears and we were able to watch ROD programming. At this point my wife had pretty much given up and would leave the room everytime I went to try Channel 100.

 

We had just started getting used to watching missed TV shows and decided to watch a movie on a Saturday night when ROD would not load. I made a call to Rogers and was told that this happens all the time during peak periods?? However now every time (no matter what day of the week) I go to ROD its a crapshoot. If I'd have know this service was so terrible I would have mounted the power bar beside the TV rather than behind it.

 

Is there a solution ...

 

 

Re: Rogers On Demand Menu not Appearing

Gypsy
I'm Here A Lot

Same problem happening to me in Ottawa with my HD 8342 - I have to re-boot all the time when I try channel 100 or 300 ROD.  It's so frustrating that I just give up and watch something else.  I have not called Rogers on this issue because I'm already waiting for a call back from a Manager/Supervisor on another issue with Rogers.  Unbelievable **bleep** service!! 

Re: Rogers On Demand Menu not Appearing

If your digital box requires frequent resets, I would recommend contacting our cable repair department via 1-888-764-3771 for direct assistance. They'll be able to check your signal levels to make sure there aren't any issues as well as do a hard reset and re-authorize the box from their end. If those steps fail to resolve the issue, swapping the box may be suggested.

 

Thanks

Re: Rogers On Demand Menu not Appearing

Laurie22
I've Been Here Awhile

We are having the exact same problem.  I called the Rogers support number for direct assistance and they recommended that a tech come to my house to fix our signal which is weak.  Not sure what that means, but the support person was helpful and booked me an appointment for Saturday morning which was appreciated.  He also reset our black box from his end and I reset it (again) from my end and now we have the menus loading--at least tonight anyway.  I was impressed with the quick response when I called Rogers as I am used to waiting on the phone for at least 20 minutes for support calls.

Re: Rogers On Demand Menu not Appearing

echo
I've Been Here Awhile

We've been having a problem with on demand for months. It only happens on Friday or Saturday nights. When we try to watch anything on demand in HD we get an error message stating that our order cannot be processed at this time. I spoke to Rogers and they admitted that they do not have the capacity to keep up with on demand on the weekends. Each time I call they do work some magic that allows me to get the program I want but spending 15 minutes on the phone before watching a movie is not enjoyable.

Re: Rogers On Demand Menu not Appearing

leman
I Plan to Stick Around

Not sure if you have had this problem resolved yet....If not have the set top exchanged.  I had a 3250 hd  box and put up with that very problem for a number of months and then finding out that certain models have had a memory problem that would not allow the titles to show.   I also did the same experiment with scrolling to what I would know would be the new this week section and to my surprise a movie started to play.   Don't put up with that problem any longer.   Go to retail or have a technician exchange the set top for you. 

Re: Rogers On Demand Menu not Appearing

supervillain
I Plan to Stick Around
Bumping this up, I am having the same problem, 4642HD box here....very frustrating. It seems all the on demand channels are like this. ROD, TMNOD, MPIXOD, etc etc...I have talked to tech support a couple of times, no luck.. Only had the box for less than a week....grr

Re: Rogers On Demand Menu not Appearing

keep calling.  there is a problem but they are still in the garhering info stage.  short term solution is to try a box that is not an 8642, though some 4642 may be reporting same issue.  i have had the problem since june.  kind of makes me yearn for my old box and non hi def tv.  i only upgraded because of the new tv....and i WAS enjoying catching up on HBO shows, but now i can only watch them if i happen to be home, or remember to PVR them.  no on demand for me!

Re: Rogers On Demand Menu not Appearing

I've also had the same problem on a non- HD box since June 2010. Got my box swapped once but the problem is still there. Had to call multiple times for them to actually send someone. There was never any signal issue with my cable. In fact, my box used to shut off and reset by itself at times, which is why I really insisted on them sending someone despite the fact that everything looked normal on their end. The new box, different model, still has the same issues as the old ones.

Very frustrating. Looking forward to new ISP.

Re: Rogers On Demand Menu not Appearing

@Mrtne

 

That is EXACTLY what's been happening with me as well.  I have their New Explorer 4620... I was concerned at first when the Self-Serve screen no longer appeared and, when I had called to ask about it, I was told that, on this model the Self-Serve will not function on this type of Digital Box model and that they are taking measures to have it on. No problem... Was a slight annoyance at times anyway.

 

As for my ROD channel, It's the same thing... I switch to the channel, screen goes blank, except for "Loading"... the intro screen comes up about 1-2 minutes after and I press the A as directed... Screen goes blank again... It freezes, for that matter, as I'd noticed that when I brought up the channel guide and when I wanted to exit, it wouldn't do anything.  After a few minutes of that the screen goes blank again and the Digital Box shuts down and goes through the process of resetting itself... From there I'm fed up (and log onto Netflix)... However, after the digital box resets, everything works fine, especially ROD! this happens EVERY time I switch to my ROD channels... I haven't called about this as of yet, but it is VERY annoying, especially when having company over... I REALLY HOPE they are looking into this and it will be fixed much sooner than it's been taking already!

 

Re: Rogers On Demand Menu not Appearing

leman
I Plan to Stick Around

perhaps there should be a thread for 8642 and 4642 boxes regarding on demand.   The original post was for the titles not showing up after the on demand channel loaded.  Many of the posts here are regarding on demand not loading  or black screen after on demand tries to load specifically with 8642 and 4642 set tops.    

Re: Rogers On Demand Menu not Appearing

pammiet80
I've Been Around

Hi.... I haven't read to see if you've found the solution yet, but I just thought I'd share just in case that I found the solution by talking to a Rogers Tech dude tonight on the phone (after 2 weeks of talking to rogers tech dudes)

 

All you have to do is reset the box... and (this is assuming you've got the same remote with the Yellow A button, etc) go to your channel 309 or 100 or whichever one you want, and just keep repeatedly pushing the A button. After several times, the gray loading box on your screen will appear. I wish I'd been told this 2 weeks ago this has been a pain in the **bleep**.

 

The kid on the phone explained to me that its not the channel itself that's the problem. Its just that some boxes (in my case, its this tiny little thing with no time or anything) have issues connecting to the ROD server and the A button is the one that connects the cable to the server.

 

Hope this helps.

Topic Stats