Re: Froyo (2.2) on Captivate

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
marcbebee
I've Been Around
Posts: 1

Re: Froyo (2.2) on Captivate

Just wanted to add my experiences, which have been horrible but have ended well for anyone else reading through these forums to save them some frustration.

 

I wanted to believe. I was hyped about the Android based captivate and I have (if I do say so myself) a fair amount of technical expertise. But I had problems with my captivate right from the word GO with email (wouldn't send out for 24+ hours sometimes, features like skype not working, and the stupid security options that lack passphrase or code. And that's just a quick list - there's lots more wrong with 2.1 captivate on launch.

 

Of course, as people have discovered Kies 2.0 doesn't work with our phone which is just bizarre on Samsung's part and at least on windows 7, I get initialization errors on 1.5.3 although it does work.

 

Lo and behold, I saw the upgrade to 2.2 and thought the promised land was here! And for a day or so it was.

 

Then my email problems became nightmares. Sometimes if person A sent me an email, it would put in person B's message in the body of A's message. Worse, if you replied, it simply sent a message saying "null". It did this across email accounts. And heres the nightmare: I just discovered today that it was forwarding emails to person A that contained older emails meant for person B after person B approached me in confusion as to what my message was about.

 

Fortunately, for me, that particular email wasn't something embarassing but I think readers here can see the potential for great harm depending on what your emails contain. And that bug, even if it is rare, is simply unacceptable - this isn't android 1.0 folks. This was 2.2 and this is just basic email functionality. And then there's that known, and yet unfixed, bug that does the same thing with text messages (google it - its real). I haven't, yet, encountered that charming bug.

 

I called Rogers and to their credit the guy I had was calm and professional and recommended the factory reset and resetup. If I can make a few tips: 1) If you haven't gotten out of the 15 day return guarantee with rogers, return the phone if security matters to you. My email experience isn't the reason - there's also a known bug I've read about where text messages go to unintended recipients in a fashion similar to my emails.  Go with blackberry, which I was with before until it broke, and now I sorely miss. Blackberry wasnt as sexy perhaps, but it worked everytime and it was rock solid secure. 2) Update the phone via kies 1.5.3. and follow to the letter the instructions rogers has on their site. Back up your data prior to update. 3) After ensuring the update worked, again make sure you've backed up your data. Then do a factory reset. Yes, reset it even though the update "worked" 4) Froyo 2.2 will remain after reset but you will need to re-setup your apps and accounts starting with updating the email client samsung provides in "samsung apps"before you add email accounts. Personally, I now use the samsung email app which is NOT the same as the one provided by google. Why they have two email apps, I have no idea nor can I honestly say that samsung's app is better - I just know what works and frankly Im tired of experimenting with this.

 

After all that, my phone now has easily better battery life and is much snappier. It "feels"good and you can clearly see what the fuss was all about. But in my mind it will take several weeks or months before I trust it again fully because, again, I cant rely on Android's security.

 

Bottom line, this was a very poor roll out by someone - either rogers and/or Samsung. It should have shipped with Froyo to begin with and shouldve had an easier and faster update process.

 

And Rogers, if you're reading this, please please please step on whoever's toes you have to: a) Update Kies so that your phone works on the newest version, b) Make sure someone quality tests THOROUGHLY the update process so a reset isnt necessary, c) support your CUSTOMERS and their phones by making sure it can take on the already available 2.3 gingerbread OS update. Anything that kills bugs is badly needed for this phone.

rykev
I've Been Here Awhile
Posts: 3

Re: Froyo (2.2) on Captivate

Thank you for your post marcbebee. Based on your experiences, I believe I will reset my data & cache.

Akalon
I'm Here A Lot
Posts: 7

Re: Froyo (2.2) on Captivate

Updating was rather simple for me. Only thing about the update that threw me off a bit was having to put it into DL mode. Should not have to do this to update the phone. You really need to make sure the process is as easy as possible for those that might not be very technically inclined. I did have to factory reset as I was seeing "lag" when I first booted up after the update.

 

I've only dealt with a couple of bugs so far and those would be the SD card only allowing a little over 2GB to be transferred on to it. Mine does show the full size of the card when mounted as mass storage. Only way I have found to get by this was to mount in media player or kies. My other bug is the proximity sensor (according to Samsung reps this is Googles mistake) doesn't work when the phone is horizontal. So when I have to cradle it between my shoulder and head I end up hanging up on people, not the biggest of problems for me but still annoying when I didn't know about it and when I forget about it.

 

One last possible bug, I say possible because it could just be my wireless network acting funny. I have noticed that using allshare now to stream movies my phone needs to buffer a fair amount more. I never had this problem with 2.1 it would buffer at the beginning of a movie and that was it. I'm also seeing slight stuttering during play back streamed or played from the phone.

 

The good things, it's fast and responsive. GPS is much better for me, and my battery after a bump charging lasted me over 30 hours before I needed to plug it in this morning and I still had about 15% juice left. That was with some texts, checking facebook and other web apps used through out the day a couple of youtube videos and I watched a movie that I streamed from my computer.

 

Over all I've been pleased with my purchase but this update leaves a bit to be desired when you consider how many people have been having problems even doing the update. Not to mention some of the basic bugs that this update brought like the SD card issue.

qzaman
I've Been Here Awhile
Posts: 2

Re: Froyo (2.2) on Captivate

Hi i had the same issue , with MSC.firmware.update has stopped working

i did everything i can imagine but couldn't fix this issue on Vista, 7

even used xp as virtual machine but still sucks

i hate Kies

 

Update : work arround i borrowed my friend's native xp computer (originally came with xp preinstalled)

installed kies -

connected the phone -

after device drivers are updated -

i closed kies

Launched firmware updater from

C:\programfiles\samsung\msc.thunder.firmwareupdater.exe

disconnected phone- and connected again

updated the firmware succesfuly

 

no problem and happy finally but still hate Kies

 

qzaman
I've Been Here Awhile
Posts: 2

Re: Froyo (2.2) on Captivate

Were your phone rooted before ?
psyfactor
I'm Here A Lot
Posts: 5

BUG?? One more thing about the bluetooth dialer

As I wrote in a few posts earlier about the poor performance of the new bluetooth voice dialer. It doesn't recognized any commands issued throught the bluetooth headset yet the same commandes work with the  voice dialer throught the internal mic (same software). Now, I just install Vlingo just to test this and to my surprise, Vlingo suffers the same problem. Then, I noticed that no voice data is routed to the bluetooth headset when using voice commands. That means the software on the phone waits for the voice commands throught the headset but nothing comes. I think there's a bug which prevents the voice input to be routed throught the bluetooth headset in voice command mode. It works only in phone mode... Man Mad 

kj2112
I've Been Around
Posts: 1

Re: Froyo (2.2) on Captivate

I am glad some of you are enjoying 2.2..........myself, I am stuck still on conecting to device in Kies 1.5.3 hanging forever, I have spent 6 hours looking thru the web for fixes, done a bunch of stuff, and still back where I started.  And I know my stuff when it comes to phones and pc's.  Kies just doesn't wanna see my phone.  It does see it in media mode, but it says I have to go into kies mode, whatever that is.

 

I have tried every walk through and fix I can find on the web, and 6 hours later nothing.

 

Extremely ticked off...and just got my phone 3 days ago, so may just return it!  My wifes iphone was about 3 mouse clicks and her O/S was updated!!!!  

 

Rogers and Samsung have really made a mess!

BuckMacklin
I'm a Reliable Contributor
Posts: 172

Re: Froyo (2.2) on Captivate

Ok, lets go step by step.

 

Are you using the USB cable that came with the captivate?

 

When you plug it in do you see on the captivate screen a menu that allows you to select Keis mode?

 

Also shut off bluetooth when you do this.

 

 

okcoocoo
I've Been Here Awhile
Posts: 2

Re: Froyo (2.2) on Captivate

http://mobilesyrup.com/forum/showthread.php?t=5486

 

All updating help can be found there, GL!

BGrant
I Plan to Stick Around
Posts: 57

Re: Froyo (2.2) on Captivate

The proximity bug is horrible.  They need to fix it right away, and the code to fix it exists because it's been addressed in Gingerbread.