PVR Extenders/Expanders not working

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
Showing results for 
Search instead for 
Did you mean: 
I've Been Here Awhile
Posts: 3

PVR Extenders/Expanders not working




I have a SA8300HD PVR (160GB)  and to expand capacity for recording (shows we used to tape in SD by default now record automatically in HD with Roger’s  latest firmware upgrade  ) shows  just bought a Western Digital 1 TB DVR Expander eSATA Edition (EHDD)  from Best Buy .  Link to the product is below and this is a  product specialized for this purpose (from probably the leading HD manufacturer in North America) and works according to their site works with the SA8300HD     http://www.wdc.com/en/products/products.aspx?id=360


My issue is that this product does not work properly with the Rogers system. Once set up and formatted it is recognized by the PVR and records fine as along as it is back to back shows (such as 5 shows in a row). The problem occurs when you break that block (don’t schedule the next recording for another hour or 2) and the ehdd goes to sleep because of inactivity and energy efficiency purposes. For that next scheduled recording the PVR  red record light shows it as working but the PVR  does not send a proper signal to wake up the EHDD to actually make the recording hence nothing is recorded.

I did some googling and found some extensive discussions in other forums (links below)  on EHDD issues with PVRs and it seems to all be linked to the latest firmware upgrade done by Rogers in Nov/Dec before I ever bought my EDDD. Many used their own home built EHDD systems using western digital drives  that worked before the firmware change by Rogers that don’t work now with the same symptoms I have described.






The discussions indicate people are not getting answers from the Rogers CSRs when they report these issues and one moderator  indicated Rogers may be working on a fix but no guarantee if an when it would be done.


Rogers is selling their own PVR extenders (I believe they are Seagate) but at $249 for 1TB compared to the $127 I paid at Best Buy for the WD 1 TB DVR Expander it seems excessively expensive and I fear they will have the sleep/awaken issue as well.


The problem seems to be with Roger’s latest firmware upgrade not undergoing prior testing for EHDD expanders/extenders  before it was issued.  If the  Western Digital  1 TB DVR Expander works can work with hundreds of thousands of SA8300HD PVRs with Time Warner cable in the US it should work with the same PVR product here



 Does anybody have any more recent news or solutions/fixes on this EHDD  issue?






***Edited labels***

I've Been Around
Posts: 1

Re: PVR Extenders/Expanders not working

I have the same problem, with a Rogers PVR Extender; after the firmware upgrade I lost my recordings and the technical support took me step by step through the reset procedure and installing the extender, again.  It worked for the recording with tech support online, but there was no way to check whether that recording was to the hard drive on the pvr or the external drive.

Anyway, I have found that although it appeared to record over the past 3-1/2 weeks (red light and recordings in the memory index), we get the error when we try to play.  At the time of the tech support, I was told not to erase them because "they might come back"  meaning a fix was in the works?  Well, it's been over a month and I want my old firmware that works back.  She said that Rogers had no control over it, it was Cisco that did it remotely.  As far as I can tell, the external drive does not work with this firmware (note that here on the website they say the extender only works with the 8300HD model).  So, my pvr says 8300, but,

the firmware was changed.  So, Rogers, please restore it back to what I owned, please!  It was MINE!

Resident Expert
Resident Expert
Posts: 2,959

Re: PVR Extenders/Expanders not working

you can still record the shows in SD, just tune to the SD equivalent channel in the 100's other than that i dunno how to fix your external extender

I'm a Reliable Contributor
Posts: 115

Re: PVR Extenders/Expanders not working

turner -  We have the exact same model (purchased last August) and it has worked just fine since the update. I also hooked up one for my sister-in-law on Christmas Day and once again there are no issues. I wish I could offer you a solution, but I do know they will work. Unfortunately, since it is not a Rogers product, you are unlikely to get help from them. But as noted from another poster, even the Rogers expanders have had the same sort of issues since the firmware update.

I've Been Here Awhile
Posts: 3

Re: PVR Extenders/Expanders not working

I have been using an extender for over 2 years with no problem until this firmware *upgrade* .  Below is the reponse that I received from Rogers tech support when I contacted them:


Below is for non Rogers equipment


"We do not support equipment that has not been certified by Rogers and or is not on the Rogers Network. Unless otherwise specified by us, customers are responsible for updating and maintaining their equipment and software as necessary to meet our network requirements. Rogers does not provide customer support for equipment that is not certified for our network and that is not sold in our Retail or Authorized dealer locations. Please contact your equipment manufacturer for additional support."


Was not an issue before but now it appears you are compelled to buy Rogers.  Nice.

I've Been Around
Posts: 1

PVR Extender recordings no longer accessible !!!

I have a similar problem. PVR Explorer 8300HD and PVR Extender bought from Rogers.


Recently, probably since the PVR latest upgrade (Cisco software), all my recordings that were residing on the PVR Extender are not accessible anymore, they are still on the List, but once I try to play them, I just get the "Playback Channel". Recordings resident on the PVR can be played back quite ok.


I've done various full reboots of PVR and Extender, but it hasn't fixed the problem. The only  things I noticed is that judging by the available space, it seems that the PVR is treating the Extender  as completly empty!!!


I know latest recordings are resident on the PVR Extender, since my PVR was full when I bought the Extender, so everything that has been recorded recently has gone on the Extender.


I haven't called support, which I will, but I don't have high hopes they will be able to help me.


By the way, new recordings on the PVR Extender seem to be working fine.


Is there any hope? any suggestions?

I've Been Around
Posts: 1

Re: PVR Extender recordings no longer accessible !!!

I have the identical setup and situation as the last user Albatros.

PVR 8300HD and PVR Extender all bought from Rogers.

Trying to play back any recordings from the Extender greets me with failure and the Playback Channel.

Rebooted both devices 3 times with no change in the situation. While it is certainly not the first time an PVR "upgrade/ update" created a problem, it is the first time rebooting cannot resolve the mess.

Not impressed Rogers especially in lieu of the costs involved for buying the Extender in the first place via extortionist pricing.

Here's to hoping you get your act together and try to serve your customers...
I've Been Here Awhile
Posts: 3

Re: PVR Extenders/Expanders not working

Update to my original post re  Western Digital 1 TB DVR Expander not working with the SA8300HD PVR.


I called Rogers and they indicated they had not heard of any similar problems re expanders/extenders not working. I asked specifically if their own brand of extenders (overpriced) they are marketing were experiencing any problems and they said no.


I phoned Western Digital and spoke to a level 2 tech there and hesaid he had not heard of similar problems about comparatbility wit the SA8300HD PVR.


I ended up returnming the DVR expander to Best Buy - it is possible I just bought a dud but if some of the people posting here are experiencing problems with the Rogers Brand extenders (seagate) then something must be wrong - its just frustrating that Rogers is not acknowleding there is a probem - it would be easier to accept if they just said they were working on a fix to the software but no mention of that


The only way it will get fixed is if all people experiencing problems start calling Rogers



I'm Here A Lot
Posts: 5

Re: PVR Extenders/Expanders not working

I experienced the same problem with losing old programs recorded onto my extender, after their new CISCO firmware update in Nov/Dec.


I called into Rogers support and the CSR told me that they were aware of the problem and had other people calling in about it.  I didn't receive a callback on the ticket and had to follow up a couple of weeks later since it was still not resolved.  Got the same thing from the CSR.....they're aware of the problem and they're working on it.  No time for problem resolution.


This is totally unacceptable in my view.  The problem surfaced after they rolled out their new CISCO firmware update.  It's not rocket science to figure out that the firmware update caused the issues.


I'm at the point of cancelling my Rogers cable service and going with Bell if they do not get it rectified satisfactorily.


I had some programs recorded a couple of weeks ago and am unable to play it back now.  The customer service is terrible at Rogers and their firmware rollout was haphazard in my opinion.


I have been using an external PVR extender for over a year on the old firmware, and have not had any issues with it.  It worked quite well until the latest CISCO firmware rollout. 


My setup has a Vantec external SATA enclosure with a 1TB Seagate HD in it.


Rogers better step up with something better than their attempts at fluffing these problems off or they'll likely lose me as a client.  That's for cable and wireless!


I'm a Senior Advisor
Posts: 1,299

Re: PVR Extenders/Expanders not working

I've read that some people have resolved this issue by doing a full power cycle two times in a row.

Unplug the PVR for say 30 seconds. Plug it back in and let it boot up usually a few minutes. Then unplugging it again for 30 seconds then plugging it in again and letting it boot up.

I don't know why 2 in a row but it has worked for some people.