Outlook 2010 keeps asking for my password

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
I've Been Around
Posts: 1

Outlook 2010 keeps asking for my password

I recently upgraded my laptop & the new one has windows 8.  I got outlook 2010 set up ok & when I go to receive emails it says it's receiving them, but nothing goes in my inbox, junk or elsewhere.  I've sent test emails and checked my account via the online method and they are in my inbox, but when I use outlook to retrieve them again it says "receiving" but no new emails show up.

 

I've tried removing and recreating the account, but still have the same problem...

 

Here are my settings ...

Incoming: pop.broadband.rogers.com

Incoming server: 110

Outgoing: smtp.broadband.rogers.com

Outgoing server:25

 

I can't seem to send from outlook as well.

I've been fighting with this for a week. Any help would be greatly appreciated.

 

Thanks

 

 

***edited labels***

 

 

Solved! Go to Solution.

Accepted Solutions
Highlighted
I'm a Trusted Contributor
Posts: 350

Re: Outlook 2010 keeps asking for my password

Please make sure you have an option "My outgoing server (SMTP) requires authentication" checked and use the same user name and password.

 

Also change your outgoing mail server port to 587 without any encryption.

___________________

Updated Solution : Here is a quick link on the complete settings for Outlook 2010 with your Rogers Email. Outlook 2010

 

 

 

View solution in original post


All Replies
Highlighted
Resident Expert
Resident Expert
Posts: 2,670

Re: Outlook 2010 keeps asking for my password

try logging into the yahoo mail site with your rogers email and pass and see what error message it gives?



Highlighted
I'm a Trusted Contributor
Posts: 350

Re: Outlook 2010 keeps asking for my password

Please make sure you have an option "My outgoing server (SMTP) requires authentication" checked and use the same user name and password.

 

Also change your outgoing mail server port to 587 without any encryption.

___________________

Updated Solution : Here is a quick link on the complete settings for Outlook 2010 with your Rogers Email. Outlook 2010

 

 

 

View solution in original post