cancel
Showing results for 
Search instead for 
Did you mean: 

Not getting HD quality signal

GoJule
I've Been Here Awhile

I just recently went to Rogers store and picked up 2 new cable boxes so I could get HD for a new 52" LCD TV. I have connected the box via HDMI to the TV and the quality of the picture is awful, only SD. I have set the settings to 1080i and I am not zoomed in. Is there something Rogers has to do so that i can receive HD quality viewing or is there any other issues anyone can think of? Very frustrating. I have the new tv and my older one both connected to the new boxes and I am getting only SD quality on both so I know it's the TV.

 

Any help would be appreciated.

 

Thanks 

 

 

***Edited labels***

12 REPLIES 12

Re: Not getting HD quality signal

Meowmix
I'm a Trusted Advisor
Hello GoJule

Rogers has a few HD channels. Most of the channels Rogers has are still on SD that is why you are seeing them as SD still.

Re: Not getting HD quality signal

mousetamer
I'm a Trusted Contributor
Is this the first time for you with the HD service? In case it is, you may not be aware that not all channels are HD yet. The ones that are offered in HD are grouped together between 490-600. Some are also set up for auto HD on the lower channel numbers which means that they will show you the HD version if available. Also, not all shows are HD yet. There will be times when an HD channel will broadcast SD content. When you get a chance, try watching some of the channels in the 500s and tell us if you are still getting SD. Lastly, make sure the Rogers box only has 3 cables hooked up to it. They should be power, HDMI, and cable in. Sometimes the boxes do weird things when you have more cables plugged in. BTW, I'm assuming you have the Cisco boxes with the new guide.

Re: Not getting HD quality signal

GoJule
I've Been Here Awhile

Hi thank you both  for the quick response. Yes it is the new Cisco cable boxes I have. I had HD about 8 months ago. We downgraded to basic cable to save some money and just yesterday wanted to go back to HD. The HD I had previously was perfect and stunningly clear. This time however, on both TV's, the picture is awful even on the 500 series channels. Does Rogers have to do anything outside myhome to receive an HD signal? I am so confused as to why this is happening. When I last had HD I received HD quality on both 500 and lower end channels. Now both are no better than when we just had SD.

 

Thanks

 

Re: Not getting HD quality signal

Gdkitty
Resident Expert
Resident Expert

Did you have the older HD boxes bofore, and the newer ones now? Or did you have the newer before as well?

The newer boxes, and newer guide, ARE more sensitive to signal issues than the older ones.. but those normaly equate to choppy video, pixelization, audio issues, etc.  Shouldnt be a QUALITY thing.

 

I am running 2 HD cisco boxes and one HD cisco PVR, and all of them are outputing HD correctly.. so unless the boxes are potentialy buggered?

What plan are  you on now?



Re: Not getting HD quality signal

GoJule
I've Been Here Awhile

Hi I had the older box before. I am on the Digital VIP plan.

 

Thanks

 

Re: Not getting HD quality signal

Gdkitty
Resident Expert
Resident Expert

Hmm.. so same plan as me.. and i know mine come in HD fine.

 

Unless there is a setting somewhere we missed.. on the HD box, you said you moved it up to 1080i, so that should be it.

 

Unless its a tv setting?



Re: Not getting HD quality signal

mousetamer
I'm a Trusted Contributor
Just for kicks, if it is set to 1080i, change the resolution to something else and save it. Then go back and put it back to 1080i and save it again.

Re: Not getting HD quality signal

you can also try power cycling it,  what  hd channels are you watching? does the channel fill in the entire tv screen?  how is the cable box hooked up to your tv? with hdmi/component or with composite video cables?



Re: Not getting HD quality signal

danielao
I've Been Here Awhile

I'm going to launch my Rogers box off the balcony...

 

Someone tell me why if I turn from a SD channel to an HD channel, the HD channel flickers on and off, or just completely lose signal for minutes at a time.

 

 

Re: Not getting HD quality signal

mousetamer
I'm a Trusted Contributor

If your box is not actually broken or your signal is not the culprit, try setting the box output to 1080i fixed. That will cut down on what the box has to process in terms of the broadcast formats. Also, a lot of TVs cause this "lag" issue. Sharp, for example, is very slow to sync with what the box outputs compared to Samsung, Sony, Panasonic, or LG. Finally, if you have a AV receiver in the mix, that too can cause this issue.

Re: Not getting HD quality signal

mousetamer
I'm a Trusted Contributor

So did it work?

Re: Not getting HD quality signal


@danielao wrote:

I'm going to launch my Rogers box off the balcony...

 

Someone tell me why if I turn from a SD channel to an HD channel, the HD channel flickers on and off, or just completely lose signal for minutes at a time.

 

 


we would need a little more info on what box, what guide, etc you are using danielao.

with the old guide, it switches between 480i and 1080i between SD and HD channels.  I have seen/heard with some TV's this does not play nice.. the TV doesnt pick up on the mode switch properly.  I know on my old box , with my old TV, you would audibly hear a click from the TV as it switched modes.



Topic Stats
  • 12 replies
  • 2659 views
  • 0 Likes
  • 6 in conversation