No internet connection on one device since upgraded to windows 8.1

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Vallleee
I've Been Here Awhile
Posts: 2

No internet connection on one device since upgraded to windows 8.1

I know our Hub is working fine since I am able to access the internet perfectly on my husbands laptop, my tablet,  phones etc,

but the laptop I use to do books updated to windows 8.1 and now I have no network connection.

I know this is an issue all over the web as a simple google search yeilds hundreds of complaints...

Surely someon hereusing Rogers has encountered similar issue?

 

We have a ZTE MF28b hub and the laptop in question is only a year old Acer....

 

Any advice would be greatly appreciated, I cannot connect to internet with it at all!

 

 

***Edited Labels***

 

RogersMoin
Moderator
Moderator
Posts: 1,975

Re: No internet connection on one device since upgraded to windows 8.1

Hello @Vallleee , Welcome to Rogers Community Forum!Smiley Happy

 

Sorry for the Wi-Fi connection issues on your Win 8.1 laptop, our community has lot of expertise to share and resolve your issue. If your Laptop was connecting before and stopped after the update, please try the below suggestions;

 

  • Sometimes when there is any Windows update, it may disable WLAN adapter, would you please confirm if it’s enabled?
  • If WLAN adapter is enabled, are you able to see your network name (SSID)?
  • If you see your network name, would it say, Windows was unable to connect to network?
  • Would you please try removing/deleting your network and try re-connecting to it?
  • Not sure of your network configuration, are you using WPA2, AES combination? Just for testing you may want to try WPA, TKIP. And then test to see if your Laptop connects
  • With Win8.1 installed now, you may want to try updating the WLAN adapter drivers

 

Community, please chime in with more ideas, thank you all!

 

Thanks,

RogersMoin

Datalink
Resident Expert
Resident Expert
Posts: 7,325

Re: No internet connection on one device since upgraded to windows 8.1

When you ran the upgrade, did you follow up and load the Windows 8.1 drivers?  I never assume that Windows will do that on its own.  I think usually it will use generic drivers instead of the drivers supplied by the pc or laptop manufacturer.

 

When you go to connect to the hub, does the laptop see the hub network in the list of networks that are broadcasting?  And, if it does and you go to connect to it, and enter the passphrase for the network, what happens next?

 

You could load inSSIDer on the laptop which is a wifi monitoring program just to confirm that yes, the laptop wifi card can detect the hub and other networks that are running.  Here is a link to the last freebie version of inSSIDer.  The Network display contains a network list and graphical display that will confirm in a matter of seconds if the wifi card is detecting the local networks.

 

http://www.techspot.com/downloads/5936-inssider.html

 

You could try something a little goofy, and that would be to download the Windows 7 driver for the wifi card from the Acer site.  At the same time, download the Windows 8.1 driver as well to reload it if this doesn't turn out.  When you have those available on the laptop, unload the Windows 8.1 driver.  Reboot the laptop and load the Windows 7 driver.  The operating system may automatically reload the Windows 8.1 driver following the reboot.  If so, such is life.  Go ahead and run the install for the Windows 7 driver in that case and if you end up with a warning that the installed driver is newer, keep loading the Windows 7 driver.  Once done, reboot.

 

Following the reboot, try to connect to the hub and see how it turns out.

 

We have an Acer laptop for which I swapped out the hard drive for an SSD and did a clean install of Windows 8.1.  We didn't have any issues with wifi connectivity at all.



Vallleee
I've Been Here Awhile
Posts: 2

Re: No internet connection on one device since upgraded to windows 8.1

Thank you for the quick responses!

I have lots of options to try now, if I can hard wire the laptop to the Hub to even get online 🙂

O will wait for hubby to get home and help with this, but will let you know what the outcome is.

 

Thanks again

Datalink
Resident Expert
Resident Expert
Posts: 7,325

Re: No internet connection on one device since upgraded to windows 8.1

Does the laptop have an ethenet port?  Our Acer doesn't.  We use a gigabit to USB 3.0 adapter if we want to plug the Acer into the network.  Here's an example:

 

http://www.canadacomputers.com/product_info.php?cPath=1336_96&item_id=056527