Nextbox slow to change channels and no program info displayed

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I've Been Here Awhile
Posts: 2

Nextbox slow to change channels and no program info displayed

Just got a new NextBox and set it up...immediately noticed long time to display a program after switching channels...up to 1 minute.

Also, no program info is displayed as it states LOADING, which takes forever...

Is it normal? What is to be done, if anything?

 

 

 

***Edited labels***

 

Highlighted
I'm a Trusted Advisor
Posts: 32,096

Re: Nextbox slow to change channels and no program info displayed

Hello igbusy


I am guessing you have the NextBox 2.0 aka 8642 box? That box always had that even with the new updates it has. Nothing can be done unfortunately.


The NextBox 3.0 is faster and doesn't have slow responses. If you want, upgrade to that one.
Highlighted
I've Been Here Awhile
Posts: 2

Re: Nextbox slow to change channels and no program info displayed

Thanks Meomix.

 

I just got this box from Rogers...do they provide 2.0 or 3.0...how I ask them for 3.0? Buy? Or just tell them I want 3.0?

 

Cheers

 

Isaac

Highlighted
Resident Expert
Resident Expert
Posts: 14,254

Re: Nextbox slow to change channels and no program info displayed

I agree.. if you got a NB2 (8642), you would be better to swap to a NB3.
you should be able to go to a store and swap, etc.. they will change the necessary stuff around on your plan.
or call in, and they can arange for a tech to come out and swap one for the other.

 

As well.. if the box it JUST plugged in.. it might take a bit for it to finish pulling all the data in.
Beyond that.. did you have a box at all, etc there before?
If not.. if the signal is not up to par to that jack, etc.. it can cause comunication issues, which could cause it to fail to load guide information, have channel problems, etc.

 

Might be worth the tech out anyways.. to check the signals, etc.



Highlighted
I'm a Trusted Advisor
Posts: 32,096

Re: Nextbox slow to change channels and no program info displayed

Hello igbusy

You could go to the store and have then exchange it for a 3.0 box. Just ask them to do it and they will if they have any in Stock.


It could well be a signal issue outside or inside but do the exchange first and see. If that doesn't fix it, then call Rogers and get a tech out to see what's going on
I'm a Trusted Contributor
Posts: 694

Re: Nextbox slow to change channels and no program info displayed

I have the 8642 HDPVR (not nextbox) and have not experienced anything like what you describe. So yeah, either try exchanging it or try a reboot.
Highlighted
I'm a Trusted Advisor
Posts: 32,096

Re: Nextbox slow to change channels and no program info displayed

Hello jays77

 Rogers 8642 box is rebranded as the NextBox 2.0.  Just the box model number is 8642. Unless you bought a 8642 which isn't from Rogers but i doubt it as Rogers won't be able to activate it.

Highlighted
I'm a Trusted Contributor
Posts: 694

Re: Nextbox slow to change channels and no program info displayed

That's what I thought and yes it is from Rogers and has for the most part work well. Some things can be a bit sluggish at times but never near a bad as the OP related.
Highlighted
I'm a Trusted Advisor
Posts: 32,096

Re: Nextbox slow to change channels and no program info displayed

Hello jays77

Yeah its a NextBox 2.0 aka 8642 box then. Some box's may not have the same issue but some do. It's normal with any electronic
Highlighted
I Plan to Stick Around
Posts: 25

Re: Nextbox slow to change channels and no program info displayed

FIrst, I have to ay this website  is a perfect reflection of my experience with Rogers. It is slow, frustrating and full of glitches.  Just logging in is sometimes so problematic I give up.

 

I am a new Rogers customer.  And I am not happy.  It is day 5 and now I was having the same problem as the OP.  My channel changing was largely unresponsive.  Sometimes it took LITERALLY one minute for a simple channel bump of one channel, like going from Channel 2 to 3.  And my guide said "No Information".  I did a reboot as mentioned here and the problem is fixed, but WTH?  I don't want to have to do this every 5 days.  And....

 

Even now the channel changes and remote functions are hardly snappy.  You press a button and LITERALLY about half a second later something happens.  Which is fine.  If this were 1979!  Is there a way to make things work faster?  (Maybe a firmware update or something?)

 

Frustratingly Yours,

Matt