Myrogers

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Resident Expert
Resident Expert
Posts: 6,942

Re: Myrogers

Nope, your not hallucinating.  Does almost the same for me using Firefox.  I don't have the name and password stored.  The instant that I type the first character in the in the username entry field the login page refreshes, after which the username field is empty again, so, I end up restarting the login again.  And, sometimes, but not every time, when it starts the login process I get the never ending screen telling me that the services are loading, or whatever the wording is.  When that happens I bail out of Firefox and switch to Chrome.  In the past this was never an issue.  I guess this is what you would call progress 😞



Highlighted
I'm a Senior Advisor
Posts: 3,668

Re: Myrogers

Yes,  I've also seen the perpetual services loading screen a few times. Now when I click My Rogers to open in a new tab I see Account Overview with nothing there and no account number in the dropdown box.  I click BILLING & PAYMENT and I get the screen with exclamation marks I posted above. The only way I can get anything is by clicking PROFILE and then from there i can just get the old BILLS & PAYMENTS page. Yes, something is royally screwed up.


LG-E410B PayGo. Location: S-W Ontario
Highlighted
I'm a Senior Advisor
Posts: 3,668

Re: Myrogers

No change this morning. Another thing I've noticed is previously whenever I signed into My Rogers I was presented with a popup to choose either my Cable or Paygo account number. It didn't matter which one I chose. Then, lately, it changed the number in the dropdown to that number. Now I don't get the popup and the dropdown box is blank.


LG-E410B PayGo. Location: S-W Ontario
Highlighted
I'm a Senior Contributor
Posts: 152

Re: Myrogers

@OLDYELLR

 

Last night, I was checking my e-mail and I got the one from Rogers teling me that my bill was available online.  This was on my Win 7 machine.  I clicked the link to view my bill, and Firefox opened and I was able to sign on and get a proper Myrogers page.  I was hoping that meant everything was fixed or there was something special about the link in the e-mail that fixed the issue.  I forwarded the e-mail to my Gmail account so I could try it in the morning on my Macbook.

 

This morning I tried the link on the Macbook, which brought up Chrome browser and it looked like it might work, but then I got this message:

 

400 Bad Request...Check your PC and browser settings.

 

I copied the original link to Firefox, and got the same problem as before.

 

I had already tried deleting cookies for rogers.com on Firefox and it made no difference.  I'll try again because it seems to work with the machine that I rarely use to access Rogers, so maybe there is something in the cache that is contributing to the problem.

 

So I went to Firefox preferences and deleted cookies, cache, history, etc. for today only and then brought up Rogers.com and was able to sign on and get a proper page.  The account popup showed up again, and I have a list of accounts in the dropdown.  I don't know what changed last week, but it is probably a cached page, since deleting cookies before had no effect.

 

View solution in original post

Highlighted
I'm a Senior Advisor
Posts: 3,668

Re: Myrogers

@roxandtreez thanks for the tip. I deleted recent history and Rogers cookies in Firefox and it's back to normal and My Rogers works. I can view both my Cable bills and PayGo transctions.

 


LG-E410B PayGo. Location: S-W Ontario
Highlighted
I'm a Senior Contributor
Posts: 152

Re: Myrogers

@OLDYELLR  The strange thing is that after I go to sign in a second time, I get the "account locked" page flashing by, but I can still sign on and get the full functionality.  It seems that there are two issues - one is causing the "account locked" page to flash by, even before signing in, and a problem with a cached file which causes the MyRogers page to fail and give no data.

Highlighted
I'm a Trusted Contributor
Posts: 766

Re: Myrogers

@OLDYELLR....  you seem to be a generous  soul !   I see you're up to 1500 posts and I have to wonder if you got minimum wage  for all thetime spent with problems  that you seem to have helped Rogers resolve , how much have your plans really cost you? 

I realize that some likely enjoy the puzzle but there must be a significant number that just get peeved when Rogers seems to have such challenges  and end up wasting so much customer time. 

 

 

Highlighted
I'm a Senior Advisor
Posts: 3,668

Re: Myrogers

I'm retired, with lots of time on my hands, so I'm here a lot. No great expert, but I've been a computer nerd since the 1980s.


LG-E410B PayGo. Location: S-W Ontario
Highlighted
I'm a Trusted Contributor
Posts: 224

Re: Myrogers

Im still having the same issue 😞
Highlighted
I'm a Trusted Contributor
Posts: 766

Re: Myrogers

Yup ... mine did to 

 

Set the screen zoom back to 75% and tried again and it worked fine. 

I can only assume that Rogers feels it is a lot easier to put one over on you if the print is so small you can't read it.  Smiley Mad

Just like the fine print and sidenotes on all their advertising .   Smiley Sad