cancel
Showing results for 
Search instead for 
Did you mean: 

Myrogers

jkroesen
I'm a Trusted Contributor

Anyone else having an issue with Myrogers.com this morning? Mine isn't showing anything...

 

Pretty much a blank page...

 

Say's account over view but no services are showing 

 

Billing & Payment is empty 

 

the only page working is account profile... 

 

 

****Edit Labels****

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Myrogers

roxandtreez
I'm a Senior Contributor

@OLDYELLR

 

Last night, I was checking my e-mail and I got the one from Rogers teling me that my bill was available online.  This was on my Win 7 machine.  I clicked the link to view my bill, and Firefox opened and I was able to sign on and get a proper Myrogers page.  I was hoping that meant everything was fixed or there was something special about the link in the e-mail that fixed the issue.  I forwarded the e-mail to my Gmail account so I could try it in the morning on my Macbook.

 

This morning I tried the link on the Macbook, which brought up Chrome browser and it looked like it might work, but then I got this message:

 

400 Bad Request...Check your PC and browser settings.

 

I copied the original link to Firefox, and got the same problem as before.

 

I had already tried deleting cookies for rogers.com on Firefox and it made no difference.  I'll try again because it seems to work with the machine that I rarely use to access Rogers, so maybe there is something in the cache that is contributing to the problem.

 

So I went to Firefox preferences and deleted cookies, cache, history, etc. for today only and then brought up Rogers.com and was able to sign on and get a proper page.  The account popup showed up again, and I have a list of accounts in the dropdown.  I don't know what changed last week, but it is probably a cached page, since deleting cookies before had no effect.

 

View solution in original post

20 REPLIES 20

Re: Myrogers

barndoor
I'm a Trusted Contributor

OOOh    .... be patient   @jkroesen .... maybe it will be all new and improved when it comes back ...  Smiley LOL

 

again ....Smiley LOL

Re: Myrogers

roxandtreez
I'm a Senior Contributor

@jkroesen  I saw the same thing when I logged in to get to the forums this afternoon.  I have no accounts any more (had 4).

Re: Myrogers

roxandtreez
I'm a Senior Contributor

MyRogers is still not displaying anything today.  I noticed that after entering the sign-on information, a page flashed up for less than a second which appears to have information (possibly an error), but it went by too fast to read except for "this account".  Can @CommunityHelps address this issue for me, or should I be phoning the problem in?

Re: Myrogers

Good afternoon @roxandtreez,

 

I am sorry for the issues you have been experiencing with your online profile.

I'd love to help out!

Allow me a few minutes, I will reach out to you directly via Private Message, from @CommunityHelps.

 

Keep an eye on your inbox Smiley Wink

 

RogersMaude

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

@roxandtreez wrote:

MyRogers is still not displaying anything today.  I noticed that after entering the sign-on information, a page flashed up for less than a second which appears to have information (possibly an error), but it went by too fast to read except for "this account".  Can @CommunityHelps address this issue for me, or should I be phoning the problem in?


I've been seeing a strange screen flash when I sign in, but too quick to read. When I clicked My Rogers to open in a new tab I got pretty much nothing and clicking Billing & Payment, I got this:

 

Clipboard01.jpg

That's similar to the screen I saw flash signing in, except that one had text where the (!)'s are. However, when I clicked PROFILE and then BILLS & PAYMENTS, I got my account information. It seems going via my PROFILE page cures a lot of things, such as not being able to sign into the Forum.


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

I managed to capture the screen that flashed just before my login screen. Very strange. Maybe my browser is too slow inserting my username and password.

 

Clipboard01.jpg


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

Okay, just to clarify in order to get to the bottom of getting to the "BILLING & PAYMENT" page, the one where you can see a pdf of your bill. That's the one I'm not able to get to anymore and displays blank boxes with (!)'s in them as pictured a couple of poats back.

 

There is another, older, page I can get to by going through PROFILE, which is called "BILLS & PAYMENTS" but will not show me a pdf of my cable bill, but it will show me my Paygo call transactions after I choose my cell number from the dropdown.

 

It seems Rogers has had these two parallel, but different, pages going for the last few months and now the newer one is broken.  I need them both to see my Paygo calls and my Cable bill, even though they both let me choose which account. It's almost as if two different teams had been working on these pages with the right hand not knowing what the left hand was doing.


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

roxandtreez
I'm a Senior Contributor

@OLDYELLR  That is exactly the page that flashes past before I log in.  I don't know how you managed to capture it, but thanks for that.  It proves that (in this case anyway) I am not hallucinating.

 

One question - do you have your browser automatically provide the userid and password, or do you key them in every time.  I have them saved in my  browser.  Just wondering if that has any effect.

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

Yes. My browser has my username and password saved for Rogers. That screen flashes right after it asks for my username and password and before Firefox enters it. i've only been seeing it the last couple of days I think.


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

Nope, your not hallucinating.  Does almost the same for me using Firefox.  I don't have the name and password stored.  The instant that I type the first character in the in the username entry field the login page refreshes, after which the username field is empty again, so, I end up restarting the login again.  And, sometimes, but not every time, when it starts the login process I get the never ending screen telling me that the services are loading, or whatever the wording is.  When that happens I bail out of Firefox and switch to Chrome.  In the past this was never an issue.  I guess this is what you would call progress 😞



Re: Myrogers

OLDYELLR
I'm a Senior Advisor

Yes,  I've also seen the perpetual services loading screen a few times. Now when I click My Rogers to open in a new tab I see Account Overview with nothing there and no account number in the dropdown box.  I click BILLING & PAYMENT and I get the screen with exclamation marks I posted above. The only way I can get anything is by clicking PROFILE and then from there i can just get the old BILLS & PAYMENTS page. Yes, something is royally screwed up.


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

No change this morning. Another thing I've noticed is previously whenever I signed into My Rogers I was presented with a popup to choose either my Cable or Paygo account number. It didn't matter which one I chose. Then, lately, it changed the number in the dropdown to that number. Now I don't get the popup and the dropdown box is blank.


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

roxandtreez
I'm a Senior Contributor

@OLDYELLR

 

Last night, I was checking my e-mail and I got the one from Rogers teling me that my bill was available online.  This was on my Win 7 machine.  I clicked the link to view my bill, and Firefox opened and I was able to sign on and get a proper Myrogers page.  I was hoping that meant everything was fixed or there was something special about the link in the e-mail that fixed the issue.  I forwarded the e-mail to my Gmail account so I could try it in the morning on my Macbook.

 

This morning I tried the link on the Macbook, which brought up Chrome browser and it looked like it might work, but then I got this message:

 

400 Bad Request...Check your PC and browser settings.

 

I copied the original link to Firefox, and got the same problem as before.

 

I had already tried deleting cookies for rogers.com on Firefox and it made no difference.  I'll try again because it seems to work with the machine that I rarely use to access Rogers, so maybe there is something in the cache that is contributing to the problem.

 

So I went to Firefox preferences and deleted cookies, cache, history, etc. for today only and then brought up Rogers.com and was able to sign on and get a proper page.  The account popup showed up again, and I have a list of accounts in the dropdown.  I don't know what changed last week, but it is probably a cached page, since deleting cookies before had no effect.

 

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

@roxandtreez thanks for the tip. I deleted recent history and Rogers cookies in Firefox and it's back to normal and My Rogers works. I can view both my Cable bills and PayGo transctions.

 


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

roxandtreez
I'm a Senior Contributor

@OLDYELLR  The strange thing is that after I go to sign in a second time, I get the "account locked" page flashing by, but I can still sign on and get the full functionality.  It seems that there are two issues - one is causing the "account locked" page to flash by, even before signing in, and a problem with a cached file which causes the MyRogers page to fail and give no data.

Re: Myrogers

barndoor
I'm a Trusted Contributor

@OLDYELLR....  you seem to be a generous  soul !   I see you're up to 1500 posts and I have to wonder if you got minimum wage  for all thetime spent with problems  that you seem to have helped Rogers resolve , how much have your plans really cost you? 

I realize that some likely enjoy the puzzle but there must be a significant number that just get peeved when Rogers seems to have such challenges  and end up wasting so much customer time. 

 

 

Re: Myrogers

OLDYELLR
I'm a Senior Advisor

I'm retired, with lots of time on my hands, so I'm here a lot. No great expert, but I've been a computer nerd since the 1980s.


Rogers PayGo. Location: S-W Ontario

Re: Myrogers

jkroesen
I'm a Trusted Contributor
Im still having the same issue 😞

Re: Myrogers

barndoor
I'm a Trusted Contributor

Yup ... mine did to 

 

Set the screen zoom back to 75% and tried again and it worked fine. 

I can only assume that Rogers feels it is a lot easier to put one over on you if the print is so small you can't read it.  Smiley Mad

Just like the fine print and sidenotes on all their advertising .   Smiley Sad

 

 

Re: Myrogers

jkroesen
I'm a Trusted Contributor
All seems good today with MY rogers!
Community Testing Lab

We’ve got an amazing opportunity to test our upcoming Gateway!

Click here to find out more!

Topic Stats
  • 20 replies
  • 2746 views
  • 6 Likes
  • 6 in conversation