MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

Need Help?

That's what we're here for! The goal of the Rogers Community is to help you find answers on everything Rogers. Can't find what you're looking for? Just ask!
cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
I Plan to Stick Around
Posts: 8

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

Check my post up above ... my issue had to do with an app called Onavo installed on my phone.  Onavo helps reduce data usage, and something about this app was thwarting the MyAcct app from authenticating me.  Once I removed it, MyAcct worked.

 

 

Highlighted
I Plan to Stick Around
Posts: 66

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

Are you guys on the 6GB plan ? If yes then that's the reason.

Rogers cannot display the data usage for the 6 GB for the past 2 months. They are working on it but the issue not just proxies. android phone are also affected.
Highlighted
I Plan to Stick Around
Posts: 9

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

that explains a lot! I was wondering why everything would display but the usage for my data would not :S

Highlighted
I'm Here A Lot
Posts: 7

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

Uh.. I'm on the 1GB plan.. still can't see my data usage ever since I had my plan changed.

Highlighted
I Plan to Stick Around
Posts: 58

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

Nope. That's not the case. I have the 6 GB plan and the data usage shows up fine. I think MyAccount app is buggy. Just like I cant see when my credits expire online or why I get billed for overage on SMS when I only texted 50/2500 text messages during the billing period. Rogers' system is freaken messed up.
Highlighted
I Plan to Stick Around
Posts: 66

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem


@Hmm wrote:
Nope. That's not the case. I have the 6 GB plan and the data usage shows up fine. I think MyAccount app is buggy. Just like I cant see when my credits expire online or why I get billed for overage on SMS when I only texted 50/2500 text messages during the billing period. Rogers' system is freaken messed up.

Did your plan change in the last 2-3 months ?

 

I think the whole is issue is based on a data plan changed and not actuall the plan your on (6GB or 1GB or 500MB)

Highlighted
I've Been Here Awhile
Posts: 4

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

MyAccount App has always 100% worked for me. on the 6 GIG plan with iphone 3gs. So it is possible:)

Highlighted
I'm a Trusted Advisor
Posts: 32,019

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

Mine just shows " details not Available at this time" for the past 3 months..

Highlighted
I Plan to Stick Around
Posts: 58

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

 

Did your plan change in the last 2-3 months ?

 I think the whole is issue is based on a data plan changed and not actuall the plan your on (6GB or 1GB or 500MB)

 

That's as good of a guess as any, but no. Not so in my case. The only thing that changed in the last few months was the acquisition of the data plan. Like the previous poster stated, he has the same problem. 

 

"My Rogers" is very flaky.  It would be reassuring at the very least, if Rogers posts a listing of current issues with their website. Unfortunately, many organizations and managers in charge don't subscribe to admitting/acknowledging problems or issues because in their mind, they feel it shows weakness or inferiority.

Highlighted
I'm Here A Lot
Posts: 5

Re: MyAccount App hasn't worked in WEEKS! Will not authenticate ... anyone else have this problem

I have the same problem ... open a ticket with customer service and called back a couple of time and someone told me that they were experiencing problem with this app? But it is still not working and no one seems to be doing anything about it?