cancel
Showing results for 
Search instead for 
Did you mean: 

Mobile data disconnected

Psutcliffe
I've Been Around
I recently got and unlocked a new HTC One M9 originally set up for Telus. My old phone was a nice HTC One M8. When I put the sim card in the new phone it recognizes it and I can make calls but it says my mobile data is disconnected and nothing shows up when I check the APN's. I'be tried resetting, restoring, shutting off and what not with no success. Any thoughts?
3 REPLIES 3

Re: Mobile data disconnected

RogersArthur
Retired Moderator
Retired Moderator

Hi @Psutcliffe

 

Sorry to hear about your issue with the unlocked HTC One M9 not connecting to our Rogers data services. You just need to add some required APN settings.

 

Try following these steps (may vary by model)
1. Open Applications.
2. Select Settings.
3. Select mobile data or mobile networks settings.
4. Select APN's.
5. Select the Menu key (vertical dots upper right)
6. Select New APN.
7. Add and save the following APN settings:
Name: Rogers
APN: rogers-core-appl1.apn
Username: wapuser1
Password: wap

 

Here's a link to some other Rogers APN settings which might be useful.


 
@RogersArthur

Re: Mobile data disconnected

Ambi
I've Been Around
Ditto. Tried apn suggestion. Didn't work. Link to other apn suggestions dead. Any other options?

Re: Mobile data disconnected

Hi @Ambi

 

Welcome to the Community Forums!

 

Take a look at our How To on APN Settings here

 

Let us know if that helps!

 

 

@RogersPrasana

We Want Your Opinion
Would you be interested in becoming a Community Testing Lab member?
Topic Stats
  • 3 replies
  • 12576 views
  • 0 Likes
  • 4 in conversation